diff options
author | Paul Eggleton <paul.eggleton@linux.intel.com> | 2012-10-28 13:49:59 +0000 |
---|---|---|
committer | Paul Eggleton <paul.eggleton@linux.intel.com> | 2012-10-28 14:32:06 +0000 |
commit | 3a30c562385cb3d9cd1b3043f6fe677a22024018 (patch) | |
tree | 66dc67f338ba316c25ca672950ef334e9e357386 /meta-oe/recipes-devtools | |
parent | d66c9a8b625f7b19f7b17e728dc82413399c2e19 (diff) | |
download | meta-openembedded-3a30c562385cb3d9cd1b3043f6fe677a22024018.tar.gz |
Replace bb.data.* with d.*
Used sed expression given here:
http://lists.linuxtogo.org/pipermail/openembedded-core/2011-November/012373.html
Plus an additional expression for .expand. Full expression is:
sed \
-e 's:bb.data.\(setVar([^,]*,[^,]*\), \([^ )]*\) *):\2.\1):g' \
-e 's:bb.data.\(setVarFlag([^,]*,[^,]*,[^,]*\), \([^) ]*\) *):\2.\1):g' \
-e 's:bb.data.\(getVar([^,]*\), \([^, ]*\) *,\([^)]*\)):\2.\1,\3):g' \
-e 's:bb.data.\(getVarFlag([^,]*,[^,]*\), \([^, ]*\) *,\([^)]*\)):\2.\1,\3):g' \
-e 's:bb.data.\(getVarFlag([^,]*,[^,]*\), \([^) ]*\) *):\2.\1):g' \
-e 's:bb.data.\(getVar([^,]*\), \([^) ]*\) *):\2.\1):g' \
-e 's:bb.data.\(expand([^,]*\), \([^ )]*\) *):\2.\1):g' \
-i `grep -ril bb.data *`
Some minor correction in systemd.bbclass was needed for some expressions
that didn't quite match the regex in the desired way; additionally a few
instances were manually changed.
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r-- | meta-oe/recipes-devtools/libcanberra/libcanberra_0.26.bb | 2 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/libgee/libgee_0.6.4.bb | 2 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/orc/orc.inc | 2 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/vala/vala.inc | 2 |
4 files changed, 4 insertions, 4 deletions
diff --git a/meta-oe/recipes-devtools/libcanberra/libcanberra_0.26.bb b/meta-oe/recipes-devtools/libcanberra/libcanberra_0.26.bb index c2f1cc82e..8b796ac67 100644 --- a/meta-oe/recipes-devtools/libcanberra/libcanberra_0.26.bb +++ b/meta-oe/recipes-devtools/libcanberra/libcanberra_0.26.bb | |||
@@ -29,7 +29,7 @@ EXTRA_OECONF = "\ | |||
29 | # enable pulse again when pulseaudio >= 0.9.11 is the default in OE | 29 | # enable pulse again when pulseaudio >= 0.9.11 is the default in OE |
30 | 30 | ||
31 | python populate_packages_prepend() { | 31 | python populate_packages_prepend() { |
32 | plugindir = bb.data.expand('${libdir}/${P}/', d) | 32 | plugindir = d.expand('${libdir}/${P}/') |
33 | do_split_packages(d, plugindir, '^libcanberra-(.*)\.so$', 'libcanberra-%s', '%s support library', extra_depends='' ) | 33 | do_split_packages(d, plugindir, '^libcanberra-(.*)\.so$', 'libcanberra-%s', '%s support library', extra_depends='' ) |
34 | } | 34 | } |
35 | 35 | ||
diff --git a/meta-oe/recipes-devtools/libgee/libgee_0.6.4.bb b/meta-oe/recipes-devtools/libgee/libgee_0.6.4.bb index a6044cdf3..fbd14662f 100644 --- a/meta-oe/recipes-devtools/libgee/libgee_0.6.4.bb +++ b/meta-oe/recipes-devtools/libgee/libgee_0.6.4.bb | |||
@@ -4,7 +4,7 @@ PR = "${INC_PR}.2" | |||
4 | DEPENDS += "gobject-introspection-stub" | 4 | DEPENDS += "gobject-introspection-stub" |
5 | DEPENDS_virtclass-native += "gobject-introspection-stub-native" | 5 | DEPENDS_virtclass-native += "gobject-introspection-stub-native" |
6 | 6 | ||
7 | SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}" | 7 | SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}" |
8 | SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libgee/${SHRT_VER}/${BP}.tar.xz" | 8 | SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libgee/${SHRT_VER}/${BP}.tar.xz" |
9 | SRC_URI[md5sum] = "a32bf498cf33d5e3417823a7b252ad22" | 9 | SRC_URI[md5sum] = "a32bf498cf33d5e3417823a7b252ad22" |
10 | SRC_URI[sha256sum] = "55f39f3b28e676f6cbd9377d83edd031084436a4da41280a9503c94faffb1665" | 10 | SRC_URI[sha256sum] = "55f39f3b28e676f6cbd9377d83edd031084436a4da41280a9503c94faffb1665" |
diff --git a/meta-oe/recipes-devtools/orc/orc.inc b/meta-oe/recipes-devtools/orc/orc.inc index 6efe02564..7a957f324 100644 --- a/meta-oe/recipes-devtools/orc/orc.inc +++ b/meta-oe/recipes-devtools/orc/orc.inc | |||
@@ -16,7 +16,7 @@ FILES_orc-examples = "${libdir}/orc/*" | |||
16 | FILES_${PN} = "${bindir}/*" | 16 | FILES_${PN} = "${bindir}/*" |
17 | 17 | ||
18 | python populate_packages_prepend () { | 18 | python populate_packages_prepend () { |
19 | libdir = bb.data.expand('${libdir}', d) | 19 | libdir = d.expand('${libdir}') |
20 | do_split_packages(d, libdir, '^lib(.*)\.so\.*', 'lib%s', 'ORC %s library', extra_depends='', allow_links=True) | 20 | do_split_packages(d, libdir, '^lib(.*)\.so\.*', 'lib%s', 'ORC %s library', extra_depends='', allow_links=True) |
21 | } | 21 | } |
22 | 22 | ||
diff --git a/meta-oe/recipes-devtools/vala/vala.inc b/meta-oe/recipes-devtools/vala/vala.inc index 3d33953b6..6cdc6053b 100644 --- a/meta-oe/recipes-devtools/vala/vala.inc +++ b/meta-oe/recipes-devtools/vala/vala.inc | |||
@@ -9,7 +9,7 @@ LICENSE = "LGPLv2.1" | |||
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24" | 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24" |
10 | INC_PR = "r1" | 10 | INC_PR = "r1" |
11 | 11 | ||
12 | SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}" | 12 | SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}" |
13 | 13 | ||
14 | SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/${BPN}/${SHRT_VER}/${BP}.tar.xz" | 14 | SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/${BPN}/${SHRT_VER}/${BP}.tar.xz" |
15 | inherit autotools | 15 | inherit autotools |