summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin.juszkiewicz@linaro.org>2013-02-14 16:55:28 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-02-19 01:48:45 +0100
commitf72b484e53ba1c71b43ea31ef186466bef58bc43 (patch)
treee7636eff9042ff2d6d2e635dc8e45b998117d671 /meta-oe/recipes-devtools
parent8b7fa822757958c83949d719d59cc8bf0b94845b (diff)
downloadmeta-openembedded-f72b484e53ba1c71b43ea31ef186466bef58bc43.tar.gz
python-numpy: update to 1.7.0
Signed-off-by: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/python/python-numpy/aarch64.patch41
-rw-r--r--meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb (renamed from meta-oe/recipes-devtools/python/python-numpy_1.7.0rc1.bb)17
2 files changed, 7 insertions, 51 deletions
diff --git a/meta-oe/recipes-devtools/python/python-numpy/aarch64.patch b/meta-oe/recipes-devtools/python/python-numpy/aarch64.patch
deleted file mode 100644
index 8d6661564..000000000
--- a/meta-oe/recipes-devtools/python/python-numpy/aarch64.patch
+++ /dev/null
@@ -1,41 +0,0 @@
1From 7d7a5939dcf5821d9f381d57bfa2012568ef6b82 Mon Sep 17 00:00:00 2001
2From: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org>
3Date: Thu, 10 Jan 2013 21:49:01 +0100
4Subject: [PATCH] Added support for AArch64 architecture
5
6Signed-off-by: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org>
7
8Upstream-Status: backport
9---
10 numpy/core/include/numpy/npy_cpu.h | 2 ++
11 numpy/core/include/numpy/npy_endian.h | 1 +
12 2 files changed, 3 insertions(+)
13
14diff --git a/numpy/core/include/numpy/npy_cpu.h b/numpy/core/include/numpy/npy_cpu.h
15index 8a29788..9707a7a 100644
16--- a/numpy/core/include/numpy/npy_cpu.h
17+++ b/numpy/core/include/numpy/npy_cpu.h
18@@ -66,6 +66,8 @@
19 #define NPY_CPU_MIPSEL
20 #elif defined(__MIPSEB__)
21 #define NPY_CPU_MIPSEB
22+#elif defined(__aarch64__)
23+ #define NPY_CPU_AARCH64
24 #else
25 #error Unknown CPU, please report this to numpy maintainers with \
26 information about your platform (OS, CPU and compiler)
27diff --git a/numpy/core/include/numpy/npy_endian.h b/numpy/core/include/numpy/npy_endian.h
28index aa5ed8b..4e3349f 100644
29--- a/numpy/core/include/numpy/npy_endian.h
30+++ b/numpy/core/include/numpy/npy_endian.h
31@@ -25,6 +25,7 @@
32 || defined(NPY_CPU_IA64) \
33 || defined(NPY_CPU_ALPHA) \
34 || defined(NPY_CPU_ARMEL) \
35+ || defined(NPY_CPU_AARCH64) \
36 || defined(NPY_CPU_SH_LE) \
37 || defined(NPY_CPU_MIPSEL)
38 #define NPY_BYTE_ORDER NPY_LITTLE_ENDIAN
39--
401.8.0
41
diff --git a/meta-oe/recipes-devtools/python/python-numpy_1.7.0rc1.bb b/meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb
index 2e4bd6ad2..bbe4e63b9 100644
--- a/meta-oe/recipes-devtools/python/python-numpy_1.7.0rc1.bb
+++ b/meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb
@@ -2,14 +2,10 @@ DESCRIPTION = "A sophisticated Numeric Processing Package for Python"
2SECTION = "devel/python" 2SECTION = "devel/python"
3LICENSE = "PSF" 3LICENSE = "PSF"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=f87832d854acbade6e9f5c601c8b30b1" 4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=f87832d854acbade6e9f5c601c8b30b1"
5PR = "r0"
6PV = "1.6.99+1.7.0rc1"
7REALPV = "1.7.0rc1"
8 5
9SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/numpy-${REALPV}.tar.gz \ 6SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/numpy-${PV}.tar.gz \
10 ${CONFIGFILESURI} \ 7 ${CONFIGFILESURI} "
11 file://aarch64.patch \ 8
12 "
13CONFIGFILESURI ?= "" 9CONFIGFILESURI ?= ""
14 10
15CONFIGFILESURI_aarch64 = "file://config.h \ 11CONFIGFILESURI_aarch64 = "file://config.h \
@@ -22,7 +18,7 @@ CONFIGFILESURI_mipsel = "file://config.h \
22 file://numpyconfig.h \ 18 file://numpyconfig.h \
23 " 19 "
24 20
25S = "${WORKDIR}/numpy-${REALPV}" 21S = "${WORKDIR}/numpy-${PV}"
26 22
27inherit distutils 23inherit distutils
28 24
@@ -36,8 +32,9 @@ do_compile_prepend() {
36} 32}
37 33
38FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a" 34FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a"
39SRC_URI[md5sum] = "a4719f5a1853bc0f8892a5956d5c4229" 35
40SRC_URI[sha256sum] = "45ea23622f72d86bc3614446d668ee962c0475ee7b91a93ef85a5e0493962de5" 36SRC_URI[md5sum] = "4fa54e40b6a243416f0248123b6ec332"
37SRC_URI[sha256sum] = "f4fa70b7edbab65ee6432eb63743f5489f1919c614632b20b2fb45aa7e682ac6"
41 38
42# install what is needed for numpy.test() 39# install what is needed for numpy.test()
43RDEPENDS_${PN} = "python-unittest \ 40RDEPENDS_${PN} = "python-unittest \