diff options
author | Armin Kuster <akuster808@gmail.com> | 2017-10-26 13:54:49 -0700 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2018-03-01 16:10:36 -0800 |
commit | e2d5593aed521d4d3ae6fa66daafe1305de9dda7 (patch) | |
tree | 7a7990c03e897c882b92a3d9ee5fced82f617be1 /meta-oe/recipes-devtools | |
parent | 56121f12f124bcfa4b94074bde2742542d402cc1 (diff) | |
download | meta-openembedded-e2d5593aed521d4d3ae6fa66daafe1305de9dda7.tar.gz |
pm-qa: move to recipe-test
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r-- | meta-oe/recipes-devtools/pm-qa/pm-qa_git.bb | 65 |
1 files changed, 0 insertions, 65 deletions
diff --git a/meta-oe/recipes-devtools/pm-qa/pm-qa_git.bb b/meta-oe/recipes-devtools/pm-qa/pm-qa_git.bb deleted file mode 100644 index 1ee6573bd..000000000 --- a/meta-oe/recipes-devtools/pm-qa/pm-qa_git.bb +++ /dev/null | |||
@@ -1,65 +0,0 @@ | |||
1 | DESCRIPTION = "Utilities for testing Power Management" | ||
2 | HOMEPAGE = "https://wiki.linaro.org/WorkingGroups/PowerManagement/Resources/TestSuite/PmQa" | ||
3 | |||
4 | LICENSE = "GPLv2" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | ||
6 | |||
7 | PV = "0.5.2" | ||
8 | |||
9 | BRANCH ?= "master" | ||
10 | |||
11 | SRCREV = "05710ec5032be4c8edafb4109d4d908d31243906" | ||
12 | |||
13 | SRC_URI = "git://git.linaro.org/power/pm-qa.git;protocol=git;branch=${BRANCH}" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | CFLAGS += "-pthread" | ||
18 | |||
19 | do_compile () { | ||
20 | # Find all the .c files in this project and build them. | ||
21 | for x in `find . -name "*.c"` | ||
22 | do | ||
23 | util=`echo ${x} | sed s/.c$//` | ||
24 | oe_runmake ${util} | ||
25 | done | ||
26 | } | ||
27 | |||
28 | do_install () { | ||
29 | install -d ${D}${bindir} | ||
30 | install -d ${D}${libdir}/${BPN} | ||
31 | |||
32 | # Install the compiled binaries that were built in the previous step | ||
33 | for x in `find . -name "*.c"` | ||
34 | do | ||
35 | util=`echo ${x} | sed s/.c$//` | ||
36 | util_basename=`basename ${util}` | ||
37 | install -m 0755 ${util} ${D}${bindir}/${util_basename} | ||
38 | done | ||
39 | |||
40 | # Install the helper scripts in a subdirectory of $libdir | ||
41 | for script in `find . -name "*.sh" | grep include` | ||
42 | do | ||
43 | # Remove hardcoded relative paths | ||
44 | sed -i -e 's#..\/utils\/##' ${script} | ||
45 | |||
46 | script_basename=`basename ${script}` | ||
47 | install -m 0755 $script ${D}${libdir}/${BPN}/${script_basename} | ||
48 | done | ||
49 | |||
50 | # Install the shell scripts NOT in the $libdir directory since those | ||
51 | # will be installed elsewhere | ||
52 | for script in `find . -name "*.sh" | grep -v include` | ||
53 | do | ||
54 | # if the script includes any helper scripts from the $libdir | ||
55 | # directory then change the source path to the absolute path | ||
56 | # to reflect the install location of the helper scripts. | ||
57 | sed -i -e "s#source ../include#source ${libdir}/${BPN}#g" ${script} | ||
58 | # Remove hardcoded relative paths | ||
59 | sed -i -e 's#..\/utils\/##' ${script} | ||
60 | |||
61 | script_basename=`basename ${script}` | ||
62 | install -m 0755 $script ${D}${bindir}/${script_basename} | ||
63 | done | ||
64 | } | ||
65 | RDEPENDS_${PN} +="bash" | ||