diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-04-23 22:20:44 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-26 20:13:30 +0200 |
commit | cc275f0b112c31381bf2258203ad58d64146900a (patch) | |
tree | 3c103dce165265d367f5e1cc3ad841104a41a015 /meta-oe/recipes-devtools | |
parent | 2f6193d78faf69aea4018e624a2402db615b11e7 (diff) | |
download | meta-openembedded-cc275f0b112c31381bf2258203ad58d64146900a.tar.gz |
msgpack-c: Upgrade to 2.1.1
Fix build with gcc7
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r-- | meta-oe/recipes-devtools/msgpack/msgpack-c/0001-Comment-intentional-fallthrough-in-case-statements.patch | 39 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/msgpack/msgpack-c/304ff96d04599401172568d042723ff507e78cc3.patch | 40 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/msgpack/msgpack-c_2.1.1.bb (renamed from meta-oe/recipes-devtools/msgpack/msgpack-c_2.0.0.bb) | 15 |
3 files changed, 90 insertions, 4 deletions
diff --git a/meta-oe/recipes-devtools/msgpack/msgpack-c/0001-Comment-intentional-fallthrough-in-case-statements.patch b/meta-oe/recipes-devtools/msgpack/msgpack-c/0001-Comment-intentional-fallthrough-in-case-statements.patch new file mode 100644 index 000000000..a388297a8 --- /dev/null +++ b/meta-oe/recipes-devtools/msgpack/msgpack-c/0001-Comment-intentional-fallthrough-in-case-statements.patch | |||
@@ -0,0 +1,39 @@ | |||
1 | From 15d8bb6792c9639d85a9ffe2ac81431f1b986c21 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 22 Apr 2017 08:53:50 -0700 | ||
4 | Subject: [PATCH] Comment intentional fallthrough in case statements | ||
5 | |||
6 | Fixes build with gcc7 | ||
7 | |||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | --- | ||
10 | include/msgpack/v1/adaptor/detail/cpp03_define_array.hpp | 4 ++++ | ||
11 | 1 file changed, 4 insertions(+) | ||
12 | |||
13 | diff --git a/include/msgpack/v1/adaptor/detail/cpp03_define_array.hpp b/include/msgpack/v1/adaptor/detail/cpp03_define_array.hpp | ||
14 | index b35c21a7..4c463a90 100644 | ||
15 | --- a/include/msgpack/v1/adaptor/detail/cpp03_define_array.hpp | ||
16 | +++ b/include/msgpack/v1/adaptor/detail/cpp03_define_array.hpp | ||
17 | @@ -105,6 +105,7 @@ struct define_array<A0, A1> { | ||
18 | switch(size) { | ||
19 | default: | ||
20 | case 2: ptr[1].convert(a1); | ||
21 | + //fallthrough | ||
22 | case 1: ptr[0].convert(a0); | ||
23 | } | ||
24 | } | ||
25 | @@ -193,8 +194,11 @@ struct define_array<A0, A1, A2, A3> { | ||
26 | switch(size) { | ||
27 | default: | ||
28 | case 4: ptr[3].convert(a3); | ||
29 | + //fallthrough | ||
30 | case 3: ptr[2].convert(a2); | ||
31 | + //fallthrough | ||
32 | case 2: ptr[1].convert(a1); | ||
33 | + //fallthrough | ||
34 | case 1: ptr[0].convert(a0); | ||
35 | } | ||
36 | } | ||
37 | -- | ||
38 | 2.12.2 | ||
39 | |||
diff --git a/meta-oe/recipes-devtools/msgpack/msgpack-c/304ff96d04599401172568d042723ff507e78cc3.patch b/meta-oe/recipes-devtools/msgpack/msgpack-c/304ff96d04599401172568d042723ff507e78cc3.patch new file mode 100644 index 000000000..b8b3d3187 --- /dev/null +++ b/meta-oe/recipes-devtools/msgpack/msgpack-c/304ff96d04599401172568d042723ff507e78cc3.patch | |||
@@ -0,0 +1,40 @@ | |||
1 | From 304ff96d04599401172568d042723ff507e78cc3 Mon Sep 17 00:00:00 2001 | ||
2 | From: James McCoy <jamessan@debian.org> | ||
3 | Date: Thu, 13 Apr 2017 11:38:45 -0400 | ||
4 | Subject: [PATCH] Comment the intentional fallthrough to default from | ||
5 | _fixed_trail_again | ||
6 | |||
7 | GCC 7 added a new diagnostic, -Wimplicit-fallthrough, which is enabled | ||
8 | with -Wextra that warns about implicitly falling through a case | ||
9 | statement. | ||
10 | |||
11 | [ 4%] Building C object CMakeFiles/msgpackc-static.dir/src/unpack.c.o | ||
12 | /usr/lib/gcc-snapshot/bin/gcc -I/home/jamessan/src/msgpack-c/. -I/home/jamessan/src/msgpack-c/include -I/home/jamessan/src/msgpack-c/build/include -g -O2 -fdebug-prefix-map=/home/jamessan/src/msgpack-c=. -specs=/usr/share/dpkg/no-pie-compile.specs -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -Wall -Wextra -Werror -g -O3 -o CMakeFiles/msgpackc-static.dir/src/unpack.c.o -c /home/jamessan/src/msgpack-c/src/unpack.c | ||
13 | In file included from /home/jamessan/src/msgpack-c/src/unpack.c:283:0: | ||
14 | /home/jamessan/src/msgpack-c/include/msgpack/unpack_template.h: In function 'template_execute': | ||
15 | /home/jamessan/src/msgpack-c/include/msgpack/unpack_template.h:238:17: error: this statement may fall through [-Werror=implicit-fallthrough=] | ||
16 | ++p; | ||
17 | ^~~ | ||
18 | /home/jamessan/src/msgpack-c/include/msgpack/unpack_template.h:240:13: note: here | ||
19 | default: | ||
20 | ^~~~~~~ | ||
21 | cc1: all warnings being treated as errors | ||
22 | |||
23 | Adding the comment makes it explicit that the fallthrough is | ||
24 | intentional, so gcc doesn't complain. | ||
25 | --- | ||
26 | include/msgpack/unpack_template.h | 1 + | ||
27 | 1 file changed, 1 insertion(+) | ||
28 | |||
29 | diff --git a/include/msgpack/unpack_template.h b/include/msgpack/unpack_template.h | ||
30 | index 8450442..e557bb6 100644 | ||
31 | --- a/include/msgpack/unpack_template.h | ||
32 | +++ b/include/msgpack/unpack_template.h | ||
33 | @@ -236,6 +236,7 @@ msgpack_unpack_func(int, _execute)(msgpack_unpack_struct(_context)* ctx, const c | ||
34 | |||
35 | _fixed_trail_again: | ||
36 | ++p; | ||
37 | + // fallthrough | ||
38 | |||
39 | default: | ||
40 | if((size_t)(pe - p) < trail) { goto _out; } | ||
diff --git a/meta-oe/recipes-devtools/msgpack/msgpack-c_2.0.0.bb b/meta-oe/recipes-devtools/msgpack/msgpack-c_2.1.1.bb index 14e860d6a..7655d9469 100644 --- a/meta-oe/recipes-devtools/msgpack/msgpack-c_2.0.0.bb +++ b/meta-oe/recipes-devtools/msgpack/msgpack-c_2.1.1.bb | |||
@@ -6,10 +6,17 @@ LIC_FILES_CHKSUM = "file://NOTICE;md5=7a858c074723608e08614061dc044352 \ | |||
6 | file://COPYING;md5=0639c4209b6f2abf1437c813b208f2d3 \ | 6 | file://COPYING;md5=0639c4209b6f2abf1437c813b208f2d3 \ |
7 | file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c \ | 7 | file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c \ |
8 | " | 8 | " |
9 | SRC_URI = "https://github.com/msgpack/msgpack-c/releases/download/cpp-${PV}/msgpack-${PV}.tar.gz" | 9 | |
10 | SRC_URI[md5sum] = "55148cd856c72f954a6eb9cc889a7d2a" | 10 | PV .= "+git${SRCPV}" |
11 | SRC_URI[sha256sum] = "41de0989a3385061ab7307a1005655e780def6fc9c89af0ec942616aa787e136" | 11 | |
12 | SRCREV = "20ef1f925b007f170ab1c257e4aa61fdd0927773" | ||
13 | |||
14 | SRC_URI = "git://github.com/msgpack/msgpack-c \ | ||
15 | file://0001-Comment-intentional-fallthrough-in-case-statements.patch \ | ||
16 | " | ||
12 | 17 | ||
13 | inherit cmake pkgconfig | 18 | inherit cmake pkgconfig |
14 | 19 | ||
15 | S = "${WORKDIR}/msgpack-${PV}" | 20 | S = "${WORKDIR}/git" |
21 | |||
22 | FILES_${PN}-dev += "${libdir}/cmake/msgpack/*.cmake" | ||