diff options
author | Moritz Fischer <moritz.fischer@ettus.com> | 2017-05-04 15:50:37 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-05-23 15:49:34 +0200 |
commit | a978ea30514307b565512817ff47d8d25cb10ff7 (patch) | |
tree | ae6bbe760906615462d35ae1dcdc791b49f761d2 /meta-oe/recipes-devtools | |
parent | fcf4ca384c94e61ef458f14ab1192f6de2b7ee73 (diff) | |
download | meta-openembedded-a978ea30514307b565512817ff47d8d25cb10ff7.tar.gz |
openocd: Add recipe for openocd
Adds a recipe for openocd. Based on recipe found in meta-zephyr.
Signed-off-by: Moritz Fischer <moritz.fischer@ettus.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r-- | meta-oe/recipes-devtools/openocd/openocd_git.bb | 44 |
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/openocd/openocd_git.bb b/meta-oe/recipes-devtools/openocd/openocd_git.bb new file mode 100644 index 000000000..783a6c707 --- /dev/null +++ b/meta-oe/recipes-devtools/openocd/openocd_git.bb | |||
@@ -0,0 +1,44 @@ | |||
1 | SUMMARY = "Free and Open On-Chip Debugging, In-System Programming and Boundary-Scan Testing" | ||
2 | LICENSE = "GPLv2" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | ||
4 | DEPENDS = "libusb-compat libftdi" | ||
5 | RDEPENDS_${PN} = "libusb1" | ||
6 | |||
7 | SRC_URI = "git://repo.or.cz/openocd.git \ | ||
8 | " | ||
9 | SRCREV = "cb317eabf2d162365467aeb89b564828e5e6d6f3" | ||
10 | |||
11 | PV = "0.10+gitr${SRCPV}" | ||
12 | S = "${WORKDIR}/git" | ||
13 | |||
14 | inherit pkgconfig autotools-brokensep gettext | ||
15 | |||
16 | BBCLASSEXTEND += "nativesdk" | ||
17 | |||
18 | EXTRA_OECONF = "--enable-ftdi --disable-doxygen-html " | ||
19 | |||
20 | do_configure() { | ||
21 | ./bootstrap | ||
22 | oe_runconf ${EXTRA_OECONF} | ||
23 | } | ||
24 | |||
25 | do_install() { | ||
26 | oe_runmake DESTDIR=${D} install | ||
27 | if [ -e "${D}${infodir}" ]; then | ||
28 | rm -Rf ${D}${infodir} | ||
29 | fi | ||
30 | if [ -e "${D}${mandir}" ]; then | ||
31 | rm -Rf ${D}${mandir} | ||
32 | fi | ||
33 | if [ -e "${D}${bindir}/.debug" ]; then | ||
34 | rm -Rf ${D}${bindir}/.debug | ||
35 | fi | ||
36 | } | ||
37 | |||
38 | FILES_${PN} = " \ | ||
39 | ${datadir}/openocd/* \ | ||
40 | ${bindir}/openocd \ | ||
41 | " | ||
42 | |||
43 | PACKAGECONFIG[sysfsgpio] = "--enable-sysfsgpio,--disable-sysfsgpio" | ||
44 | PACKAGECONFIG ??= "sysfsgpio" | ||