diff options
author | Victor Rodriguez <victor.rodriguez.bahena@intel.com> | 2015-03-09 14:57:43 -0600 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-03-21 16:42:21 +0100 |
commit | 824b6de96ddfe791a0013d96a84ad49de8e04d38 (patch) | |
tree | 611807de8115ff1c6ca9fc0ac4c36dfa885f6c58 /meta-oe/recipes-devtools | |
parent | fca56b63f267b5bba3f76b59eac4c5b397e86ceb (diff) | |
download | meta-openembedded-824b6de96ddfe791a0013d96a84ad49de8e04d38.tar.gz |
Add mpich support
This patch add mpich support to yocto in order to run MPI framework on embedded
systems.
Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
Signed-off-by: Victor Rodriguez <victor.rodriguez.bahena@intel.com>
Signed-off-by: Alexandru.Vaduva <Alexandru.Vaduva@enea.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r-- | meta-oe/recipes-devtools/mpich/mpich_3.1.1.bb | 29 |
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/mpich/mpich_3.1.1.bb b/meta-oe/recipes-devtools/mpich/mpich_3.1.1.bb new file mode 100644 index 000000000..2f4226ea9 --- /dev/null +++ b/meta-oe/recipes-devtools/mpich/mpich_3.1.1.bb | |||
@@ -0,0 +1,29 @@ | |||
1 | SUMMARY = "Message Passing Interface(MPI) implementation" | ||
2 | HOMEPAGE = "http://git.mpich.org/mpich.git/" | ||
3 | SECTION = "devel" | ||
4 | |||
5 | LICENSE = "BSD-2-Clause" | ||
6 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=2106f0435056f3dd9349747a766e5816" | ||
7 | |||
8 | SRC_URI = "http://www.mpich.org/static/downloads/${PV}/mpich-${PV}.tar.gz" | ||
9 | SRC_URI[md5sum] = "40dc408b1e03cc36d80209baaa2d32b7" | ||
10 | SRC_URI[sha256sum] = "455ccfaf4ec724d2cf5d8bff1f3d26a958ad196121e7ea26504fd3018757652d" | ||
11 | |||
12 | RDEPENDS_${PN} += "bash perl tcsh" | ||
13 | S = "${WORKDIR}/${PN}-${PV}" | ||
14 | |||
15 | EXTRA_OECONF = "--enable-debuginfo \ | ||
16 | --enable-fast \ | ||
17 | --enable-shared \ | ||
18 | --disable-f77 \ | ||
19 | --disable-fc \ | ||
20 | --disable-fortran \ | ||
21 | --disable-cxx" | ||
22 | |||
23 | inherit autotools-brokensep gettext | ||
24 | |||
25 | do_configure_prepend() { | ||
26 | autoreconf --verbose --install --force -I . -I confdb/ -I maint/ | ||
27 | oe_runconf | ||
28 | exit | ||
29 | } | ||