summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-03-09 23:41:40 -0800
committerKhem Raj <raj.khem@gmail.com>2023-03-09 23:43:22 -0800
commit7069d2fcbb6ea889207c6d14278c461128c7d7fd (patch)
treef50ed38e578f9b5df22edd4a1897b374f96f0c83 /meta-oe/recipes-devtools
parent0c9700a01f0592de51fcc2e173b4f4dee5f5ccfd (diff)
downloadmeta-openembedded-7069d2fcbb6ea889207c6d14278c461128c7d7fd.tar.gz
pahole: Upgrade to tip of trunk
Drop patches already present in 1.24+ Needed to get fixes to build with latest libbpf APIs Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/pahole/files/0001-CMakeList.txt-make-python-optional.patch44
-rw-r--r--meta-oe/recipes-devtools/pahole/files/0003-CMakeList.txt-don-t-download-libbpf-source-when-syst.patch34
-rw-r--r--meta-oe/recipes-devtools/pahole/pahole_1.24.bb (renamed from meta-oe/recipes-devtools/pahole/pahole_1.22.bb)7
3 files changed, 3 insertions, 82 deletions
diff --git a/meta-oe/recipes-devtools/pahole/files/0001-CMakeList.txt-make-python-optional.patch b/meta-oe/recipes-devtools/pahole/files/0001-CMakeList.txt-make-python-optional.patch
deleted file mode 100644
index d64cba109..000000000
--- a/meta-oe/recipes-devtools/pahole/files/0001-CMakeList.txt-make-python-optional.patch
+++ /dev/null
@@ -1,44 +0,0 @@
1From f6ca8c930d0fbd2491b3cc77169e32806a14e5e9 Mon Sep 17 00:00:00 2001
2From: Matteo Croce <mcroce@microsoft.com>
3Date: Mon, 30 Aug 2021 16:25:56 +0200
4Subject: [PATCH] CMakeList.txt: make python optional
5
6Upstream-Status: Backport [https://git.kernel.org/pub/scm/devel/pahole/pahole.git/commit/?id=88431099950ab3e8bc1645353508d7978a6cad35]
7
8ostra-cg, which requires python, is installed in the destination dir.
9Make it optional for embedded distributions which doesn't have the
10python interpreter available.
11
12Signed-off-by: Matteo Croce <mcroce@microsoft.com>
13---
14 CMakeLists.txt | 7 +++++--
15 1 file changed, 5 insertions(+), 2 deletions(-)
16
17diff --git a/CMakeLists.txt b/CMakeLists.txt
18index 4140574..8523bce 100644
19--- a/CMakeLists.txt
20+++ b/CMakeLists.txt
21@@ -61,6 +61,7 @@ find_package(DWARF REQUIRED)
22 find_package(ZLIB REQUIRED)
23 find_package(argp REQUIRED)
24 find_package(obstack REQUIRED)
25+find_package(Python3 QUIET)
26
27 # make sure git submodule(s) are checked out
28 find_package(Git QUIET)
29@@ -185,8 +186,10 @@ install(FILES dwarves.h dwarves_emit.h dwarves_reorganize.h
30 elfcreator.h elf_symtab.h hash.h libctf.h
31 DESTINATION ${CMAKE_INSTALL_PREFIX}/include/dwarves/)
32 install(FILES man-pages/pahole.1 DESTINATION ${CMAKE_INSTALL_PREFIX}/share/man/man1/)
33-install(PROGRAMS ostra/ostra-cg DESTINATION ${CMAKE_INSTALL_PREFIX}/bin)
34+if(Python3_FOUND)
35+ install(PROGRAMS ostra/ostra-cg DESTINATION ${CMAKE_INSTALL_PREFIX}/bin)
36+ install(FILES ostra/python/ostra.py DESTINATION ${CMAKE_INSTALL_PREFIX}/share/dwarves/runtime/python)
37+endif()
38 install(PROGRAMS btfdiff fullcircle DESTINATION ${CMAKE_INSTALL_PREFIX}/bin)
39-install(FILES ostra/python/ostra.py DESTINATION ${CMAKE_INSTALL_PREFIX}/share/dwarves/runtime/python)
40 install(FILES lib/Makefile lib/ctracer_relay.c lib/ctracer_relay.h lib/linux.blacklist.cu
41 DESTINATION ${CMAKE_INSTALL_PREFIX}/share/dwarves/runtime)
42--
432.31.1
44
diff --git a/meta-oe/recipes-devtools/pahole/files/0003-CMakeList.txt-don-t-download-libbpf-source-when-syst.patch b/meta-oe/recipes-devtools/pahole/files/0003-CMakeList.txt-don-t-download-libbpf-source-when-syst.patch
deleted file mode 100644
index 3d491e2ef..000000000
--- a/meta-oe/recipes-devtools/pahole/files/0003-CMakeList.txt-don-t-download-libbpf-source-when-syst.patch
+++ /dev/null
@@ -1,34 +0,0 @@
1From 3d20210d84f61ee2189927e2d9de9ce3e5a0a9c5 Mon Sep 17 00:00:00 2001
2From: Matteo Croce <mcroce@microsoft.com>
3Date: Mon, 20 Sep 2021 18:44:52 +0200
4Subject: [PATCH] CMakeList.txt: Don't download libbpf source when system
5 library is used
6
7Upstream-Status: Backport [https://git.kernel.org/pub/scm/devel/pahole/pahole.git/commit/?id=3d20210d84f61ee2189927e2d9de9ce3e5a0a9c5]
8
9The build system always download the libbpf submodule, regardless if
10we're using the embedded or the system version.
11Download the libbpf source only if we're using the embedded one.
12
13Signed-off-by: Matteo Croce <mcroce@microsoft.com>
14Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
15---
16 CMakeLists.txt | 2 +-
17 1 file changed, 1 insertion(+), 1 deletion(-)
18
19diff --git a/CMakeLists.txt b/CMakeLists.txt
20index 8523bce..2ab66e4 100644
21--- a/CMakeLists.txt
22+++ b/CMakeLists.txt
23@@ -65,7 +65,7 @@ find_package(Python3 QUIET)
24
25 # make sure git submodule(s) are checked out
26 find_package(Git QUIET)
27-if(GIT_FOUND AND EXISTS "${PROJECT_SOURCE_DIR}/.git")
28+if(LIBBPF_EMBEDDED AND GIT_FOUND AND EXISTS "${PROJECT_SOURCE_DIR}/.git")
29 # Update submodules as needed
30 option(GIT_SUBMODULE "Check submodules during build" ON)
31 if(GIT_SUBMODULE)
32--
332.31.1
34
diff --git a/meta-oe/recipes-devtools/pahole/pahole_1.22.bb b/meta-oe/recipes-devtools/pahole/pahole_1.24.bb
index 449508a5d..b7f1f8bb2 100644
--- a/meta-oe/recipes-devtools/pahole/pahole_1.22.bb
+++ b/meta-oe/recipes-devtools/pahole/pahole_1.24.bb
@@ -9,11 +9,10 @@ DEPENDS = "elfutils zlib libbpf"
9PACKAGE_ARCH = "${MACHINE_ARCH}" 9PACKAGE_ARCH = "${MACHINE_ARCH}"
10COMPATIBLE_HOST = "(x86_64|i.86|aarch64).*-linux" 10COMPATIBLE_HOST = "(x86_64|i.86|aarch64).*-linux"
11 11
12SRCREV = "f02af2553ea58ae1186226af0d0ec835a248358f" 12PV .= "+1.25+git${SRCPV}"
13SRCREV = "a9498899109d3be14f17abbc322a8f55a1067bee"
13SRC_URI = "git://git.kernel.org/pub/scm/devel/pahole/pahole.git;branch=master \ 14SRC_URI = "git://git.kernel.org/pub/scm/devel/pahole/pahole.git;branch=master \
14 file://0001-CMakeList.txt-make-python-optional.patch \ 15 file://0002-Use-usr-bin-env-python3-instead-of-just-usr-bin-pyth.patch"
15 file://0002-Use-usr-bin-env-python3-instead-of-just-usr-bin-pyth.patch \
16 file://0003-CMakeList.txt-don-t-download-libbpf-source-when-syst.patch"
17 16
18S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
19 18