diff options
author | Tim Orling <timothy.t.orling@linux.intel.com> | 2018-03-17 22:49:59 -0700 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2018-03-21 18:37:41 -0700 |
commit | 4a36055c20e354f398273f6459a5112eb390048b (patch) | |
tree | 97b4ffd95735484ad8c0c99b4bdf50f905d282d4 /meta-oe/recipes-devtools | |
parent | 72800d19f955bb6bb412c1f00dd0ad14b6fc49be (diff) | |
download | meta-openembedded-4a36055c20e354f398273f6459a5112eb390048b.tar.gz |
python-futures: upgrade v3.0.5 -> v3.2.0; inherit pypi
* For changes, see:
https://github.com/agronholm/pythonfutures/blob/master/CHANGES.rst
* Inheriting pypi class has the benefit of allowing
auto-upgrade-helper to properly check for new versions
* HOMEPAGE is now on github
* Add nativesdk to BBCLASSEXTEND
* Use LICENSE file for license checksum
* License has changed from BSD to PSF
License-Update: use LICENSE file; license is now PSF
Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r-- | meta-oe/recipes-devtools/python/python-futures_3.0.5.bb | 16 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/python/python-futures_3.2.0.bb | 13 |
2 files changed, 13 insertions, 16 deletions
diff --git a/meta-oe/recipes-devtools/python/python-futures_3.0.5.bb b/meta-oe/recipes-devtools/python/python-futures_3.0.5.bb deleted file mode 100644 index c85fc56b8..000000000 --- a/meta-oe/recipes-devtools/python/python-futures_3.0.5.bb +++ /dev/null | |||
@@ -1,16 +0,0 @@ | |||
1 | DESCRIPTION = "The concurrent.futures module provides a high-level interface for asynchronously executing callables." | ||
2 | SECTION = "devel/python" | ||
3 | LICENSE = "BSD" | ||
4 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=3d78c5bb15ac641d34f2ddc3bd7f51fa" | ||
5 | HOMEPAGE = "http://code.google.com/p/pythonfutures" | ||
6 | DEPENDS = "python" | ||
7 | |||
8 | SRC_URI = "https://pypi.python.org/packages/source/f/futures/futures-${PV}.tar.gz" | ||
9 | SRC_URI[md5sum] = "ced2c365e518242512d7a398b515ff95" | ||
10 | SRC_URI[sha256sum] = "0542525145d5afc984c88f914a0c85c77527f65946617edb5274f72406f981df" | ||
11 | |||
12 | S = "${WORKDIR}/futures-${PV}" | ||
13 | |||
14 | inherit setuptools | ||
15 | |||
16 | BBCLASSEXTEND = "native" | ||
diff --git a/meta-oe/recipes-devtools/python/python-futures_3.2.0.bb b/meta-oe/recipes-devtools/python/python-futures_3.2.0.bb new file mode 100644 index 000000000..3ee945fc9 --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-futures_3.2.0.bb | |||
@@ -0,0 +1,13 @@ | |||
1 | DESCRIPTION = "The concurrent.futures module provides a high-level interface for asynchronously executing callables." | ||
2 | SECTION = "devel/python" | ||
3 | LICENSE = "PSF" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=834d982f973c48b6d662b5944c5ab567" | ||
5 | HOMEPAGE = "https://github.com/agronholm/pythonfutures" | ||
6 | DEPENDS = "python" | ||
7 | |||
8 | SRC_URI[md5sum] = "d1b299a06b96ccb59f70324716dc0016" | ||
9 | SRC_URI[sha256sum] = "9ec02aa7d674acb8618afb127e27fde7fc68994c0437ad759fa094a574adb265" | ||
10 | |||
11 | inherit pypi setuptools | ||
12 | |||
13 | BBCLASSEXTEND = "native nativesdk" | ||