summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2021-12-21 18:53:46 +0800
committerKhem Raj <raj.khem@gmail.com>2021-12-21 18:53:28 -0800
commit0e0fc7efe3983de4f11a21bf2527f886604dcfec (patch)
treea07f504d78e562c316b04fe5722dcb14e82fa767 /meta-oe/recipes-devtools
parent482b8680690e1bff03b2aff89e503e720cd3983a (diff)
downloadmeta-openembedded-0e0fc7efe3983de4f11a21bf2527f886604dcfec.tar.gz
php: Upgrade to 8.1.0
Rebase one patch to new version and enable openssl PACKAGECONFIG as OpenSSL 3.0 is now supported in the new version now [1] and remove one patch [2] as the related support for cross-compile env is already added in 8.1.0 [3]. [1] https://github.com/php/php-src/commit/7b34db0659dda933b1146a0ff249f25acca1d669 [2] https://git.openembedded.org/meta-openembedded/commit/?id=265bab83c9acbfa97117103dd5c35bbd8a9814d6 [3] https://github.com/php/php-src/commit/f1ad9199eff32dd805bb5b155002bdb6ca69bf01 Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/php/php/0001-ext-opcache-config.m4-enable-opcache.patch50
-rw-r--r--meta-oe/recipes-devtools/php/php/0011-use-qemuwrapper-for-minilua.patch11
-rw-r--r--meta-oe/recipes-devtools/php/php_8.1.0.bb (renamed from meta-oe/recipes-devtools/php/php_8.0.12.bb)20
3 files changed, 34 insertions, 47 deletions
diff --git a/meta-oe/recipes-devtools/php/php/0001-ext-opcache-config.m4-enable-opcache.patch b/meta-oe/recipes-devtools/php/php/0001-ext-opcache-config.m4-enable-opcache.patch
index 44534cc06..a967d6412 100644
--- a/meta-oe/recipes-devtools/php/php/0001-ext-opcache-config.m4-enable-opcache.patch
+++ b/meta-oe/recipes-devtools/php/php/0001-ext-opcache-config.m4-enable-opcache.patch
@@ -1,6 +1,6 @@
1From 8cabcf1043953a0fe48107204a2212609b8e6516 Mon Sep 17 00:00:00 2001 1From ca9b419f2c146061f73ee045cb0a069c18b40cd0 Mon Sep 17 00:00:00 2001
2From: Claude Bing <cbing@cybernetics.com> 2From: Mingli Yu <mingli.yu@windriver.com>
3Date: Tue, 9 Nov 2021 12:59:15 -0500 3Date: Wed, 15 Dec 2021 14:00:08 +0800
4Subject: [PATCH 01/11] ext/opcache/config.m4: enable opcache 4Subject: [PATCH 01/11] ext/opcache/config.m4: enable opcache
5 5
6We can't use AC_TRY_RUN to run programs in a cross compile 6We can't use AC_TRY_RUN to run programs in a cross compile
@@ -17,15 +17,18 @@ Signed-off-by: Changqing Li <changqing.li@windriver.com>
17update patch to version 8.0.12 17update patch to version 8.0.12
18fix issue linking with librt 18fix issue linking with librt
19Signed-off-by: Claude Bing <cbing@cybernetics.com> 19Signed-off-by: Claude Bing <cbing@cybernetics.com>
20
21update patch to version 8.1.0
22Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
20--- 23---
21 ext/opcache/config.m4 | 197 ++---------------------------------------- 24 ext/opcache/config.m4 | 204 ++----------------------------------------
22 1 file changed, 8 insertions(+), 189 deletions(-) 25 1 file changed, 8 insertions(+), 196 deletions(-)
23 26
24diff --git a/ext/opcache/config.m4 b/ext/opcache/config.m4 27diff --git a/ext/opcache/config.m4 b/ext/opcache/config.m4
25index 5492fd920c..95158ccfd9 100644 28index 2a83fa2..9471b5d 100644
26--- a/ext/opcache/config.m4 29--- a/ext/opcache/config.m4
27+++ b/ext/opcache/config.m4 30+++ b/ext/opcache/config.m4
28@@ -101,202 +101,21 @@ if test "$PHP_OPCACHE" != "no"; then 31@@ -108,209 +108,21 @@ if test "$PHP_OPCACHE" != "no"; then
29 AC_CHECK_FUNCS([mprotect]) 32 AC_CHECK_FUNCS([mprotect])
30 33
31 AC_MSG_CHECKING(for sysvipc shared memory support) 34 AC_MSG_CHECKING(for sysvipc shared memory support)
@@ -93,9 +96,10 @@ index 5492fd920c..95158ccfd9 100644
93- } 96- }
94- return 0; 97- return 0;
95-} 98-}
96-]])],[dnl 99-]])],[have_shm_ipc=yes],[have_shm_ipc=no],[have_shm_ipc=no])
100- if test "$have_shm_ipc" = "yes"; then
97- AC_DEFINE(HAVE_SHM_IPC, 1, [Define if you have SysV IPC SHM support]) 101- AC_DEFINE(HAVE_SHM_IPC, 1, [Define if you have SysV IPC SHM support])
98- have_shm_ipc=yes],[have_shm_ipc=no],[have_shm_ipc=no]) 102- fi
99+ AC_DEFINE(HAVE_SHM_IPC, 1, [Define if you have SysV IPC SHM support]) 103+ AC_DEFINE(HAVE_SHM_IPC, 1, [Define if you have SysV IPC SHM support])
100+ have_shm_ipc=yes 104+ have_shm_ipc=yes
101 AC_MSG_RESULT([$have_shm_ipc]) 105 AC_MSG_RESULT([$have_shm_ipc])
@@ -147,9 +151,19 @@ index 5492fd920c..95158ccfd9 100644
147- } 151- }
148- return 0; 152- return 0;
149-} 153-}
150-]])],[dnl 154-]])],[have_shm_mmap_anon=yes],[have_shm_mmap_anon=no],[
155- case $host_alias in
156- *linux*)
157- have_shm_mmap_anon=yes
158- ;;
159- *)
160- have_shm_mmap_anon=no
161- ;;
162- esac
163-])
164- if test "$have_shm_mmap_anon" = "yes"; then
151- AC_DEFINE(HAVE_SHM_MMAP_ANON, 1, [Define if you have mmap(MAP_ANON) SHM support]) 165- AC_DEFINE(HAVE_SHM_MMAP_ANON, 1, [Define if you have mmap(MAP_ANON) SHM support])
152- have_shm_mmap_anon=yes],[have_shm_mmap_anon=no],[have_shm_mmap_anon=no]) 166- fi
153+ AC_DEFINE(HAVE_SHM_MMAP_ANON, 1, [Define if you have mmap(MAP_ANON) SHM support]) 167+ AC_DEFINE(HAVE_SHM_MMAP_ANON, 1, [Define if you have mmap(MAP_ANON) SHM support])
154+ have_shm_mmap_anon=yes 168+ have_shm_mmap_anon=yes
155 AC_MSG_RESULT([$have_shm_mmap_anon]) 169 AC_MSG_RESULT([$have_shm_mmap_anon])
@@ -219,16 +233,12 @@ index 5492fd920c..95158ccfd9 100644
219- } 233- }
220- return 0; 234- return 0;
221-} 235-}
222-]])],[dnl 236-]])],[have_shm_mmap_posix=yes],[have_shm_mmap_posix=no],[have_shm_mmap_posix=no])
237- if test "$have_shm_mmap_posix" = "yes"; then
223- AC_DEFINE(HAVE_SHM_MMAP_POSIX, 1, [Define if you have POSIX mmap() SHM support]) 238- AC_DEFINE(HAVE_SHM_MMAP_POSIX, 1, [Define if you have POSIX mmap() SHM support])
224- AC_MSG_RESULT([yes])
225- have_shm_mmap_posix=yes
226- PHP_CHECK_LIBRARY(rt, shm_unlink, [PHP_ADD_LIBRARY(rt,1,OPCACHE_SHARED_LIBADD)]) 239- PHP_CHECK_LIBRARY(rt, shm_unlink, [PHP_ADD_LIBRARY(rt,1,OPCACHE_SHARED_LIBADD)])
227- ],[ 240- fi
228- AC_MSG_RESULT([no]) 241- AC_MSG_RESULT([$have_shm_mmap_posix])
229- ],[
230- AC_MSG_RESULT([no])
231- ])
232+ AC_DEFINE(HAVE_SHM_MMAP_POSIX, 1, [Define if you have POSIX mmap() SHM support]) 242+ AC_DEFINE(HAVE_SHM_MMAP_POSIX, 1, [Define if you have POSIX mmap() SHM support])
233+ AC_MSG_RESULT([yes]) 243+ AC_MSG_RESULT([yes])
234+ have_shm_mmap_posix=yes 244+ have_shm_mmap_posix=yes
@@ -237,5 +247,5 @@ index 5492fd920c..95158ccfd9 100644
237 PHP_NEW_EXTENSION(opcache, 247 PHP_NEW_EXTENSION(opcache,
238 ZendAccelerator.c \ 248 ZendAccelerator.c \
239-- 249--
2402.25.1 2502.17.1
241 251
diff --git a/meta-oe/recipes-devtools/php/php/0011-use-qemuwrapper-for-minilua.patch b/meta-oe/recipes-devtools/php/php/0011-use-qemuwrapper-for-minilua.patch
deleted file mode 100644
index 892a0460c..000000000
--- a/meta-oe/recipes-devtools/php/php/0011-use-qemuwrapper-for-minilua.patch
+++ /dev/null
@@ -1,11 +0,0 @@
1--- a/ext/opcache/jit/Makefile.frag 2021-10-19 06:34:32.000000000 -0400
2+++ b/ext/opcache/jit/Makefile.frag 2021-11-15 15:10:41.437289836 -0500
3@@ -3,7 +3,7 @@ $(builddir)/minilua: $(srcdir)/jit/dynas
4 $(CC) $(srcdir)/jit/dynasm/minilua.c -lm -o $@
5
6 $(builddir)/jit/zend_jit_x86.c: $(srcdir)/jit/zend_jit_x86.dasc $(srcdir)/jit/dynasm/*.lua $(builddir)/minilua
7- $(builddir)/minilua $(srcdir)/jit/dynasm/dynasm.lua $(DASM_FLAGS) -o $@ $(srcdir)/jit/zend_jit_x86.dasc
8+ $(top_srcdir)/qemuwrapper $(builddir)/minilua $(srcdir)/jit/dynasm/dynasm.lua $(DASM_FLAGS) -o $@ $(srcdir)/jit/zend_jit_x86.dasc
9
10 $(builddir)/jit/zend_jit.lo: \
11 $(builddir)/jit/zend_jit_x86.c \
diff --git a/meta-oe/recipes-devtools/php/php_8.0.12.bb b/meta-oe/recipes-devtools/php/php_8.1.0.bb
index 38771948f..593eb3955 100644
--- a/meta-oe/recipes-devtools/php/php_8.0.12.bb
+++ b/meta-oe/recipes-devtools/php/php_8.1.0.bb
@@ -6,7 +6,7 @@ LICENSE = "PHP-3.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=99532e0f6620bc9bca34f12fadaee33c" 6LIC_FILES_CHKSUM = "file://LICENSE;md5=99532e0f6620bc9bca34f12fadaee33c"
7 7
8BBCLASSEXTEND = "native" 8BBCLASSEXTEND = "native"
9DEPENDS = "zlib bzip2 libxml2 virtual/libiconv php-native lemon-native qemu-native" 9DEPENDS = "zlib bzip2 libxml2 virtual/libiconv php-native lemon-native"
10DEPENDS:class-native = "zlib-native libxml2-native" 10DEPENDS:class-native = "zlib-native libxml2-native"
11 11
12PHP_MAJOR_VERSION = "${@d.getVar('PV').split('.')[0]}" 12PHP_MAJOR_VERSION = "${@d.getVar('PV').split('.')[0]}"
@@ -25,7 +25,6 @@ SRC_URI:append:class-target = " \
25 file://0006-ext-phar-Makefile.frag-Fix-phar-packaging.patch \ 25 file://0006-ext-phar-Makefile.frag-Fix-phar-packaging.patch \
26 file://0007-sapi-cli-config.m4-fix-build-directory.patch \ 26 file://0007-sapi-cli-config.m4-fix-build-directory.patch \
27 file://0008-ext-imap-config.m4-fix-include-paths.patch \ 27 file://0008-ext-imap-config.m4-fix-include-paths.patch \
28 file://0011-use-qemuwrapper-for-minilua.patch \
29 file://php-fpm.conf \ 28 file://php-fpm.conf \
30 file://php-fpm-apache.conf \ 29 file://php-fpm-apache.conf \
31 file://70_mod_php${PHP_MAJOR_VERSION}.conf \ 30 file://70_mod_php${PHP_MAJOR_VERSION}.conf \
@@ -33,10 +32,10 @@ SRC_URI:append:class-target = " \
33 " 32 "
34 33
35S = "${WORKDIR}/php-${PV}" 34S = "${WORKDIR}/php-${PV}"
36SRC_URI[sha256sum] = "b4886db1df322dc8fb128d8b34ae7e94f6fc682ecb29ff4f5a591d4de9feadbf" 35SRC_URI[sha256sum] = "0725ed2baea125496a898455d501a77460218b2a0cfad773fa9322f491b82b61"
37 36
38 37
39inherit autotools pkgconfig python3native gettext qemu 38inherit autotools pkgconfig python3native gettext
40 39
41# phpize is not scanned for absolute paths by default (but php-config is). 40# phpize is not scanned for absolute paths by default (but php-config is).
42# 41#
@@ -77,7 +76,7 @@ EXTRA_OECONF:class-native = " \
77 ${COMMON_EXTRA_OECONF} \ 76 ${COMMON_EXTRA_OECONF} \
78" 77"
79 78
80PACKAGECONFIG ??= "mysql sqlite3 imap opcache \ 79PACKAGECONFIG ??= "mysql sqlite3 imap opcache openssl \
81 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6 pam', d)} \ 80 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6 pam', d)} \
82" 81"
83PACKAGECONFIG:class-native = "" 82PACKAGECONFIG:class-native = ""
@@ -128,17 +127,6 @@ do_configure:prepend () {
128 find ${S} -name config.m4 | xargs -n1 sed -i 's!APXS_HTTPD=.*!APXS_HTTPD=${STAGING_SBINDIR_NATIVE}/httpd!' 127 find ${S} -name config.m4 | xargs -n1 sed -i 's!APXS_HTTPD=.*!APXS_HTTPD=${STAGING_SBINDIR_NATIVE}/httpd!'
129} 128}
130 129
131do_configure:prepend:class-target () {
132 # Write out a qemu wrapper that will be used by the makefile
133 # so that it can run minilua through that.
134 qemu_binary="${@qemu_wrapper_cmdline(d, d.getVar('STAGING_DIR_HOST'), [d.expand('${STAGING_DIR_HOST}${libdir}'),d.expand('${STAGING_DIR_HOST}${base_libdir}')])}"
135 cat > ${S}/qemuwrapper << EOF
136#!/bin/sh
137$qemu_binary "\$@"
138EOF
139 chmod +x ${S}/qemuwrapper
140}
141
142do_configure:append() { 130do_configure:append() {
143 # No, libtool, we really don't want rpath set... 131 # No, libtool, we really don't want rpath set...
144 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool 132 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool