summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorPaul Barker <pbarker@toganlabs.com>2017-11-05 22:07:27 +0000
committerArmin Kuster <akuster808@gmail.com>2017-11-15 16:34:05 -0800
commitd91f92cf042029f879feb1b9b1e4e84b4905c908 (patch)
tree16e62355995e06f6dbb80127b4c790220ad65a44 /meta-oe/recipes-devtools
parent57492d40b569f0bfbfcf351b363d76f714e41729 (diff)
downloadmeta-openembedded-d91f92cf042029f879feb1b9b1e4e84b4905c908.tar.gz
mercurial: Support building for target
Rather than trying to work out the exact python modules needed, we just add 'python-modules' to the dependencies list. If you can afford to install mercurial on target then python-modules shouldn't be too much of a burden. Signed-off-by: Paul Barker <pbarker@toganlabs.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/mercurial/mercurial_4.4.bb (renamed from meta-oe/recipes-devtools/mercurial/mercurial-native_4.4.bb)9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta-oe/recipes-devtools/mercurial/mercurial-native_4.4.bb b/meta-oe/recipes-devtools/mercurial/mercurial_4.4.bb
index 693d4e40d..90524974b 100644
--- a/meta-oe/recipes-devtools/mercurial/mercurial-native_4.4.bb
+++ b/meta-oe/recipes-devtools/mercurial/mercurial_4.4.bb
@@ -3,7 +3,11 @@ HOMEPAGE = "http://mercurial.selenic.com/"
3SECTION = "console/utils" 3SECTION = "console/utils"
4LICENSE = "GPLv2" 4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" 5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6DEPENDS = "python-native" 6DEPENDS = "python python-native"
7DEPENDS_class-native = "python-native"
8RDEPENDS_${PN} = "python python-modules"
9
10inherit python-dir
7 11
8SRC_URI = "https://www.mercurial-scm.org/release/${BP}.tar.gz" 12SRC_URI = "https://www.mercurial-scm.org/release/${BP}.tar.gz"
9SRC_URI[md5sum] = "c1d9fad1b7ed7077b0d4ae82e71154db" 13SRC_URI[md5sum] = "c1d9fad1b7ed7077b0d4ae82e71154db"
@@ -11,7 +15,7 @@ SRC_URI[sha256sum] = "234af4a67565c85923b0a1910c704ab44bcf12f69b8553268720877656
11 15
12S = "${WORKDIR}/mercurial-${PV}" 16S = "${WORKDIR}/mercurial-${PV}"
13 17
14inherit native 18BBCLASSEXTEND = "native"
15 19
16EXTRA_OEMAKE = "STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \ 20EXTRA_OEMAKE = "STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \
17 PREFIX=${prefix}" 21 PREFIX=${prefix}"
@@ -24,3 +28,4 @@ do_install () {
24 oe_runmake -e install-bin DESTDIR=${D} PREFIX=${prefix} 28 oe_runmake -e install-bin DESTDIR=${D} PREFIX=${prefix}
25} 29}
26 30
31FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"