summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorMing Liu <peter.x.liu@external.atlascopco.com>2017-08-30 17:16:29 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-09-07 10:59:21 +0200
commita966c86b5c95640f37d2e0861ec971fa2768fa11 (patch)
tree191f8da73d6127478d4a0db19f1f0e59544a297b /meta-oe/recipes-devtools
parentffc78c155c36c657c4648ee303f108b164fef4b8 (diff)
downloadmeta-openembedded-a966c86b5c95640f37d2e0861ec971fa2768fa11.tar.gz
librcf: link to libatomic
In commit 1d594f18f66700f0b2c03b7acf1104a825b155b4: [ librcf: Add -latomic to LDFLAGS ] I added '-latomic' to LDFLAGS, which worked for clang 3.9 but it does not work for clang 5.0, seems the linking order matters for clang 5.0, it should be after -lrcf. Signed-off-by: Ming Liu <peter.x.liu@external.atlascopco.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/librcf/librcf/0001-Add-CMake-build-files.patch2
-rw-r--r--meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb2
2 files changed, 1 insertions, 3 deletions
diff --git a/meta-oe/recipes-devtools/librcf/librcf/0001-Add-CMake-build-files.patch b/meta-oe/recipes-devtools/librcf/librcf/0001-Add-CMake-build-files.patch
index cd0d1433f..560c3a6d7 100644
--- a/meta-oe/recipes-devtools/librcf/librcf/0001-Add-CMake-build-files.patch
+++ b/meta-oe/recipes-devtools/librcf/librcf/0001-Add-CMake-build-files.patch
@@ -53,7 +53,7 @@ index 0000000..f6e24be
53+#################################################################### 53+####################################################################
54+INCLUDE (${CMAKE_SOURCE_DIR}/VERSION.cmake) 54+INCLUDE (${CMAKE_SOURCE_DIR}/VERSION.cmake)
55+ 55+
56+SET (LIBRCF_LIBRARIES "-lpthread -ldl") 56+SET (LIBRCF_LIBRARIES "-lpthread -ldl -latomic")
57+INCLUDE_DIRECTORIES (${CMAKE_SOURCE_DIR}/include) 57+INCLUDE_DIRECTORIES (${CMAKE_SOURCE_DIR}/include)
58+ 58+
59+IF (LIBRCF_USE_OPENSSL) 59+IF (LIBRCF_USE_OPENSSL)
diff --git a/meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb b/meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb
index 46b75c514..43eff72a3 100644
--- a/meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb
+++ b/meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb
@@ -23,8 +23,6 @@ SRC_URI[sha256sum] = "bbfcc88de502c39604878c395f516b03fff4eac63eb4f7f44c07d43383
23 23
24S = "${WORKDIR}/RCF-${PV}" 24S = "${WORKDIR}/RCF-${PV}"
25 25
26LDFLAGS += "-Wl,--as-needed -latomic -Wl,--no-as-needed"
27
28inherit cmake dos2unix 26inherit cmake dos2unix
29 27
30PACKAGECONFIG ?= "zlib openssl sf-serialization boost-filesystem boost-asio protobuf json dll static shared demos" 28PACKAGECONFIG ?= "zlib openssl sf-serialization boost-filesystem boost-asio protobuf json dll static shared demos"