diff options
author | Noor Ahsan <noor_ahsan@mentor.com> | 2011-09-06 20:17:58 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-09-07 10:38:26 +0200 |
commit | 5e2cdae237f2093f9b592277c9419b6f0275feb5 (patch) | |
tree | aa80870f571610136e1a8eb681c9270061df5f47 /meta-oe/recipes-devtools | |
parent | cdff22f41acca435f909cc4f564e254daf8bff9e (diff) | |
download | meta-openembedded-5e2cdae237f2093f9b592277c9419b6f0275feb5.tar.gz |
python-lxml: Add version 2.2.8 (initial recipe)
* Imported from oe.dev commit id bc6a94559157e6fcc190a22a259c0f757b8664ae.
* Getting "skipping incompatible libraries" message in compilation log. Fixed that issue by changing --with-xml2-config=${STAGING_BINDIR_NATIVE}/xml2-config to --with-xml2-config=${STAGING_BINDIR_CROSS}/xml2-config.
* Added BBCLASSEXTEND native and nativesdk for native recipe.
* Tested with MACHINE = 'qemuppc'
Signed-off-by: Noor Ahsan <noor_ahsan@mentor.com>
Reviewed-by: Paul Menzel <paulepanter@users.sourceforge.net>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r-- | meta-oe/recipes-devtools/python/python-lxml_2.2.8.bb | 33 |
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-lxml_2.2.8.bb b/meta-oe/recipes-devtools/python/python-lxml_2.2.8.bb new file mode 100644 index 000000000..e19c77635 --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-lxml_2.2.8.bb | |||
@@ -0,0 +1,33 @@ | |||
1 | DESCRIPTION = "Powerful and Pythonic XML processing library combining \ | ||
2 | libxml2/libxslt with the ElementTree API." | ||
3 | HOMEPAGE = "http://codespeak.net/lxml" | ||
4 | LICENSE = "BSD" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=7de92baeb3b7bfaebe72404155fdb346" | ||
6 | SRCNAME = "lxml" | ||
7 | |||
8 | DEPENDS = "libxml2 libxslt" | ||
9 | RDEPENDS_${PN} += "libxml2 libxslt python-compression" | ||
10 | |||
11 | SRC_URI = "http://pypi.python.org/packages/source/l/${SRCNAME}/${SRCNAME}-${PV}.tar.gz;name=lxml" | ||
12 | SRC_URI[lxml.md5sum] = "d6c612d63a84d79440912a1b29d3b981" | ||
13 | SRC_URI[lxml.sha256sum] = "89b73925b5e3295dcf4675cb948007a20eb029fe35c9a162ae19ec11f1abafe5" | ||
14 | |||
15 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
16 | |||
17 | inherit setuptools | ||
18 | |||
19 | DISTUTILS_BUILD_ARGS += " \ | ||
20 | --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \ | ||
21 | --with-xml2-config='${STAGING_BINDIR_CROSS}/xml2-config' \ | ||
22 | " | ||
23 | |||
24 | DISTUTILS_INSTALL_ARGS += " \ | ||
25 | --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \ | ||
26 | --with-xml2-config='${STAGING_BINDIR_CROSS}/xml2-config' \ | ||
27 | " | ||
28 | |||
29 | BBCLASSEXTEND = "native nativesdk" | ||
30 | RDEPENDS_${PN}_virtclass-native = "libxml2-native libxslt-native" | ||
31 | |||
32 | |||
33 | |||