summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorAlex Kiernan <alex.kiernan@gmail.com>2019-01-29 12:36:06 +0000
committerKhem Raj <raj.khem@gmail.com>2019-01-30 13:34:49 -0800
commit9ada8b1306dad1a4675765b6ea54f1eb390c13dc (patch)
tree1d4d768ba9678a6ee1f01a4ab6bfe9896ecd6bcc /meta-oe/recipes-devtools
parentac179bc18eddaa2e10191908e5518c9f94346d81 (diff)
downloadmeta-openembedded-9ada8b1306dad1a4675765b6ea54f1eb390c13dc.tar.gz
jq: update to 1.6
Drop backported patch as it's present in 1.6. Switch to autotools-brokensep to avoid | sed -e 's/\\/\\\\/g' -e 's/"/\\"/g' -e 's/^/"/' -e 's/$/\\n"/' ../jq-1.6/src/builtin.jq > src/builtin.inc | /bin/sh: src/builtin.inc: No such file or directory License-Update: whitespace changes Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/jq/jq/Support-without-oniguruma.patch68
-rw-r--r--meta-oe/recipes-devtools/jq/jq_1.6.bb (renamed from meta-oe/recipes-devtools/jq/jq_1.5.bb)9
2 files changed, 4 insertions, 73 deletions
diff --git a/meta-oe/recipes-devtools/jq/jq/Support-without-oniguruma.patch b/meta-oe/recipes-devtools/jq/jq/Support-without-oniguruma.patch
deleted file mode 100644
index 1dfd955f0..000000000
--- a/meta-oe/recipes-devtools/jq/jq/Support-without-oniguruma.patch
+++ /dev/null
@@ -1,68 +0,0 @@
1From 18b4b18b41f5ed396d73449ce8d6ec408d95d6b2 Mon Sep 17 00:00:00 2001
2From: David Tolnay <dtolnay@gmail.com>
3Date: Sat, 21 Nov 2015 10:05:37 -0800
4Subject: [PATCH] Support --without-oniguruma
5
6Upstream-Status: Backport
7
8Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
9
10---
11 configure.ac | 41 ++++++++++++++++++++---------------------
12 1 file changed, 20 insertions(+), 21 deletions(-)
13
14diff --git a/configure.ac b/configure.ac
15index 9e2c8cf..7f6be34 100644
16--- a/configure.ac
17+++ b/configure.ac
18@@ -52,27 +52,26 @@ fi
19 AC_ARG_WITH([oniguruma],
20 [AS_HELP_STRING([--with-oniguruma=prefix],
21 [try this for a non-standard install prefix of the oniguruma library])],
22- [ONIGURUMAPATHSET=1],
23- [ONIGURUMAPATHSET=0])
24-
25-if test $ONIGURUMAPATHSET = 1; then
26- CFLAGS="$CFLAGS -I${with_oniguruma}/include"
27- LDFLAGS="$LDFLAGS -L${with_oniguruma}/lib"
28-fi
29-
30-# check for ONIGURUMA library
31-HAVE_ONIGURUMA=0
32-AC_CHECK_HEADER("oniguruma.h",
33- AC_CHECK_LIB([onig],[onig_version],[LIBS="$LIBS -lonig"; HAVE_ONIGURUMA=1;]))
34-
35-# handle check results
36-if test $HAVE_ONIGURUMA != 1; then
37- AC_MSG_NOTICE([Oniguruma was not found.])
38- AC_MSG_NOTICE([ Try setting the location using '--with-oniguruma=PREFIX' ])
39-else
40- AC_DEFINE([HAVE_ONIGURUMA],1,[Define to 1 if Oniguruma is installed])
41-fi
42-
43+ [],
44+ [with_oniguruma=yes])
45+
46+AS_IF([test "x$with_oniguruma" != xno], [
47+ AS_IF([test "x$with_oniguruma" != xyes], [
48+ CFLAGS="$CFLAGS -I${with_oniguruma}/include"
49+ LDFLAGS="$LDFLAGS -L${with_oniguruma}/lib"
50+ ])
51+ # check for ONIGURUMA library
52+ have_oniguruma=0
53+ AC_CHECK_HEADER("oniguruma.h",
54+ AC_CHECK_LIB([onig],[onig_version],[LIBS="$LIBS -lonig"; have_oniguruma=1;]))
55+ # handle check results
56+ AS_IF([test $have_oniguruma = 1], [
57+ AC_DEFINE([HAVE_ONIGURUMA], 1, [Define to 1 if Oniguruma is installed])
58+ ], [
59+ AC_MSG_NOTICE([Oniguruma was not found.])
60+ AC_MSG_NOTICE([Try setting the location using '--with-oniguruma=PREFIX'])
61+ ])
62+])
63
64 dnl Check for valgrind
65 AC_CHECK_PROGS(valgrind_cmd, valgrind)
66--
671.9.1
68
diff --git a/meta-oe/recipes-devtools/jq/jq_1.5.bb b/meta-oe/recipes-devtools/jq/jq_1.6.bb
index 0f40815cc..0086eae5c 100644
--- a/meta-oe/recipes-devtools/jq/jq_1.5.bb
+++ b/meta-oe/recipes-devtools/jq/jq_1.6.bb
@@ -6,16 +6,15 @@ HOMEPAGE = "https://stedolan.github.io/jq/"
6BUGTRACKER = "https://github.com/stedolan/jq/issues" 6BUGTRACKER = "https://github.com/stedolan/jq/issues"
7SECTION = "utils" 7SECTION = "utils"
8LICENSE = "MIT" 8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://COPYING;md5=29dd0c35d7e391bb8d515eacf7592e00" 9LIC_FILES_CHKSUM = "file://COPYING;md5=15d03e360fa7399f76d5a4359fc72cbf"
10 10
11SRC_URI = "https://github.com/stedolan/${BPN}/releases/download/${BP}/${BP}.tar.gz \ 11SRC_URI = "https://github.com/stedolan/${BPN}/releases/download/${BP}/${BP}.tar.gz \
12 file://Support-without-oniguruma.patch \
13" 12"
14 13
15SRC_URI[md5sum] = "0933532b086bd8b6a41c1b162b1731f9" 14SRC_URI[md5sum] = "e68fbd6a992e36f1ac48c99bbf825d6b"
16SRC_URI[sha256sum] = "c4d2bfec6436341113419debf479d833692cc5cdab7eb0326b5a4d4fbe9f493c" 15SRC_URI[sha256sum] = "5de8c8e29aaa3fb9cc6b47bb27299f271354ebb72514e3accadc7d38b5bbaa72"
17 16
18inherit autotools 17inherit autotools-brokensep
19 18
20PACKAGECONFIG ?= "oniguruma" 19PACKAGECONFIG ?= "oniguruma"
21 20