diff options
author | Viktor Rosendahl <Viktor.Rosendahl@bmw.de> | 2020-02-17 17:39:35 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-02-17 11:09:49 -0800 |
commit | 416c4f7d5bc9cd129102923f6ab01e432403ed5f (patch) | |
tree | 662aacb59089d56d2809c87c6cdaafa2a694b3d6 /meta-oe/recipes-devtools | |
parent | cbe0b43010a870c2943358a5173731f4baaa2064 (diff) | |
download | meta-openembedded-416c4f7d5bc9cd129102923f6ab01e432403ed5f.tar.gz |
perl: Add libperlio-gzip-perl and libjson-perl
We need to add these perl modules in order to make lcov compatible
with gcc9.
Signed-off-by: Viktor Rosendahl <Viktor.Rosendahl@bmw.de>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r-- | meta-oe/recipes-devtools/perl/libjson-perl_4.02000.bb | 22 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/perl/libperlio-gzip-perl_0.20.bb | 30 |
2 files changed, 52 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/perl/libjson-perl_4.02000.bb b/meta-oe/recipes-devtools/perl/libjson-perl_4.02000.bb new file mode 100644 index 000000000..4e5a8a6ff --- /dev/null +++ b/meta-oe/recipes-devtools/perl/libjson-perl_4.02000.bb | |||
@@ -0,0 +1,22 @@ | |||
1 | SUMMARY = "Perl module to decode/encode json files" | ||
2 | DESCRIPTION = "This package contains the JSON.pm module with friends. \ | ||
3 | The module implements JSON encode/decode." | ||
4 | |||
5 | HOMEPAGE = "https://metacpan.org/pod/JSON" | ||
6 | SECTION = "libs" | ||
7 | LICENSE = "Artistic-1.0 | GPL-1.0+" | ||
8 | LIC_FILES_CHKSUM = "file://README;beginline=1171;endline=1176;md5=3be2cb8159d094768e67386c453e8bbe" | ||
9 | |||
10 | DEPENDS += "perl" | ||
11 | |||
12 | SRC_URI = "git://github.com/makamaka/JSON.git;protocol=https" | ||
13 | |||
14 | SRCREV = "42a6324df654e92419512cee80c0b49155d9e56d" | ||
15 | |||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | inherit cpan | ||
19 | |||
20 | RDEPENDS_${PN} += "perl" | ||
21 | |||
22 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-oe/recipes-devtools/perl/libperlio-gzip-perl_0.20.bb b/meta-oe/recipes-devtools/perl/libperlio-gzip-perl_0.20.bb new file mode 100644 index 000000000..ffe7a7d99 --- /dev/null +++ b/meta-oe/recipes-devtools/perl/libperlio-gzip-perl_0.20.bb | |||
@@ -0,0 +1,30 @@ | |||
1 | SUMMARY = "Perl module to manipulate and access gzip files" | ||
2 | DESCRIPTION = "This package contains the gzip.pm module with friends. \ | ||
3 | The module implements perlio layer for gzip." | ||
4 | |||
5 | HOMEPAGE = "https://metacpan.org/pod/PerlIO::gzip" | ||
6 | SECTION = "libs" | ||
7 | LICENSE = "Artistic-1.0 | GPL-1.0+" | ||
8 | LIC_FILES_CHKSUM = "file://README;beginline=55;endline=61;md5=bc3da2dec1fbea59ac91172c5e0eb837" | ||
9 | |||
10 | DEPENDS += "perl" | ||
11 | |||
12 | SRC_URI = "https://cpan.metacpan.org/authors/id/N/NW/NWCLARK/PerlIO-gzip-${PV}.tar.gz" | ||
13 | |||
14 | SRC_URI[md5sum] = "0393eae5d0b23df6cf40ed44af7d711c" | ||
15 | SRC_URI[sha256sum] = "4848679a3f201e3f3b0c5f6f9526e602af52923ffa471a2a3657db786bd3bdc5" | ||
16 | |||
17 | S = "${WORKDIR}/PerlIO-gzip-${PV}" | ||
18 | |||
19 | EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}" | ||
20 | |||
21 | inherit cpan | ||
22 | |||
23 | do_compile() { | ||
24 | export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" | ||
25 | cpan_do_compile | ||
26 | } | ||
27 | |||
28 | RDEPENDS_${PN} += "perl perl-module-perlio" | ||
29 | |||
30 | BBCLASSEXTEND = "native nativesdk" | ||