summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-10-13 12:43:09 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-10-23 12:53:22 +0200
commit796f9ba6a6e3ba9d315b62d8e9f7f0873fe95b7c (patch)
tree0f4447e09be8fa7febe3c9d8f88c1206503e5f16 /meta-oe/recipes-devtools
parent29e99a67da917efe3f7c41a4701fa78334ab4df5 (diff)
downloadmeta-openembedded-796f9ba6a6e3ba9d315b62d8e9f7f0873fe95b7c.tar.gz
debootstrap: cleanup the recipe
* FILESEXTRAPATHS_prepend isn't needed * ${PN}-${PV} -> ${BP} * drop autotools, it doesn't use autotools, there is just a Makefile * use SUMMARY instead of DESCRIPTION Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/debootstrap/debootstrap_1.0.67.bb26
1 files changed, 18 insertions, 8 deletions
diff --git a/meta-oe/recipes-devtools/debootstrap/debootstrap_1.0.67.bb b/meta-oe/recipes-devtools/debootstrap/debootstrap_1.0.67.bb
index 8e4a988e5..73dea9b82 100644
--- a/meta-oe/recipes-devtools/debootstrap/debootstrap_1.0.67.bb
+++ b/meta-oe/recipes-devtools/debootstrap/debootstrap_1.0.67.bb
@@ -1,12 +1,10 @@
1DESCRIPTION = "Install a Debian system into a subdirectory" 1SUMMARY = "Install a Debian system into a subdirectory"
2HOMEPAGE = "https://wiki.debian.org/Debootstrap" 2HOMEPAGE = "https://wiki.debian.org/Debootstrap"
3SECTION = "devel" 3SECTION = "devel"
4LICENSE = "debootstrap-custom-license" 4LICENSE = "debootstrap-custom-license"
5LIC_FILES_CHKSUM = "file://debian/copyright;md5=1e68ced6e1689d4cd9dac75ff5225608" 5LIC_FILES_CHKSUM = "file://debian/copyright;md5=1e68ced6e1689d4cd9dac75ff5225608"
6 6
7inherit autotools pkgconfig 7inherit pkgconfig
8
9FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
10 8
11SRC_URI = "\ 9SRC_URI = "\
12 http://http.debian.net/debian/pool/main/d/debootstrap/debootstrap_1.0.67.tar.gz \ 10 http://http.debian.net/debian/pool/main/d/debootstrap/debootstrap_1.0.67.tar.gz \
@@ -16,9 +14,21 @@ SRC_URI = "\
16SRC_URI[md5sum] = "eacabfe2e45415af60b1d74c3a23418a" 14SRC_URI[md5sum] = "eacabfe2e45415af60b1d74c3a23418a"
17SRC_URI[sha256sum] = "0a12e0a2bbff185d47711a716b1f2734856100e8784361203e834fed0cffa51b" 15SRC_URI[sha256sum] = "0a12e0a2bbff185d47711a716b1f2734856100e8784361203e834fed0cffa51b"
18 16
19S = "${WORKDIR}/${PN}-${PV}" 17S = "${WORKDIR}/${BP}"
18
19# All Makefile does is creation of devices.tar.gz, which fails in OE build, we use
20# static devices.tar.gz as work around
21# | NOTE: make -j 8 -e MAKEFLAGS=
22# | rm -rf dev
23# | mkdir -p dev
24# | chown 0:0 dev
25# | chown: changing ownership of `dev': Operation not permitted
26# | make: *** [devices.tar.gz] Error 1
27# | WARNING: exit code 1 from a shell command.
28do_compile_prepend() {
29 cp ${WORKDIR}/devices.tar.gz ${B}
30}
20 31
21do_install_prepend() { 32do_install() {
22 cp ${WORKDIR}/devices.tar.gz ${S} 33 oe_runmake 'DESTDIR=${D}' install
23 cd "${S}"
24} 34}