summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2015-06-11 16:26:55 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-06-17 22:36:11 +0200
commit73bd1cdf74b7f020eddc143979d847eb113bb7c0 (patch)
tree3b35c6d48f74ce54196b6d63768dd39ba4a192ee /meta-oe/recipes-devtools
parenta8b76a264155f4b9f6ba1bebe3ac87640a6f35ed (diff)
downloadmeta-openembedded-73bd1cdf74b7f020eddc143979d847eb113bb7c0.tar.gz
pm-qa: fix PN -> BPN for multilib
Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/pm-qa/pm-qa_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-oe/recipes-devtools/pm-qa/pm-qa_git.bb b/meta-oe/recipes-devtools/pm-qa/pm-qa_git.bb
index 66804dd5b..7322df8e7 100644
--- a/meta-oe/recipes-devtools/pm-qa/pm-qa_git.bb
+++ b/meta-oe/recipes-devtools/pm-qa/pm-qa_git.bb
@@ -28,7 +28,7 @@ do_compile () {
28 28
29do_install () { 29do_install () {
30 install -d ${D}${bindir} 30 install -d ${D}${bindir}
31 install -d ${D}${libdir}/${PN} 31 install -d ${D}${libdir}/${BPN}
32 32
33 # Install the compiled binaries that were built in the previous step 33 # Install the compiled binaries that were built in the previous step
34 for x in `find . -name "*.c"` 34 for x in `find . -name "*.c"`
@@ -45,7 +45,7 @@ do_install () {
45 sed -i -e 's#..\/utils\/##' ${script} 45 sed -i -e 's#..\/utils\/##' ${script}
46 46
47 script_basename=`basename ${script}` 47 script_basename=`basename ${script}`
48 install -m 0755 $script ${D}${libdir}/${PN}/${script_basename} 48 install -m 0755 $script ${D}${libdir}/${BPN}/${script_basename}
49 done 49 done
50 50
51 # Install the shell scripts NOT in the $libdir directory since those 51 # Install the shell scripts NOT in the $libdir directory since those
@@ -55,7 +55,7 @@ do_install () {
55 # if the script includes any helper scripts from the $libdir 55 # if the script includes any helper scripts from the $libdir
56 # directory then change the source path to the absolute path 56 # directory then change the source path to the absolute path
57 # to reflect the install location of the helper scripts. 57 # to reflect the install location of the helper scripts.
58 sed -i -e "s#source ../include#source ${libdir}/${PN}#g" ${script} 58 sed -i -e "s#source ../include#source ${libdir}/${BPN}#g" ${script}
59 # Remove hardcoded relative paths 59 # Remove hardcoded relative paths
60 sed -i -e 's#..\/utils\/##' ${script} 60 sed -i -e 's#..\/utils\/##' ${script}
61 61