diff options
author | Paul Eggleton <paul.eggleton@linux.intel.com> | 2013-08-28 10:43:24 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-09-03 19:12:37 +0200 |
commit | ad185f4494fff1254bfa167d6715db7be5a2de04 (patch) | |
tree | 8ce9cca555b61157443539b6298dc417fa495d3d /meta-oe/recipes-devtools | |
parent | bbf1026bd2004667d8e12a10f1bb333e73be39e3 (diff) | |
download | meta-openembedded-ad185f4494fff1254bfa167d6715db7be5a2de04.tar.gz |
vala: remove
This is now in OE-Core as of 649b48557d8702daaf4f28482848ab0b07abed83.
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
3 files changed, 0 insertions, 81 deletions
diff --git a/meta-oe/recipes-devtools/vala/vala-0.16.0/0001-git-version-gen-don-t-append-dirty-if-we-re-not-in-g.patch b/meta-oe/recipes-devtools/vala/vala-0.16.0/0001-git-version-gen-don-t-append-dirty-if-we-re-not-in-g.patch deleted file mode 100644 index e6c7941a7..000000000 --- a/meta-oe/recipes-devtools/vala/vala-0.16.0/0001-git-version-gen-don-t-append-dirty-if-we-re-not-in-g.patch +++ /dev/null | |||
@@ -1,53 +0,0 @@ | |||
1 | From 2460d7b79f7e90dcfeebde5e9c53d9b6798a1f3c Mon Sep 17 00:00:00 2001 | ||
2 | From: Martin Jansa <Martin.Jansa@gmail.com> | ||
3 | Date: Tue, 21 Feb 2012 17:12:50 +0100 | ||
4 | Subject: [PATCH] git-version-gen: don't append -dirty if we're not in git | ||
5 | repo | ||
6 | |||
7 | * for example if we have some dirty directory and we unpack clean vala tarball in it, then it will append -dirty | ||
8 | |||
9 | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | ||
10 | --- | ||
11 | build-aux/git-version-gen | 25 ++++++++++++++----------- | ||
12 | 1 files changed, 14 insertions(+), 11 deletions(-) | ||
13 | |||
14 | diff --git a/build-aux/git-version-gen b/build-aux/git-version-gen | ||
15 | index 0fa6faa..1d1f9d2 100755 | ||
16 | --- a/build-aux/git-version-gen | ||
17 | +++ b/build-aux/git-version-gen | ||
18 | @@ -126,18 +126,21 @@ fi | ||
19 | |||
20 | v=`echo "$v" |sed 's/^v//'` | ||
21 | |||
22 | -# Don't declare a version "dirty" merely because a time stamp has changed. | ||
23 | -git status > /dev/null 2>&1 | ||
24 | +if test -d .git | ||
25 | +then | ||
26 | + # Don't declare a version "dirty" merely because a time stamp has changed. | ||
27 | + git status > /dev/null 2>&1 | ||
28 | |||
29 | -dirty=`sh -c 'git diff-index --name-only HEAD' 2>/dev/null` || dirty= | ||
30 | -case "$dirty" in | ||
31 | - '') ;; | ||
32 | - *) # Append the suffix only if there isn't one already. | ||
33 | - case $v in | ||
34 | - *-dirty) ;; | ||
35 | - *) v="$v-dirty" ;; | ||
36 | - esac ;; | ||
37 | -esac | ||
38 | + dirty=`sh -c 'git diff-index --name-only HEAD' 2>/dev/null` || dirty= | ||
39 | + case "$dirty" in | ||
40 | + '') ;; | ||
41 | + *) # Append the suffix only if there isn't one already. | ||
42 | + case $v in | ||
43 | + *-dirty) ;; | ||
44 | + *) v="$v-dirty" ;; | ||
45 | + esac ;; | ||
46 | + esac | ||
47 | +fi | ||
48 | |||
49 | # Omit the trailing newline, so that m4_esyscmd can use the result directly. | ||
50 | echo "$v" | tr -d '\012' | ||
51 | -- | ||
52 | 1.7.8.4 | ||
53 | |||
diff --git a/meta-oe/recipes-devtools/vala/vala.inc b/meta-oe/recipes-devtools/vala/vala.inc deleted file mode 100644 index 6cdc6053b..000000000 --- a/meta-oe/recipes-devtools/vala/vala.inc +++ /dev/null | |||
@@ -1,20 +0,0 @@ | |||
1 | DESCRIPTION = "Vala is a C#-like language dedicated to ease GObject programming. \ | ||
2 | Vala compiles to plain C and has no runtime environment nor penalities whatsoever." | ||
3 | SECTION = "devel" | ||
4 | DEPENDS = "glib-2.0 dbus gtk+" | ||
5 | BBCLASSEXTEND = "native" | ||
6 | DEPENDS_virtclass-native = "glib-2.0-native dbus-native" | ||
7 | HOMEPAGE = "http://vala-project.org" | ||
8 | LICENSE = "LGPLv2.1" | ||
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24" | ||
10 | INC_PR = "r1" | ||
11 | |||
12 | SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}" | ||
13 | |||
14 | SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/${BPN}/${SHRT_VER}/${BP}.tar.xz" | ||
15 | inherit autotools | ||
16 | |||
17 | EXTRA_OECONF = "--disable-vapigen" | ||
18 | |||
19 | FILES_${PN}-doc += "${datadir}/devhelp" | ||
20 | FILES_${PN} += "${datadir}/${BPN}-${SHRT_VER}/vapi" | ||
diff --git a/meta-oe/recipes-devtools/vala/vala_0.16.0.bb b/meta-oe/recipes-devtools/vala/vala_0.16.0.bb deleted file mode 100644 index 92120b4a3..000000000 --- a/meta-oe/recipes-devtools/vala/vala_0.16.0.bb +++ /dev/null | |||
@@ -1,8 +0,0 @@ | |||
1 | require ${BPN}.inc | ||
2 | |||
3 | PR = "${INC_PR}.1" | ||
4 | |||
5 | SRC_URI += " file://0001-git-version-gen-don-t-append-dirty-if-we-re-not-in-g.patch" | ||
6 | |||
7 | SRC_URI[md5sum] = "84b742e9cca4c90fde3026c3793c03c1" | ||
8 | SRC_URI[sha256sum] = "3adb37aa2b35e2e2daed47552e85dbcbf752c0f7768b269d856993620073a657" | ||