diff options
author | André Draszik <andre.draszik@jci.com> | 2020-03-03 18:22:36 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-03-03 11:40:40 -0800 |
commit | 754b54699b881459eda3eaf4e2ba893e85b76abf (patch) | |
tree | c1a3cdff50127af19bce7bec8d9cecac37456317 /meta-oe/recipes-devtools | |
parent | d5cf4a0041d1c53ebb2c9baa5b3a17c6af41b5b9 (diff) | |
download | meta-openembedded-754b54699b881459eda3eaf4e2ba893e85b76abf.tar.gz |
nodejs: drop 'gyp' PACKAGECONFIG
During the python3 / nodejs update, the dependencies weren't updated, so
using system-gyp ends up trying to use the python2 version of system-
gyp, which will of course fail.
Fixing this to depend on the python3 version of gyp still doesn't
doesn't make things work, though:
ERROR: nodejs-native-12.14.1-r0 do_configure: Execution of '.../nodejs-native/12.14.1-r0/temp/run.do_configure.26054' failed with exit code 1:
gyp: Error importing pymod_do_mainmodule (ForEachFormat): No module named 'ForEachFormat' while loading dependencies of .../nodejs-native/12.14.1-r0/node-v12.14.1/node.gyp while trying to load .../nodejs-native/12.14.1-r0/node-v12.14.1/node.gyp
Error running GYP
The reason is commit fff922afee6e ("deps,build: compute torque_outputs in v8.gyp")
in NodeJS v12, where they modified their bundled version of gyp to
become incompatible with the upstream version of gyp by adding extra /
unusual search paths to gyp.
Since I'm not sure how to deal with that when using system-gyp, and because
the original intention for using system-gyp was to make the previous nodejs
version compatible with python3 by ultimately switching to the python3 version
of system-gyp which isn't necessary anymore, and given nobody else seems to
be using this PACKAGECONFIG, just drop it.
Signed-off-by: André Draszik <andre.draszik@jci.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r-- | meta-oe/recipes-devtools/nodejs/nodejs_12.14.1.bb | 3 |
1 files changed, 0 insertions, 3 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_12.14.1.bb b/meta-oe/recipes-devtools/nodejs/nodejs_12.14.1.bb index 6eb52c209..49bb71e28 100644 --- a/meta-oe/recipes-devtools/nodejs/nodejs_12.14.1.bb +++ b/meta-oe/recipes-devtools/nodejs/nodejs_12.14.1.bb | |||
@@ -53,7 +53,6 @@ ARCHFLAGS ?= "" | |||
53 | 53 | ||
54 | PACKAGECONFIG ??= "ares icu libuv zlib" | 54 | PACKAGECONFIG ??= "ares icu libuv zlib" |
55 | PACKAGECONFIG[ares] = "--shared-cares,,c-ares" | 55 | PACKAGECONFIG[ares] = "--shared-cares,,c-ares" |
56 | PACKAGECONFIG[gyp] = ",,gyp-py2-native" | ||
57 | PACKAGECONFIG[icu] = "--with-intl=system-icu,--without-intl,icu" | 56 | PACKAGECONFIG[icu] = "--with-intl=system-icu,--without-intl,icu" |
58 | PACKAGECONFIG[libuv] = "--shared-libuv,,libuv" | 57 | PACKAGECONFIG[libuv] = "--shared-libuv,,libuv" |
59 | PACKAGECONFIG[nghttp2] = "--shared-nghttp2,,nghttp2" | 58 | PACKAGECONFIG[nghttp2] = "--shared-nghttp2,,nghttp2" |
@@ -82,8 +81,6 @@ python do_unpack() { | |||
82 | shutil.rmtree(d.getVar('S') + '/deps/openssl', True) | 81 | shutil.rmtree(d.getVar('S') + '/deps/openssl', True) |
83 | if 'ares' in d.getVar('PACKAGECONFIG'): | 82 | if 'ares' in d.getVar('PACKAGECONFIG'): |
84 | shutil.rmtree(d.getVar('S') + '/deps/cares', True) | 83 | shutil.rmtree(d.getVar('S') + '/deps/cares', True) |
85 | if 'gyp' in d.getVar('PACKAGECONFIG'): | ||
86 | shutil.rmtree(d.getVar('S') + '/tools/gyp', True) | ||
87 | if 'libuv' in d.getVar('PACKAGECONFIG'): | 84 | if 'libuv' in d.getVar('PACKAGECONFIG'): |
88 | shutil.rmtree(d.getVar('S') + '/deps/uv', True) | 85 | shutil.rmtree(d.getVar('S') + '/deps/uv', True) |
89 | if 'nghttp2' in d.getVar('PACKAGECONFIG'): | 86 | if 'nghttp2' in d.getVar('PACKAGECONFIG'): |