diff options
author | Philip Balister <philip@balister.org> | 2014-03-31 16:05:29 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-04-20 10:51:37 +0200 |
commit | 6041efb6022f11a9f7bd80a9b13584477977180a (patch) | |
tree | 7fff7f8889a6a26f0bca489657a3a4480bbecfef /meta-oe/recipes-devtools | |
parent | 8df46686a8e3cc8a9b1681d6d47b898ab937d998 (diff) | |
download | meta-openembedded-6041efb6022f11a9f7bd80a9b13584477977180a.tar.gz |
swig: Update to version 2.0.12 and fix cmake find swig issue.
* Dropped PR and PR_INC due to PV change.
* The cmake rule looks for swig2.0. For the sdk case, the host distro
may have a swig2.0 installed. If so the sdk would find the host swig. This
updates the sdk so it also has a swig2.0 soft linked to the swig binary in
the sdk.
Signed-off-by: Philip Balister <philip@balister.org>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r-- | meta-oe/recipes-devtools/swig/swig.inc | 5 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/swig/swig_2.0.10.bb | 9 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/swig/swig_2.0.12.bb | 7 |
3 files changed, 11 insertions, 10 deletions
diff --git a/meta-oe/recipes-devtools/swig/swig.inc b/meta-oe/recipes-devtools/swig/swig.inc index 8e83526d9..52ef9a620 100644 --- a/meta-oe/recipes-devtools/swig/swig.inc +++ b/meta-oe/recipes-devtools/swig/swig.inc | |||
@@ -6,7 +6,6 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=e7807a6282784a7dde4c846626b08fc6 \ | |||
6 | file://LICENSE-UNIVERSITIES;md5=8ce9dcc8f7c994de4a408b205c72ba08" | 6 | file://LICENSE-UNIVERSITIES;md5=8ce9dcc8f7c994de4a408b205c72ba08" |
7 | 7 | ||
8 | SECTION = "devel" | 8 | SECTION = "devel" |
9 | INC_PR = "r3" | ||
10 | 9 | ||
11 | DEPENDS = "libpcre python" | 10 | DEPENDS = "libpcre python" |
12 | 11 | ||
@@ -50,3 +49,7 @@ do_configure() { | |||
50 | oe_runconf | 49 | oe_runconf |
51 | } | 50 | } |
52 | 51 | ||
52 | do_install_append_class-nativesdk() { | ||
53 | cd ${D}${bindir} | ||
54 | ln -s swig swig2.0 | ||
55 | } | ||
diff --git a/meta-oe/recipes-devtools/swig/swig_2.0.10.bb b/meta-oe/recipes-devtools/swig/swig_2.0.10.bb deleted file mode 100644 index 312ce1151..000000000 --- a/meta-oe/recipes-devtools/swig/swig_2.0.10.bb +++ /dev/null | |||
@@ -1,9 +0,0 @@ | |||
1 | require ${BPN}.inc | ||
2 | |||
3 | PR = "${INC_PR}.0" | ||
4 | |||
5 | SRC_URI += "file://0001-Use-proc-self-exe-for-swig-swiglib-on-non-Win32-plat.patch" | ||
6 | |||
7 | SRC_URI[md5sum] = "6d5e7ad05b4a404e5e85db9befb70c9a" | ||
8 | SRC_URI[sha256sum] = "d1eef329e867124ce60838b5ad07c763146b6c8f250dd22a861ead7406f78e63" | ||
9 | |||
diff --git a/meta-oe/recipes-devtools/swig/swig_2.0.12.bb b/meta-oe/recipes-devtools/swig/swig_2.0.12.bb new file mode 100644 index 000000000..0fbcfa1bf --- /dev/null +++ b/meta-oe/recipes-devtools/swig/swig_2.0.12.bb | |||
@@ -0,0 +1,7 @@ | |||
1 | require ${BPN}.inc | ||
2 | |||
3 | SRC_URI += "file://0001-Use-proc-self-exe-for-swig-swiglib-on-non-Win32-plat.patch" | ||
4 | |||
5 | SRC_URI[md5sum] = "c3fb0b2d710cc82ed0154b91e43085a4" | ||
6 | SRC_URI[sha256sum] = "65e13f22a60cecd7279c59882ff8ebe1ffe34078e85c602821a541817a4317f7" | ||
7 | |||