diff options
author | Marko Lindqvist <cazfi74@gmail.com> | 2012-11-28 21:03:53 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2012-12-16 21:11:44 +0100 |
commit | 4e6bd189c52bc5376a853919b584661661118581 (patch) | |
tree | d35af40728065b73f27afb571e7bbf7b594dd881 /meta-oe/recipes-devtools | |
parent | 31ff8c0cb7e8525ded97ed664871f944a8812544 (diff) | |
download | meta-openembedded-4e6bd189c52bc5376a853919b584661661118581.tar.gz |
lua: update to upstream version 5.1.5
* COPYRIGHT: md5sum changed only because (C) years now up to 2012.
* MJ: removed trailing whitespaces
Signed-off-by: Marko Lindqvist <cazfi74@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r-- | meta-oe/recipes-devtools/lua/lua5.1/bitwise_operators.patch | 143 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/lua/lua5.1/lua5.1.pc | 2 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/lua/lua5.1_5.1.5.bb (renamed from meta-oe/recipes-devtools/lua/lua5.1_5.1.4.bb) | 9 |
3 files changed, 69 insertions, 85 deletions
diff --git a/meta-oe/recipes-devtools/lua/lua5.1/bitwise_operators.patch b/meta-oe/recipes-devtools/lua/lua5.1/bitwise_operators.patch index 138a2bd54a..4f0331ebb6 100644 --- a/meta-oe/recipes-devtools/lua/lua5.1/bitwise_operators.patch +++ b/meta-oe/recipes-devtools/lua/lua5.1/bitwise_operators.patch | |||
@@ -1,8 +1,7 @@ | |||
1 | Index: lua-5.1.4/src/lcode.c | 1 | diff -Nurd lua-5.1.5/src/lcode.c lua-5.1.5/src/lcode.c |
2 | =================================================================== | 2 | --- lua-5.1.5/src/lcode.c 2011-01-31 16:53:16.000000000 +0200 |
3 | --- lua-5.1.4.orig/src/lcode.c 2007-12-28 16:32:23.000000000 +0100 | 3 | +++ lua-5.1.5/src/lcode.c 2012-11-28 21:12:23.958419501 +0200 |
4 | +++ lua-5.1.4/src/lcode.c 2009-01-27 21:15:39.000000000 +0100 | 4 | @@ -642,6 +642,17 @@ |
5 | @@ -650,6 +650,17 @@ | ||
6 | case OP_POW: r = luai_numpow(v1, v2); break; | 5 | case OP_POW: r = luai_numpow(v1, v2); break; |
7 | case OP_UNM: r = luai_numunm(v1); break; | 6 | case OP_UNM: r = luai_numunm(v1); break; |
8 | case OP_LEN: return 0; /* no constant folding for 'len' */ | 7 | case OP_LEN: return 0; /* no constant folding for 'len' */ |
@@ -20,7 +19,7 @@ Index: lua-5.1.4/src/lcode.c | |||
20 | default: lua_assert(0); r = 0; break; | 19 | default: lua_assert(0); r = 0; break; |
21 | } | 20 | } |
22 | if (luai_numisnan(r)) return 0; /* do not attempt to produce NaN */ | 21 | if (luai_numisnan(r)) return 0; /* do not attempt to produce NaN */ |
23 | @@ -662,7 +673,11 @@ | 22 | @@ -654,7 +665,11 @@ |
24 | if (constfolding(op, e1, e2)) | 23 | if (constfolding(op, e1, e2)) |
25 | return; | 24 | return; |
26 | else { | 25 | else { |
@@ -32,7 +31,7 @@ Index: lua-5.1.4/src/lcode.c | |||
32 | int o1 = luaK_exp2RK(fs, e1); | 31 | int o1 = luaK_exp2RK(fs, e1); |
33 | if (o1 > o2) { | 32 | if (o1 > o2) { |
34 | freeexp(fs, e1); | 33 | freeexp(fs, e1); |
35 | @@ -698,6 +713,14 @@ | 34 | @@ -690,6 +705,14 @@ |
36 | expdesc e2; | 35 | expdesc e2; |
37 | e2.t = e2.f = NO_JUMP; e2.k = VKNUM; e2.u.nval = 0; | 36 | e2.t = e2.f = NO_JUMP; e2.k = VKNUM; e2.u.nval = 0; |
38 | switch (op) { | 37 | switch (op) { |
@@ -47,7 +46,7 @@ Index: lua-5.1.4/src/lcode.c | |||
47 | case OPR_MINUS: { | 46 | case OPR_MINUS: { |
48 | if (!isnumeral(e)) | 47 | if (!isnumeral(e)) |
49 | luaK_exp2anyreg(fs, e); /* cannot operate on non-numeric constants */ | 48 | luaK_exp2anyreg(fs, e); /* cannot operate on non-numeric constants */ |
50 | @@ -778,6 +801,14 @@ | 49 | @@ -770,6 +793,14 @@ |
51 | case OPR_DIV: codearith(fs, OP_DIV, e1, e2); break; | 50 | case OPR_DIV: codearith(fs, OP_DIV, e1, e2); break; |
52 | case OPR_MOD: codearith(fs, OP_MOD, e1, e2); break; | 51 | case OPR_MOD: codearith(fs, OP_MOD, e1, e2); break; |
53 | case OPR_POW: codearith(fs, OP_POW, e1, e2); break; | 52 | case OPR_POW: codearith(fs, OP_POW, e1, e2); break; |
@@ -62,10 +61,9 @@ Index: lua-5.1.4/src/lcode.c | |||
62 | case OPR_EQ: codecomp(fs, OP_EQ, 1, e1, e2); break; | 61 | case OPR_EQ: codecomp(fs, OP_EQ, 1, e1, e2); break; |
63 | case OPR_NE: codecomp(fs, OP_EQ, 0, e1, e2); break; | 62 | case OPR_NE: codecomp(fs, OP_EQ, 0, e1, e2); break; |
64 | case OPR_LT: codecomp(fs, OP_LT, 1, e1, e2); break; | 63 | case OPR_LT: codecomp(fs, OP_LT, 1, e1, e2); break; |
65 | Index: lua-5.1.4/src/lcode.h | 64 | diff -Nurd lua-5.1.5/src/lcode.h lua-5.1.5/src/lcode.h |
66 | =================================================================== | 65 | --- lua-5.1.5/src/lcode.h 2007-12-27 15:02:25.000000000 +0200 |
67 | --- lua-5.1.4.orig/src/lcode.h 2007-12-27 14:02:25.000000000 +0100 | 66 | +++ lua-5.1.5/src/lcode.h 2012-11-28 21:12:23.958419501 +0200 |
68 | +++ lua-5.1.4/src/lcode.h 2009-01-27 21:15:39.000000000 +0100 | ||
69 | @@ -25,6 +25,9 @@ | 67 | @@ -25,6 +25,9 @@ |
70 | */ | 68 | */ |
71 | typedef enum BinOpr { | 69 | typedef enum BinOpr { |
@@ -89,10 +87,9 @@ Index: lua-5.1.4/src/lcode.h | |||
89 | 87 | ||
90 | #define getcode(fs,e) ((fs)->f->code[(e)->u.s.info]) | 88 | #define getcode(fs,e) ((fs)->f->code[(e)->u.s.info]) |
91 | 89 | ||
92 | Index: lua-5.1.4/src/ldebug.c | 90 | diff -Nurd lua-5.1.5/src/ldebug.c lua-5.1.5/src/ldebug.c |
93 | =================================================================== | 91 | --- lua-5.1.5/src/ldebug.c 2008-05-08 19:56:26.000000000 +0300 |
94 | --- lua-5.1.4.orig/src/ldebug.c 2008-05-08 18:56:26.000000000 +0200 | 92 | +++ lua-5.1.5/src/ldebug.c 2012-11-28 21:12:23.958419501 +0200 |
95 | +++ lua-5.1.4/src/ldebug.c 2009-01-27 21:15:39.000000000 +0100 | ||
96 | @@ -592,6 +592,16 @@ | 93 | @@ -592,6 +592,16 @@ |
97 | luaG_typeerror(L, p2, "perform arithmetic on"); | 94 | luaG_typeerror(L, p2, "perform arithmetic on"); |
98 | } | 95 | } |
@@ -110,10 +107,9 @@ Index: lua-5.1.4/src/ldebug.c | |||
110 | 107 | ||
111 | int luaG_ordererror (lua_State *L, const TValue *p1, const TValue *p2) { | 108 | int luaG_ordererror (lua_State *L, const TValue *p1, const TValue *p2) { |
112 | const char *t1 = luaT_typenames[ttype(p1)]; | 109 | const char *t1 = luaT_typenames[ttype(p1)]; |
113 | Index: lua-5.1.4/src/ldebug.h | 110 | diff -Nurd lua-5.1.5/src/ldebug.h lua-5.1.5/src/ldebug.h |
114 | =================================================================== | 111 | --- lua-5.1.5/src/ldebug.h 2007-12-27 15:02:25.000000000 +0200 |
115 | --- lua-5.1.4.orig/src/ldebug.h 2007-12-27 14:02:25.000000000 +0100 | 112 | +++ lua-5.1.5/src/ldebug.h 2012-11-28 21:12:23.958419501 +0200 |
116 | +++ lua-5.1.4/src/ldebug.h 2009-01-27 21:15:39.000000000 +0100 | ||
117 | @@ -30,4 +30,9 @@ | 113 | @@ -30,4 +30,9 @@ |
118 | LUAI_FUNC int luaG_checkcode (const Proto *pt); | 114 | LUAI_FUNC int luaG_checkcode (const Proto *pt); |
119 | LUAI_FUNC int luaG_checkopenop (Instruction i); | 115 | LUAI_FUNC int luaG_checkopenop (Instruction i); |
@@ -124,10 +120,9 @@ Index: lua-5.1.4/src/ldebug.h | |||
124 | +#endif | 120 | +#endif |
125 | + | 121 | + |
126 | #endif | 122 | #endif |
127 | Index: lua-5.1.4/src/llex.c | 123 | diff -Nurd lua-5.1.5/src/llex.c lua-5.1.5/src/llex.c |
128 | =================================================================== | 124 | --- lua-5.1.5/src/llex.c 2009-11-23 16:58:22.000000000 +0200 |
129 | --- lua-5.1.4.orig/src/llex.c 2007-12-27 14:02:25.000000000 +0100 | 125 | +++ lua-5.1.5/src/llex.c 2012-11-28 21:12:23.958419501 +0200 |
130 | +++ lua-5.1.4/src/llex.c 2009-01-27 21:15:39.000000000 +0100 | ||
131 | @@ -39,7 +39,11 @@ | 126 | @@ -39,7 +39,11 @@ |
132 | "end", "false", "for", "function", "if", | 127 | "end", "false", "for", "function", "if", |
133 | "in", "local", "nil", "not", "or", "repeat", | 128 | "in", "local", "nil", "not", "or", "repeat", |
@@ -140,7 +135,7 @@ Index: lua-5.1.4/src/llex.c | |||
140 | "<number>", "<name>", "<string>", "<eof>", | 135 | "<number>", "<name>", "<string>", "<eof>", |
141 | NULL | 136 | NULL |
142 | }; | 137 | }; |
143 | @@ -371,6 +375,30 @@ | 138 | @@ -373,6 +377,30 @@ |
144 | if (ls->current != '=') return '='; | 139 | if (ls->current != '=') return '='; |
145 | else { next(ls); return TK_EQ; } | 140 | else { next(ls); return TK_EQ; } |
146 | } | 141 | } |
@@ -171,7 +166,7 @@ Index: lua-5.1.4/src/llex.c | |||
171 | case '<': { | 166 | case '<': { |
172 | next(ls); | 167 | next(ls); |
173 | if (ls->current != '=') return '<'; | 168 | if (ls->current != '=') return '<'; |
174 | @@ -379,8 +407,9 @@ | 169 | @@ -381,8 +409,9 @@ |
175 | case '>': { | 170 | case '>': { |
176 | next(ls); | 171 | next(ls); |
177 | if (ls->current != '=') return '>'; | 172 | if (ls->current != '=') return '>'; |
@@ -182,10 +177,9 @@ Index: lua-5.1.4/src/llex.c | |||
182 | case '~': { | 177 | case '~': { |
183 | next(ls); | 178 | next(ls); |
184 | if (ls->current != '=') return '~'; | 179 | if (ls->current != '=') return '~'; |
185 | Index: lua-5.1.4/src/llex.h | 180 | diff -Nurd lua-5.1.5/src/llex.h lua-5.1.5/src/llex.h |
186 | =================================================================== | 181 | --- lua-5.1.5/src/llex.h 2007-12-27 15:02:25.000000000 +0200 |
187 | --- lua-5.1.4.orig/src/llex.h 2007-12-27 14:02:25.000000000 +0100 | 182 | +++ lua-5.1.5/src/llex.h 2012-11-28 21:12:23.962419499 +0200 |
188 | +++ lua-5.1.4/src/llex.h 2009-01-27 21:15:39.000000000 +0100 | ||
189 | @@ -28,7 +28,11 @@ | 183 | @@ -28,7 +28,11 @@ |
190 | TK_IF, TK_IN, TK_LOCAL, TK_NIL, TK_NOT, TK_OR, TK_REPEAT, | 184 | TK_IF, TK_IN, TK_LOCAL, TK_NIL, TK_NOT, TK_OR, TK_REPEAT, |
191 | TK_RETURN, TK_THEN, TK_TRUE, TK_UNTIL, TK_WHILE, | 185 | TK_RETURN, TK_THEN, TK_TRUE, TK_UNTIL, TK_WHILE, |
@@ -198,10 +192,9 @@ Index: lua-5.1.4/src/llex.h | |||
198 | TK_NAME, TK_STRING, TK_EOS | 192 | TK_NAME, TK_STRING, TK_EOS |
199 | }; | 193 | }; |
200 | 194 | ||
201 | Index: lua-5.1.4/src/lopcodes.c | 195 | diff -Nurd lua-5.1.5/src/lopcodes.c lua-5.1.5/src/lopcodes.c |
202 | =================================================================== | 196 | --- lua-5.1.5/src/lopcodes.c 2007-12-27 15:02:25.000000000 +0200 |
203 | --- lua-5.1.4.orig/src/lopcodes.c 2007-12-27 14:02:25.000000000 +0100 | 197 | +++ lua-5.1.5/src/lopcodes.c 2012-11-28 21:12:23.962419499 +0200 |
204 | +++ lua-5.1.4/src/lopcodes.c 2009-01-27 21:15:39.000000000 +0100 | ||
205 | @@ -32,6 +32,15 @@ | 198 | @@ -32,6 +32,15 @@ |
206 | "DIV", | 199 | "DIV", |
207 | "MOD", | 200 | "MOD", |
@@ -234,10 +227,9 @@ Index: lua-5.1.4/src/lopcodes.c | |||
234 | ,opmode(0, 1, OpArgR, OpArgN, iABC) /* OP_UNM */ | 227 | ,opmode(0, 1, OpArgR, OpArgN, iABC) /* OP_UNM */ |
235 | ,opmode(0, 1, OpArgR, OpArgN, iABC) /* OP_NOT */ | 228 | ,opmode(0, 1, OpArgR, OpArgN, iABC) /* OP_NOT */ |
236 | ,opmode(0, 1, OpArgR, OpArgN, iABC) /* OP_LEN */ | 229 | ,opmode(0, 1, OpArgR, OpArgN, iABC) /* OP_LEN */ |
237 | Index: lua-5.1.4/src/lopcodes.h | 230 | diff -Nurd lua-5.1.5/src/lopcodes.h lua-5.1.5/src/lopcodes.h |
238 | =================================================================== | 231 | --- lua-5.1.5/src/lopcodes.h 2007-12-27 15:02:25.000000000 +0200 |
239 | --- lua-5.1.4.orig/src/lopcodes.h 2007-12-27 14:02:25.000000000 +0100 | 232 | +++ lua-5.1.5/src/lopcodes.h 2012-11-28 21:12:23.962419499 +0200 |
240 | +++ lua-5.1.4/src/lopcodes.h 2009-01-27 21:15:39.000000000 +0100 | ||
241 | @@ -174,10 +174,20 @@ | 233 | @@ -174,10 +174,20 @@ |
242 | OP_DIV,/* A B C R(A) := RK(B) / RK(C) */ | 234 | OP_DIV,/* A B C R(A) := RK(B) / RK(C) */ |
243 | OP_MOD,/* A B C R(A) := RK(B) % RK(C) */ | 235 | OP_MOD,/* A B C R(A) := RK(B) % RK(C) */ |
@@ -281,10 +273,9 @@ Index: lua-5.1.4/src/lopcodes.h | |||
281 | OP_SETLIST,/* A B C R(A)[(C-1)*FPF+i] := R(A+i), 1 <= i <= B */ | 273 | OP_SETLIST,/* A B C R(A)[(C-1)*FPF+i] := R(A+i), 1 <= i <= B */ |
282 | 274 | ||
283 | OP_CLOSE,/* A close all variables in the stack up to (>=) R(A)*/ | 275 | OP_CLOSE,/* A close all variables in the stack up to (>=) R(A)*/ |
284 | Index: lua-5.1.4/src/lparser.c | 276 | diff -Nurd lua-5.1.5/src/lparser.c lua-5.1.5/src/lparser.c |
285 | =================================================================== | 277 | --- lua-5.1.5/src/lparser.c 2011-10-21 22:31:42.000000000 +0300 |
286 | --- lua-5.1.4.orig/src/lparser.c 2007-12-28 16:32:23.000000000 +0100 | 278 | +++ lua-5.1.5/src/lparser.c 2012-11-28 21:12:23.962419499 +0200 |
287 | +++ lua-5.1.4/src/lparser.c 2009-01-27 21:15:39.000000000 +0100 | ||
288 | @@ -780,6 +780,9 @@ | 279 | @@ -780,6 +780,9 @@ |
289 | case TK_NOT: return OPR_NOT; | 280 | case TK_NOT: return OPR_NOT; |
290 | case '-': return OPR_MINUS; | 281 | case '-': return OPR_MINUS; |
@@ -320,10 +311,9 @@ Index: lua-5.1.4/src/lparser.c | |||
320 | {10, 9}, {5, 4}, /* power and concat (right associative) */ | 311 | {10, 9}, {5, 4}, /* power and concat (right associative) */ |
321 | {3, 3}, {3, 3}, /* equality and inequality */ | 312 | {3, 3}, {3, 3}, /* equality and inequality */ |
322 | {3, 3}, {3, 3}, {3, 3}, {3, 3}, /* order */ | 313 | {3, 3}, {3, 3}, {3, 3}, {3, 3}, /* order */ |
323 | Index: lua-5.1.4/src/ltm.c | 314 | diff -Nurd lua-5.1.5/src/ltm.c lua-5.1.5/src/ltm.c |
324 | =================================================================== | 315 | --- lua-5.1.5/src/ltm.c 2007-12-27 15:02:25.000000000 +0200 |
325 | --- lua-5.1.4.orig/src/ltm.c 2007-12-27 14:02:25.000000000 +0100 | 316 | +++ lua-5.1.5/src/ltm.c 2012-11-28 21:12:23.962419499 +0200 |
326 | +++ lua-5.1.4/src/ltm.c 2009-01-27 21:15:39.000000000 +0100 | ||
327 | @@ -34,6 +34,9 @@ | 317 | @@ -34,6 +34,9 @@ |
328 | "__add", "__sub", "__mul", "__div", "__mod", | 318 | "__add", "__sub", "__mul", "__div", "__mod", |
329 | "__pow", "__unm", "__len", "__lt", "__le", | 319 | "__pow", "__unm", "__len", "__lt", "__le", |
@@ -334,10 +324,9 @@ Index: lua-5.1.4/src/ltm.c | |||
334 | }; | 324 | }; |
335 | int i; | 325 | int i; |
336 | for (i=0; i<TM_N; i++) { | 326 | for (i=0; i<TM_N; i++) { |
337 | Index: lua-5.1.4/src/ltm.h | 327 | diff -Nurd lua-5.1.5/src/ltm.h lua-5.1.5/src/ltm.h |
338 | =================================================================== | 328 | --- lua-5.1.5/src/ltm.h 2007-12-27 15:02:25.000000000 +0200 |
339 | --- lua-5.1.4.orig/src/ltm.h 2007-12-27 14:02:25.000000000 +0100 | 329 | +++ lua-5.1.5/src/ltm.h 2012-11-28 21:12:23.962419499 +0200 |
340 | +++ lua-5.1.4/src/ltm.h 2009-01-27 21:15:39.000000000 +0100 | ||
341 | @@ -33,6 +33,15 @@ | 330 | @@ -33,6 +33,15 @@ |
342 | TM_LE, | 331 | TM_LE, |
343 | TM_CONCAT, | 332 | TM_CONCAT, |
@@ -354,23 +343,9 @@ Index: lua-5.1.4/src/ltm.h | |||
354 | TM_N /* number of elements in the enum */ | 343 | TM_N /* number of elements in the enum */ |
355 | } TMS; | 344 | } TMS; |
356 | 345 | ||
357 | Index: lua-5.1.4/src/lua.h | 346 | diff -Nurd lua-5.1.5/src/luaconf.h lua-5.1.5/src/luaconf.h |
358 | =================================================================== | 347 | --- lua-5.1.5/src/luaconf.h 2008-02-11 18:25:08.000000000 +0200 |
359 | --- lua-5.1.4.orig/src/lua.h 2008-08-06 15:30:12.000000000 +0200 | 348 | +++ lua-5.1.5/src/luaconf.h 2012-11-28 21:12:23.962419499 +0200 |
360 | +++ lua-5.1.4/src/lua.h 2009-01-27 21:16:39.000000000 +0100 | ||
361 | @@ -17,7 +17,7 @@ | ||
362 | |||
363 | |||
364 | #define LUA_VERSION "Lua 5.1" | ||
365 | -#define LUA_RELEASE "Lua 5.1.4" | ||
366 | +#define LUA_RELEASE "Lua 5.1.4+bitwiseops" | ||
367 | #define LUA_VERSION_NUM 501 | ||
368 | #define LUA_COPYRIGHT "Copyright (C) 1994-2008 Lua.org, PUC-Rio" | ||
369 | #define LUA_AUTHORS "R. Ierusalimschy, L. H. de Figueiredo & W. Celes" | ||
370 | Index: lua-5.1.4/src/luaconf.h | ||
371 | =================================================================== | ||
372 | --- lua-5.1.4.orig/src/luaconf.h 2008-02-11 17:25:08.000000000 +0100 | ||
373 | +++ lua-5.1.4/src/luaconf.h 2009-01-27 21:15:39.000000000 +0100 | ||
374 | @@ -2,6 +2,7 @@ | 349 | @@ -2,6 +2,7 @@ |
375 | ** $Id: luaconf.h,v 1.82.1.7 2008/02/11 16:25:08 roberto Exp $ | 350 | ** $Id: luaconf.h,v 1.82.1.7 2008/02/11 16:25:08 roberto Exp $ |
376 | ** Configuration file for Lua | 351 | ** Configuration file for Lua |
@@ -474,11 +449,22 @@ Index: lua-5.1.4/src/luaconf.h | |||
474 | /* }================================================================== */ | 449 | /* }================================================================== */ |
475 | 450 | ||
476 | 451 | ||
477 | Index: lua-5.1.4/src/lvm.c | 452 | diff -Nurd lua-5.1.5/src/lua.h lua-5.1.5/src/lua.h |
478 | =================================================================== | 453 | --- lua-5.1.5/src/lua.h 2012-01-13 22:36:20.000000000 +0200 |
479 | --- lua-5.1.4.orig/src/lvm.c 2007-12-28 16:32:23.000000000 +0100 | 454 | +++ lua-5.1.5/src/lua.h 2012-11-28 21:13:01.266418680 +0200 |
480 | +++ lua-5.1.4/src/lvm.c 2009-01-27 21:15:39.000000000 +0100 | 455 | @@ -17,7 +17,7 @@ |
481 | @@ -325,6 +325,9 @@ | 456 | |
457 | |||
458 | #define LUA_VERSION "Lua 5.1" | ||
459 | -#define LUA_RELEASE "Lua 5.1.5" | ||
460 | +#define LUA_RELEASE "Lua 5.1.5+bitwiseops" | ||
461 | #define LUA_VERSION_NUM 501 | ||
462 | #define LUA_COPYRIGHT "Copyright (C) 1994-2012 Lua.org, PUC-Rio" | ||
463 | #define LUA_AUTHORS "R. Ierusalimschy, L. H. de Figueiredo & W. Celes" | ||
464 | diff -Nurd lua-5.1.5/src/lvm.c lua-5.1.5/src/lvm.c | ||
465 | --- lua-5.1.5/src/lvm.c 2011-08-17 23:43:11.000000000 +0300 | ||
466 | +++ lua-5.1.5/src/lvm.c 2012-11-28 21:12:23.966419498 +0200 | ||
467 | @@ -329,6 +329,9 @@ | ||
482 | case TM_MOD: setnvalue(ra, luai_nummod(nb, nc)); break; | 468 | case TM_MOD: setnvalue(ra, luai_nummod(nb, nc)); break; |
483 | case TM_POW: setnvalue(ra, luai_numpow(nb, nc)); break; | 469 | case TM_POW: setnvalue(ra, luai_numpow(nb, nc)); break; |
484 | case TM_UNM: setnvalue(ra, luai_numunm(nb)); break; | 470 | case TM_UNM: setnvalue(ra, luai_numunm(nb)); break; |
@@ -488,7 +474,7 @@ Index: lua-5.1.4/src/lvm.c | |||
488 | default: lua_assert(0); break; | 474 | default: lua_assert(0); break; |
489 | } | 475 | } |
490 | } | 476 | } |
491 | @@ -332,7 +335,30 @@ | 477 | @@ -336,7 +339,30 @@ |
492 | luaG_aritherror(L, rb, rc); | 478 | luaG_aritherror(L, rb, rc); |
493 | } | 479 | } |
494 | 480 | ||
@@ -520,7 +506,7 @@ Index: lua-5.1.4/src/lvm.c | |||
520 | 506 | ||
521 | /* | 507 | /* |
522 | ** some macros for common tasks in `luaV_execute' | 508 | ** some macros for common tasks in `luaV_execute' |
523 | @@ -369,6 +395,22 @@ | 509 | @@ -373,6 +399,22 @@ |
524 | } | 510 | } |
525 | 511 | ||
526 | 512 | ||
@@ -543,7 +529,7 @@ Index: lua-5.1.4/src/lvm.c | |||
543 | 529 | ||
544 | void luaV_execute (lua_State *L, int nexeccalls) { | 530 | void luaV_execute (lua_State *L, int nexeccalls) { |
545 | LClosure *cl; | 531 | LClosure *cl; |
546 | @@ -502,6 +544,45 @@ | 532 | @@ -506,6 +548,45 @@ |
547 | } | 533 | } |
548 | continue; | 534 | continue; |
549 | } | 535 | } |
@@ -589,10 +575,9 @@ Index: lua-5.1.4/src/lvm.c | |||
589 | case OP_NOT: { | 575 | case OP_NOT: { |
590 | int res = l_isfalse(RB(i)); /* next assignment may change this value */ | 576 | int res = l_isfalse(RB(i)); /* next assignment may change this value */ |
591 | setbvalue(ra, res); | 577 | setbvalue(ra, res); |
592 | Index: lua-5.1.4/test/bitwisepatchtest.lua | 578 | diff -Nurd lua-5.1.5/test/bitwisepatchtest.lua lua-5.1.5/test/bitwisepatchtest.lua |
593 | =================================================================== | 579 | --- lua-5.1.5/test/bitwisepatchtest.lua 1970-01-01 02:00:00.000000000 +0200 |
594 | --- /dev/null 1970-01-01 00:00:00.000000000 +0000 | 580 | +++ lua-5.1.5/test/bitwisepatchtest.lua 2012-11-28 21:12:23.966419498 +0200 |
595 | +++ lua-5.1.4/test/bitwisepatchtest.lua 2009-01-27 21:15:39.000000000 +0100 | ||
596 | @@ -0,0 +1,24 @@ | 581 | @@ -0,0 +1,24 @@ |
597 | +hex=function (i) return "0x"..string.format("%X", i) end | 582 | +hex=function (i) return "0x"..string.format("%X", i) end |
598 | +print(hex(0x54|0x55)) | 583 | +print(hex(0x54|0x55)) |
diff --git a/meta-oe/recipes-devtools/lua/lua5.1/lua5.1.pc b/meta-oe/recipes-devtools/lua/lua5.1/lua5.1.pc index 41d5801232..64c03d2b6c 100644 --- a/meta-oe/recipes-devtools/lua/lua5.1/lua5.1.pc +++ b/meta-oe/recipes-devtools/lua/lua5.1/lua5.1.pc | |||
@@ -4,7 +4,7 @@ includedir=${prefix}/include | |||
4 | 4 | ||
5 | Name: Lua | 5 | Name: Lua |
6 | Description: Lua language engine | 6 | Description: Lua language engine |
7 | Version: 5.1.4 | 7 | Version: 5.1.5 |
8 | Requires: | 8 | Requires: |
9 | Libs: -L${libdir} -llua | 9 | Libs: -L${libdir} -llua |
10 | Libs.private: -lm | 10 | Libs.private: -lm |
diff --git a/meta-oe/recipes-devtools/lua/lua5.1_5.1.4.bb b/meta-oe/recipes-devtools/lua/lua5.1_5.1.5.bb index 0dc81dbea8..9da9e957a9 100644 --- a/meta-oe/recipes-devtools/lua/lua5.1_5.1.4.bb +++ b/meta-oe/recipes-devtools/lua/lua5.1_5.1.5.bb | |||
@@ -1,11 +1,10 @@ | |||
1 | DESCRIPTION = "Lua is a powerful light-weight programming language designed \ | 1 | DESCRIPTION = "Lua is a powerful light-weight programming language designed \ |
2 | for extending applications." | 2 | for extending applications." |
3 | LICENSE = "MIT" | 3 | LICENSE = "MIT" |
4 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=90c3badc6055c699194c4a7cea583296" | 4 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=59bdd99bb82238f238cf5c65c21604fd" |
5 | HOMEPAGE = "http://www.lua.org/" | 5 | HOMEPAGE = "http://www.lua.org/" |
6 | 6 | ||
7 | DEPENDS += "readline" | 7 | DEPENDS += "readline" |
8 | PR = "r11" | ||
9 | SRC_URI = "http://www.lua.org/ftp/lua-${PV}.tar.gz \ | 8 | SRC_URI = "http://www.lua.org/ftp/lua-${PV}.tar.gz \ |
10 | file://bitwise_operators.patch \ | 9 | file://bitwise_operators.patch \ |
11 | file://lua5.1.pc \ | 10 | file://lua5.1.pc \ |
@@ -20,7 +19,7 @@ SRC_URI_append_libc-uclibc = "${UCLIBC_PATCHES}" | |||
20 | TARGET_CC_ARCH += " -fPIC ${LDFLAGS}" | 19 | TARGET_CC_ARCH += " -fPIC ${LDFLAGS}" |
21 | EXTRA_OEMAKE = "'CC=${CC} -fPIC' 'MYCFLAGS=${CFLAGS} -DLUA_USE_LINUX -fPIC' MYLDFLAGS='${LDFLAGS}'" | 20 | EXTRA_OEMAKE = "'CC=${CC} -fPIC' 'MYCFLAGS=${CFLAGS} -DLUA_USE_LINUX -fPIC' MYLDFLAGS='${LDFLAGS}'" |
22 | 21 | ||
23 | do_configure_prepend() { | 22 | do_configure_prepend() { |
24 | sed -i -e s:/usr/local:${prefix}:g src/luaconf.h | 23 | sed -i -e s:/usr/local:${prefix}:g src/luaconf.h |
25 | } | 24 | } |
26 | 25 | ||
@@ -45,5 +44,5 @@ do_install () { | |||
45 | } | 44 | } |
46 | BBCLASSEXTEND = "native" | 45 | BBCLASSEXTEND = "native" |
47 | 46 | ||
48 | SRC_URI[md5sum] = "d0870f2de55d59c1c8419f36e8fac150" | 47 | SRC_URI[md5sum] = "2e115fe26e435e33b0d5c022e4490567" |
49 | SRC_URI[sha256sum] = "b038e225eaf2a5b57c9bcc35cd13aa8c6c8288ef493d52970c9545074098af3a" | 48 | SRC_URI[sha256sum] = "2640fc56a795f29d28ef15e13c34a47e223960b0240e8cb0a82d9b0738695333" |