summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-01-05 19:39:54 -0800
committerKhem Raj <raj.khem@gmail.com>2013-01-08 09:31:45 -0800
commit8925d39d3697196ee7ca77b1c8ffe5901e41da1c (patch)
tree818f7ed082762f201d51b0b59567c7b51765acac /meta-oe/recipes-devtools
parente71ddf94913ff10d7fe0cee53b0752b67df774cb (diff)
downloadmeta-openembedded-8925d39d3697196ee7ca77b1c8ffe5901e41da1c.tar.gz
cppunit: Upgrade recipes from 1.12.1 -> 1.13.1
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/cppunit/cppunit_1.12.1.bb16
-rw-r--r--meta-oe/recipes-devtools/cppunit/cppunit_1.13.1.bb11
2 files changed, 11 insertions, 16 deletions
diff --git a/meta-oe/recipes-devtools/cppunit/cppunit_1.12.1.bb b/meta-oe/recipes-devtools/cppunit/cppunit_1.12.1.bb
deleted file mode 100644
index 6487a3a07..000000000
--- a/meta-oe/recipes-devtools/cppunit/cppunit_1.12.1.bb
+++ /dev/null
@@ -1,16 +0,0 @@
1DESCRIPTION = "CppUnit is a C++ unit testing framework"
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
4
5SRC_URI = "${SOURCEFORGE_MIRROR}/cppunit/cppunit-${PV}.tar.gz"
6SRC_URI[md5sum] = "bd30e9cf5523cdfc019b94f5e1d7fd19"
7SRC_URI[sha256sum] = "ac28a04c8e6c9217d910b0ae7122832d28d9917fa668bcc9e0b8b09acb4ea44a"
8
9inherit autotools binconfig
10
11# Fix a linker ordering problem, we want -ldl *after* -lstdc++
12do_configure_append() {
13 for i in $(find ${S} -name "Makefile") ; do
14 sed -i -e 's:-lm:-lm -ldl:g' $i
15 done
16}
diff --git a/meta-oe/recipes-devtools/cppunit/cppunit_1.13.1.bb b/meta-oe/recipes-devtools/cppunit/cppunit_1.13.1.bb
new file mode 100644
index 000000000..3e525fe4f
--- /dev/null
+++ b/meta-oe/recipes-devtools/cppunit/cppunit_1.13.1.bb
@@ -0,0 +1,11 @@
1DESCRIPTION = "CppUnit is the C++ port of the famous JUnit framework for unit testing. Test output is in XML for automatic testing and GUI based for supervised tests. "
2HOMEPAGE = "http://www.freedesktop.org/wiki/Software/cppunit"
3LICENSE = "LGPL-2.1"
4SECTION = "libs"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
7SRC_URI = "http://dev-www.libreoffice.org/src/cppunit-${PV}.tar.gz"
8SRC_URI[md5sum] = "fa9aa839145cdf860bf596532bb8af97"
9SRC_URI[sha256sum] = "d5b9f3ffc9f1634d75b20b54f48c02e0817bca6afa1d5160b244889d6bff8e0f"
10
11inherit autotools