summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2013-02-21 18:19:56 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2013-03-02 15:27:45 +0100
commit683a10384e6553dd90423a306809304bbc53f1c4 (patch)
treeda49281dda8bc9b5f664d32402b6aa09e0c6e59f /meta-oe/recipes-devtools
parent84ea5433739ddc2551216902f6053d5c2368e755 (diff)
downloadmeta-openembedded-683a10384e6553dd90423a306809304bbc53f1c4.tar.gz
geany: fix compile by removing extra check for c++ compiler
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/geany/geany/0001-configure.ac-remove-additional-c-test.patch47
-rw-r--r--meta-oe/recipes-devtools/geany/geany_1.22.bb6
2 files changed, 52 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/geany/geany/0001-configure.ac-remove-additional-c-test.patch b/meta-oe/recipes-devtools/geany/geany/0001-configure.ac-remove-additional-c-test.patch
new file mode 100644
index 000000000..5166fece0
--- /dev/null
+++ b/meta-oe/recipes-devtools/geany/geany/0001-configure.ac-remove-additional-c-test.patch
@@ -0,0 +1,47 @@
1From e62d5b59262ec7ffe07931790712c7e247377795 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Thu, 21 Feb 2013 09:31:31 +0100
4Subject: [PATCH] configure.ac remove additional c++ test
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9For openembedded cross-builds CXX can contain something like:
10
11arm-oe-linux-gnueabi-g++ -march=armv5te -marm -mthumb-interwork --sysroot=/home/jenkins/oe/shr-core-branches/shr-core/tmp-eglibc/sysroots/qemuarm
12
13This ends up in
14
15configure:5582: error: No C++ compiler found. Please install a C++ compiler.
16
17Anyway if [1] is still valid, the combination of AC_PROG_CC and AC_PROG_CXX
18should thow an error message.
19
20[1] http://lists.gnu.org/archive/html/bug-autoconf/2010-05/msg00001.html
21
22Upstream-Status: Inappropriate [configuration]
23
24Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
25---
26 configure.ac | 5 -----
27 1 files changed, 0 insertions(+), 5 deletions(-)
28
29diff --git a/configure.ac b/configure.ac
30index c37312a..742bf35 100644
31--- a/configure.ac
32+++ b/configure.ac
33@@ -26,11 +26,6 @@ AC_USE_SYSTEM_EXTENSIONS
34 AC_PROG_CC
35
36 AC_PROG_CXX
37-# check for C++ compiler explicitly and fail if none is found, do this check
38-# after AC_PROG_CXX has set the CXX environment variable
39-if ! which $CXX >/dev/null 2>&1; then
40- AC_MSG_ERROR([No C++ compiler found. Please install a C++ compiler.])
41-fi
42
43 AC_PROG_INSTALL
44 AC_PROG_LN_S
45--
461.7.6.5
47
diff --git a/meta-oe/recipes-devtools/geany/geany_1.22.bb b/meta-oe/recipes-devtools/geany/geany_1.22.bb
index 1e56ec8e0..e0b5df509 100644
--- a/meta-oe/recipes-devtools/geany/geany_1.22.bb
+++ b/meta-oe/recipes-devtools/geany/geany_1.22.bb
@@ -3,10 +3,14 @@ HOMEPAGE = "http://www.geany.org/"
3LICENSE = "GPLv2" 3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=c107cf754550e65755c42985a5d4e9c9" 4LIC_FILES_CHKSUM = "file://COPYING;md5=c107cf754550e65755c42985a5d4e9c9"
5DEPENDS = "gtk+" 5DEPENDS = "gtk+"
6PR = "r1"
6 7
7inherit autotools pkgconfig 8inherit autotools pkgconfig
8 9
9SRC_URI = "http://download.geany.org/${PN}-${PV}.tar.bz2" 10SRC_URI = " \
11 http://download.geany.org/${PN}-${PV}.tar.bz2 \
12 file://0001-configure.ac-remove-additional-c-test.patch \
13"
10SRC_URI[md5sum] = "0672077fe83e2a739aa0eaca426aacf0" 14SRC_URI[md5sum] = "0672077fe83e2a739aa0eaca426aacf0"
11SRC_URI[sha256sum] = "901a35a7395ef10a80fb10b3ab63bae3871693a4e82d56388e9521a27877577e" 15SRC_URI[sha256sum] = "901a35a7395ef10a80fb10b3ab63bae3871693a4e82d56388e9521a27877577e"
12 16