summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin.juszkiewicz@linaro.org>2013-02-05 08:58:50 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-02-05 11:05:51 +0100
commit0ecbe9467c2ed3835c5e2b1f54ba52fa058e26db (patch)
treeda07d79fd9bce876e6f68b93cfc8b0d5215c3e2d /meta-oe/recipes-devtools
parentac174eac597a7e3fd4469b3d571c6aa9525fe3b9 (diff)
downloadmeta-openembedded-0ecbe9467c2ed3835c5e2b1f54ba52fa058e26db.tar.gz
python-numpy: add 1.7.0rc1
Signed-off-by: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/python/python-numpy/aarch64.patch41
-rw-r--r--meta-oe/recipes-devtools/python/python-numpy/aarch64/_numpyconfig.h30
-rw-r--r--meta-oe/recipes-devtools/python/python-numpy/aarch64/config.h139
-rw-r--r--meta-oe/recipes-devtools/python/python-numpy_1.7.0rc1.bb (renamed from meta-oe/recipes-devtools/python/python-numpy_1.4.1.bb)33
4 files changed, 236 insertions, 7 deletions
diff --git a/meta-oe/recipes-devtools/python/python-numpy/aarch64.patch b/meta-oe/recipes-devtools/python/python-numpy/aarch64.patch
new file mode 100644
index 000000000..8d6661564
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-numpy/aarch64.patch
@@ -0,0 +1,41 @@
1From 7d7a5939dcf5821d9f381d57bfa2012568ef6b82 Mon Sep 17 00:00:00 2001
2From: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org>
3Date: Thu, 10 Jan 2013 21:49:01 +0100
4Subject: [PATCH] Added support for AArch64 architecture
5
6Signed-off-by: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org>
7
8Upstream-Status: backport
9---
10 numpy/core/include/numpy/npy_cpu.h | 2 ++
11 numpy/core/include/numpy/npy_endian.h | 1 +
12 2 files changed, 3 insertions(+)
13
14diff --git a/numpy/core/include/numpy/npy_cpu.h b/numpy/core/include/numpy/npy_cpu.h
15index 8a29788..9707a7a 100644
16--- a/numpy/core/include/numpy/npy_cpu.h
17+++ b/numpy/core/include/numpy/npy_cpu.h
18@@ -66,6 +66,8 @@
19 #define NPY_CPU_MIPSEL
20 #elif defined(__MIPSEB__)
21 #define NPY_CPU_MIPSEB
22+#elif defined(__aarch64__)
23+ #define NPY_CPU_AARCH64
24 #else
25 #error Unknown CPU, please report this to numpy maintainers with \
26 information about your platform (OS, CPU and compiler)
27diff --git a/numpy/core/include/numpy/npy_endian.h b/numpy/core/include/numpy/npy_endian.h
28index aa5ed8b..4e3349f 100644
29--- a/numpy/core/include/numpy/npy_endian.h
30+++ b/numpy/core/include/numpy/npy_endian.h
31@@ -25,6 +25,7 @@
32 || defined(NPY_CPU_IA64) \
33 || defined(NPY_CPU_ALPHA) \
34 || defined(NPY_CPU_ARMEL) \
35+ || defined(NPY_CPU_AARCH64) \
36 || defined(NPY_CPU_SH_LE) \
37 || defined(NPY_CPU_MIPSEL)
38 #define NPY_BYTE_ORDER NPY_LITTLE_ENDIAN
39--
401.8.0
41
diff --git a/meta-oe/recipes-devtools/python/python-numpy/aarch64/_numpyconfig.h b/meta-oe/recipes-devtools/python/python-numpy/aarch64/_numpyconfig.h
new file mode 100644
index 000000000..be57ac27b
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-numpy/aarch64/_numpyconfig.h
@@ -0,0 +1,30 @@
1#define NPY_HAVE_ENDIAN_H 1
2#define NPY_SIZEOF_SHORT SIZEOF_SHORT
3#define NPY_SIZEOF_INT SIZEOF_INT
4#define NPY_SIZEOF_LONG SIZEOF_LONG
5#define NPY_SIZEOF_FLOAT 4
6#define NPY_SIZEOF_COMPLEX_FLOAT 8
7#define NPY_SIZEOF_DOUBLE 8
8#define NPY_SIZEOF_COMPLEX_DOUBLE 16
9#define NPY_SIZEOF_LONGDOUBLE 16
10#define NPY_SIZEOF_COMPLEX_LONGDOUBLE 32
11#define NPY_SIZEOF_PY_INTPTR_T 8
12#define NPY_SIZEOF_PY_LONG_LONG 8
13#define NPY_SIZEOF_LONGLONG 8
14#define NPY_NO_SMP 0
15#define NPY_HAVE_DECL_ISNAN
16#define NPY_HAVE_DECL_ISINF
17#define NPY_HAVE_DECL_ISFINITE
18#define NPY_HAVE_DECL_SIGNBIT
19#define NPY_USE_C99_COMPLEX 1
20#define NPY_HAVE_COMPLEX_DOUBLE 1
21#define NPY_HAVE_COMPLEX_FLOAT 1
22#define NPY_HAVE_COMPLEX_LONG_DOUBLE 1
23#define NPY_USE_C99_FORMATS 1
24#define NPY_VISIBILITY_HIDDEN __attribute__((visibility("hidden")))
25#define NPY_ABI_VERSION 0x01000009
26#define NPY_API_VERSION 0x00000007
27
28#ifndef __STDC_FORMAT_MACROS
29#define __STDC_FORMAT_MACROS 1
30#endif
diff --git a/meta-oe/recipes-devtools/python/python-numpy/aarch64/config.h b/meta-oe/recipes-devtools/python/python-numpy/aarch64/config.h
new file mode 100644
index 000000000..c30b868f2
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-numpy/aarch64/config.h
@@ -0,0 +1,139 @@
1#define HAVE_ENDIAN_H 1
2#define SIZEOF_PY_INTPTR_T 8
3#define SIZEOF_PY_LONG_LONG 8
4#define MATHLIB m
5#define HAVE_SIN 1
6#define HAVE_COS 1
7#define HAVE_TAN 1
8#define HAVE_SINH 1
9#define HAVE_COSH 1
10#define HAVE_TANH 1
11#define HAVE_FABS 1
12#define HAVE_FLOOR 1
13#define HAVE_CEIL 1
14#define HAVE_SQRT 1
15#define HAVE_LOG10 1
16#define HAVE_LOG 1
17#define HAVE_EXP 1
18#define HAVE_ASIN 1
19#define HAVE_ACOS 1
20#define HAVE_ATAN 1
21#define HAVE_FMOD 1
22#define HAVE_MODF 1
23#define HAVE_FREXP 1
24#define HAVE_LDEXP 1
25#define HAVE_RINT 1
26#define HAVE_TRUNC 1
27#define HAVE_EXP2 1
28#define HAVE_LOG2 1
29#define HAVE_ATAN2 1
30#define HAVE_POW 1
31#define HAVE_NEXTAFTER 1
32#define HAVE_SINF 1
33#define HAVE_COSF 1
34#define HAVE_TANF 1
35#define HAVE_SINHF 1
36#define HAVE_COSHF 1
37#define HAVE_TANHF 1
38#define HAVE_FABSF 1
39#define HAVE_FLOORF 1
40#define HAVE_CEILF 1
41#define HAVE_RINTF 1
42#define HAVE_TRUNCF 1
43#define HAVE_SQRTF 1
44#define HAVE_LOG10F 1
45#define HAVE_LOGF 1
46#define HAVE_LOG1PF 1
47#define HAVE_EXPF 1
48#define HAVE_EXPM1F 1
49#define HAVE_ASINF 1
50#define HAVE_ACOSF 1
51#define HAVE_ATANF 1
52#define HAVE_ASINHF 1
53#define HAVE_ACOSHF 1
54#define HAVE_ATANHF 1
55#define HAVE_HYPOTF 1
56#define HAVE_ATAN2F 1
57#define HAVE_POWF 1
58#define HAVE_FMODF 1
59#define HAVE_MODFF 1
60#define HAVE_FREXPF 1
61#define HAVE_LDEXPF 1
62#define HAVE_EXP2F 1
63#define HAVE_LOG2F 1
64#define HAVE_COPYSIGNF 1
65#define HAVE_NEXTAFTERF 1
66#define HAVE_SINL 1
67#define HAVE_COSL 1
68#define HAVE_TANL 1
69#define HAVE_SINHL 1
70#define HAVE_COSHL 1
71#define HAVE_TANHL 1
72#define HAVE_FABSL 1
73#define HAVE_FLOORL 1
74#define HAVE_CEILL 1
75#define HAVE_RINTL 1
76#define HAVE_TRUNCL 1
77#define HAVE_SQRTL 1
78#define HAVE_LOG10L 1
79#define HAVE_LOGL 1
80#define HAVE_LOG1PL 1
81#define HAVE_EXPL 1
82#define HAVE_EXPM1L 1
83#define HAVE_ASINL 1
84#define HAVE_ACOSL 1
85#define HAVE_ATANL 1
86#define HAVE_ASINHL 1
87#define HAVE_ACOSHL 1
88#define HAVE_ATANHL 1
89#define HAVE_HYPOTL 1
90#define HAVE_ATAN2L 1
91#define HAVE_POWL 1
92#define HAVE_FMODL 1
93#define HAVE_MODFL 1
94#define HAVE_FREXPL 1
95#define HAVE_LDEXPL 1
96#define HAVE_EXP2L 1
97#define HAVE_LOG2L 1
98#define HAVE_COPYSIGNL 1
99#define HAVE_NEXTAFTERL 1
100#define HAVE_DECL_SIGNBIT
101#define HAVE_COMPLEX_H 1
102#define HAVE_CREAL 1
103#define HAVE_CIMAG 1
104#define HAVE_CABS 1
105#define HAVE_CARG 1
106#define HAVE_CEXP 1
107#define HAVE_CSQRT 1
108#define HAVE_CLOG 1
109#define HAVE_CCOS 1
110#define HAVE_CSIN 1
111#define HAVE_CPOW 1
112#define HAVE_CREALF 1
113#define HAVE_CIMAGF 1
114#define HAVE_CABSF 1
115#define HAVE_CARGF 1
116#define HAVE_CEXPF 1
117#define HAVE_CSQRTF 1
118#define HAVE_CLOGF 1
119#define HAVE_CCOSF 1
120#define HAVE_CSINF 1
121#define HAVE_CPOWF 1
122#define HAVE_CREALL 1
123#define HAVE_CIMAGL 1
124#define HAVE_CABSL 1
125#define HAVE_CARGL 1
126#define HAVE_CEXPL 1
127#define HAVE_CSQRTL 1
128#define HAVE_CLOGL 1
129#define HAVE_CCOSL 1
130#define HAVE_CSINL 1
131#define HAVE_CPOWL 1
132#define HAVE_LDOUBLE_IEEE_QUAD_LE 1
133#ifndef __cplusplus
134/* #undef inline */
135#endif
136
137#ifndef _NPY_NPY_CONFIG_H_
138#error config.h should never be included directly, include npy_config.h instead
139#endif
diff --git a/meta-oe/recipes-devtools/python/python-numpy_1.4.1.bb b/meta-oe/recipes-devtools/python/python-numpy_1.7.0rc1.bb
index 2bede0925..2e4bd6ad2 100644
--- a/meta-oe/recipes-devtools/python/python-numpy_1.4.1.bb
+++ b/meta-oe/recipes-devtools/python/python-numpy_1.7.0rc1.bb
@@ -1,14 +1,20 @@
1DESCRIPTION = "A sophisticated Numeric Processing Package for Python" 1DESCRIPTION = "A sophisticated Numeric Processing Package for Python"
2SECTION = "devel/python" 2SECTION = "devel/python"
3LICENSE = "PSF" 3LICENSE = "PSF"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3c42211d73c3faa1026e671dd39883fa" 4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=f87832d854acbade6e9f5c601c8b30b1"
5PR = "r5" 5PR = "r0"
6PV = "1.6.99+1.7.0rc1"
7REALPV = "1.7.0rc1"
6 8
7SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/numpy-${PV}.tar.gz \ 9SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/numpy-${REALPV}.tar.gz \
8 ${CONFIGFILESURI} \ 10 ${CONFIGFILESURI} \
11 file://aarch64.patch \
9 " 12 "
10CONFIGFILESURI ?= "" 13CONFIGFILESURI ?= ""
11 14
15CONFIGFILESURI_aarch64 = "file://config.h \
16 file://_numpyconfig.h \
17 "
12CONFIGFILESURI_arm = "file://config.h \ 18CONFIGFILESURI_arm = "file://config.h \
13 file://numpyconfig.h \ 19 file://numpyconfig.h \
14 " 20 "
@@ -16,7 +22,7 @@ CONFIGFILESURI_mipsel = "file://config.h \
16 file://numpyconfig.h \ 22 file://numpyconfig.h \
17 " 23 "
18 24
19S = "${WORKDIR}/numpy-${PV}" 25S = "${WORKDIR}/numpy-${REALPV}"
20 26
21inherit distutils 27inherit distutils
22 28
@@ -29,14 +35,27 @@ do_compile_prepend() {
29 cp ${WORKDIR}/*config.h ${S}/build/$(ls ${S}/build | grep src)/numpy/core/include/numpy/ 35 cp ${WORKDIR}/*config.h ${S}/build/$(ls ${S}/build | grep src)/numpy/core/include/numpy/
30} 36}
31 37
32SRC_URI[md5sum] = "5c7b5349dc3161763f7f366ceb96516b"
33SRC_URI[sha256sum] = "2e7bb84573e5123e07f3c919fd433bc09b78d606252b6b719e385c2a981d8e06"
34
35FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a" 38FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a"
39SRC_URI[md5sum] = "a4719f5a1853bc0f8892a5956d5c4229"
40SRC_URI[sha256sum] = "45ea23622f72d86bc3614446d668ee962c0475ee7b91a93ef85a5e0493962de5"
36 41
42# install what is needed for numpy.test()
37RDEPENDS_${PN} = "python-unittest \ 43RDEPENDS_${PN} = "python-unittest \
38 python-difflib \ 44 python-difflib \
39 python-pprint \ 45 python-pprint \
40 python-pickle \ 46 python-pickle \
41 python-shell \ 47 python-shell \
48 python-nose \
49 python-doctest \
50 python-datetime \
51 python-distutils \
52 python-misc \
53 python-mmap \
54 python-netclient \
55 python-numbers \
56 python-pydoc \
57 python-pkgutil \
58 python-email \
59 python-subprocess \
60 python-compression \
42 " 61 "