summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorNoor Ahsan <noor_ahsan@mentor.com>2012-03-30 06:49:09 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-03-31 16:48:43 +0200
commitd248ea6ada38ba9070f45f4fd2ab107bc6ed0246 (patch)
tree53bfcccb26d95f77a90aac9a47449345ff0d0848 /meta-oe/recipes-devtools
parent6460fe3a04e1c4ddb1fae09ef4d32dcfbf42a211 (diff)
downloadmeta-openembedded-d248ea6ada38ba9070f45f4fd2ab107bc6ed0246.tar.gz
libedit: Remove files folder as no patch was being used
* No patch file was being used in the recipe so removed the folder to make it bit clean. Signed-off-by: Noor Ahsan <noor_ahsan@mentor.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/libedit/files/20031222-debian-to-gentoo.patch125
-rw-r--r--meta-oe/recipes-devtools/libedit/files/libedit-add-soname.diff12
2 files changed, 0 insertions, 137 deletions
diff --git a/meta-oe/recipes-devtools/libedit/files/20031222-debian-to-gentoo.patch b/meta-oe/recipes-devtools/libedit/files/20031222-debian-to-gentoo.patch
deleted file mode 100644
index 62069d53d..000000000
--- a/meta-oe/recipes-devtools/libedit/files/20031222-debian-to-gentoo.patch
+++ /dev/null
@@ -1,125 +0,0 @@
1This patch is from openembedded 4e75705872fd9f289bbf4c74a912ca4710f50b93.
2
3Upstream-Status: Inappropriate [not author]
4diff -ur netbsd-cvs/Makefile libedit-20031222/Makefile
5--- netbsd-cvs/Makefile 2003-12-22 13:44:24.798012752 -0500
6+++ libedit-20031222/Makefile 2003-12-22 14:55:15.133863488 -0500
7@@ -5,6 +5,7 @@
8
9 WARNS= 3
10 LIB= edit
11+LIBS=-lncurses
12
13 OSRCS= chared.c common.c el.c emacs.c fcns.c help.c hist.c key.c map.c \
14 parse.c prompt.c read.c refresh.c search.c sig.c term.c tty.c vi.c
15@@ -22,9 +23,10 @@
16 editline.3 tok_line.3 editline.3 tok_str.3
17
18 # For speed and debugging
19-#SRCS= ${OSRCS} tokenizer.c history.c readline.c
20+SRCS= ${OSRCS} tokenizer.c history.c readline.c vis.c unvis.c fgetln.c strlcat.c strlcpy.c
21 # For protection
22-SRCS= editline.c tokenizer.c history.c readline.c
23+#SRCS= editline.c tokenizer.c history.c readline.c
24+OOBJS= $(patsubst %.c,%.o,$(SRCS))
25
26 LIBEDITDIR?=${.CURDIR}
27
28@@ -38,6 +40,7 @@
29 CPPFLAGS+=-I. -I${.CURDIR}
30 CPPFLAGS+=#-DDEBUG_TTY -DDEBUG_KEY -DDEBUG_READ -DDEBUG -DDEBUG_REFRESH
31 CPPFLAGS+=#-DDEBUG_PASTE -DDEBUG_EDIT
32+CFLAGS+=-I. -include ../glibc-bsd-glue/bsdcompat.h -I../glibc-compat -I../glibc-bsd-glue
33
34 AHDR=vi.h emacs.h common.h
35 ASRC=${LIBEDITDIR}/vi.c ${LIBEDITDIR}/emacs.c ${LIBEDITDIR}/common.c
36@@ -46,46 +49,56 @@
37 CLEANFILES+= ${AHDR} fcns.h help.h fcns.c help.c
38
39 SUBDIR= readline
40+HOST_SH=sh
41+LIBEDITDIR=.
42+all: .depend libedit.a libedit.so
43
44 vi.h: vi.c makelist
45 ${HOST_SH} ${LIBEDITDIR}/makelist -h ${LIBEDITDIR}/vi.c \
46- > ${.TARGET}.tmp && \
47- mv ${.TARGET}.tmp ${.TARGET}
48+ > $@.tmp && \
49+ mv $@.tmp $@
50
51 emacs.h: emacs.c makelist
52 ${HOST_SH} ${LIBEDITDIR}/makelist -h ${LIBEDITDIR}/emacs.c \
53- > ${.TARGET}.tmp && \
54- mv ${.TARGET}.tmp ${.TARGET}
55+ > $@.tmp && \
56+ mv $@.tmp $@
57
58 common.h: common.c makelist
59 ${HOST_SH} ${LIBEDITDIR}/makelist -h ${LIBEDITDIR}/common.c \
60- > ${.TARGET}.tmp && \
61- mv ${.TARGET}.tmp ${.TARGET}
62+ > $@.tmp && \
63+ mv $@.tmp $@
64
65 fcns.h: ${AHDR} makelist
66- ${HOST_SH} ${LIBEDITDIR}/makelist -fh ${AHDR} > ${.TARGET}.tmp && \
67- mv ${.TARGET}.tmp ${.TARGET}
68+ ${HOST_SH} ${LIBEDITDIR}/makelist -fh ${AHDR} > $@.tmp && \
69+ mv $@.tmp $@
70
71 fcns.c: ${AHDR} fcns.h help.h makelist
72- ${HOST_SH} ${LIBEDITDIR}/makelist -fc ${AHDR} > ${.TARGET}.tmp && \
73- mv ${.TARGET}.tmp ${.TARGET}
74+ ${HOST_SH} ${LIBEDITDIR}/makelist -fc ${AHDR} > $@.tmp && \
75+ mv $@.tmp $@
76
77 help.c: ${ASRC} makelist
78- ${HOST_SH} ${LIBEDITDIR}/makelist -bc ${ASRC} > ${.TARGET}.tmp && \
79- mv ${.TARGET}.tmp ${.TARGET}
80+ ${HOST_SH} ${LIBEDITDIR}/makelist -bc ${ASRC} > $@.tmp && \
81+ mv $@.tmp $@
82
83 help.h: ${ASRC} makelist
84- ${HOST_SH} ${LIBEDITDIR}/makelist -bh ${ASRC} > ${.TARGET}.tmp && \
85- mv ${.TARGET}.tmp ${.TARGET}
86+ ${HOST_SH} ${LIBEDITDIR}/makelist -bh ${ASRC} > $@.tmp && \
87+ mv $@.tmp $@
88
89 editline.c: ${OSRCS}
90- ${HOST_SH} ${LIBEDITDIR}/makelist -e ${.ALLSRC:T} > ${.TARGET}.tmp && \
91- mv ${.TARGET}.tmp ${.TARGET}
92+ ${HOST_SH} ${LIBEDITDIR}/makelist -e ${.ALLSRC:T} > $@.tmp && \
93+ mv $@.tmp $@
94
95 test.o: ${LIBEDITDIR}/TEST/test.c
96
97 test: libedit.a test.o
98- ${CC} ${LDFLAGS} ${.ALLSRC} -o ${.TARGET} libedit.a ${LDADD} -ltermcap
99+ ${CC} ${LDFLAGS} ${.ALLSRC} -o $@ libedit.a ${LDADD} -ltermcap
100
101-.include <bsd.lib.mk>
102-.include <bsd.subdir.mk>
103+.depend: vi.h emacs.h common.h fcns.h help.h help.c
104+ -mkdir .a .so
105+.c.o:
106+ ${CC} ${CFLAGS} -c $< -o .a/$*
107+ ${CC} ${CFLAGS} -fPIC -c $< -o .so/$*
108+libedit.a: ${OOBJS}
109+ ar -r $@ .a/*
110+libedit.so: ${OOBJS}
111+ ${CC} --shared -o $@ .so/* ${LIBS}
112diff -ur netbsd-cvs/el.c libedit-20031222/el.c
113--- netbsd-cvs/el.c 2003-12-22 13:44:25.474909848 -0500
114+++ libedit-20031222/el.c 2003-12-22 15:00:15.545194024 -0500
115@@ -439,8 +439,10 @@
116 static const char elpath[] = "/.editrc";
117 char path[MAXPATHLEN];
118
119+#if 0
120 if (issetugid())
121 return (-1);
122+#endif
123 if ((ptr = getenv("HOME")) == NULL)
124 return (-1);
125 if (strlcpy(path, ptr, sizeof(path)) >= sizeof(path))
diff --git a/meta-oe/recipes-devtools/libedit/files/libedit-add-soname.diff b/meta-oe/recipes-devtools/libedit/files/libedit-add-soname.diff
deleted file mode 100644
index 6b0434cf2..000000000
--- a/meta-oe/recipes-devtools/libedit/files/libedit-add-soname.diff
+++ /dev/null
@@ -1,12 +0,0 @@
1Add sonmae option in compiler switches. This patch is from openembedded 4e75705872fd9f289bbf4c74a912ca4710f50b93
2
3Upstream-Status: Inappropriate [not author]
4
5--- Makefile.orig 2005-04-20 18:12:45.000000000 +0200
6+++ Makefile 2005-04-20 18:14:37.000000000 +0200
7@@ -101,4 +101,4 @@
8 libedit.a: ${OOBJS}
9 ar -r $@ .a/*
10 libedit.so: ${OOBJS}
11- ${CC} --shared -o $@ .so/* ${LIBS}
12+ ${CC} --shared -Wl,-soname=libedit.so.0 -o $@ .so/* ${LIBS}