summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.60.03.bb
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2024-10-08 15:52:35 +0800
committerKhem Raj <raj.khem@gmail.com>2024-10-09 15:47:21 -0700
commitca7ea3ed024a2cf697aa336eeddbb69bda99a196 (patch)
tree6fbbfe7bcf55901f0c7f7a6b632ed3db8baa71ed /meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.60.03.bb
parent1c346f1829e032c2c924b1aed3c5997ca91c7fa4 (diff)
downloadmeta-openembedded-ca7ea3ed024a2cf697aa336eeddbb69bda99a196.tar.gz
xmlrpc-c: 1.59.01 -> 1.60.03
Update xmlrpc-c from 1.59.01 to latest stable version 1.60.03. The SRCREV is one more fix commit after release 1.60.03 in the stable series. And remove 0002-fix-formatting-issues.patch which has been fixed in upstream. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.60.03.bb')
-rw-r--r--meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.60.03.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.60.03.bb b/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.60.03.bb
new file mode 100644
index 000000000..a34256c27
--- /dev/null
+++ b/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.60.03.bb
@@ -0,0 +1,48 @@
1DESCRIPTION = "XML-RPC for C/C++ is programming libraries and related tools to help you \
2write an XML-RPC server or client in C or C++."
3
4HOMEPAGE = "http://xmlrpc-c.sourceforge.net/"
5LICENSE = "BSD-3-Clause & MIT"
6LIC_FILES_CHKSUM = "file://doc/COPYING;md5=aefbf81ba0750f02176b6f86752ea951"
7
8SRC_URI = "git://github.com/mirror/xmlrpc-c.git;branch=master;protocol=https \
9 file://0001-test-cpp-server_abyss-Fix-build-with-clang-libc.patch \
10 "
11# one more commit after Release 1.60.03 in the Stable series
12SRCREV = "a823b0bb5cf0a4dbd34f929cbfdfb0439c5d9b0e"
13
14S = "${WORKDIR}/git/stable"
15
16inherit autotools-brokensep binconfig pkgconfig
17
18TARGET_CFLAGS += "-Wno-narrowing"
19
20EXTRA_OEMAKE += "CC_FOR_BUILD='${BUILD_CC}' \
21 LD_FOR_BUILD='${BUILD_LD}' \
22 CFLAGS_FOR_BUILD='${BUILD_CFLAGS}' \
23 LDFLAGS_FOR_BUILD='${BUILD_LDFLAGS}' \
24 "
25
26EXTRA_OECONF += "--disable-libwww-client --disable-wininet-client"
27
28PACKAGECONFIG ??= "curl cplusplus"
29
30PACKAGECONFIG[abyss] = "--enable-abyss-server --enable-abyss-threads --enable-abyss-openssl,--disable-abyss-server --disable-abyss-threads --disable-abyss-openssl,openssl"
31PACKAGECONFIG[cplusplus] = "--enable-cplusplus,--disable-cplusplus"
32PACKAGECONFIG[curl] = "--enable-curl-client,--disable-curl-client,curl"
33
34do_configure() {
35 gnu-configize --verbose --force ${S}
36 autoconf
37 oe_runconf
38 # license is incompatible with lib/util/getoptx.*
39 rm -fv ${S}/tools/turbocharger/mod_gzip.c
40}
41
42do_install:append:class-target() {
43 sed -i 's,${WORKDIR},${TARGET_DBGSRC_DIR},g' ${D}${bindir}/xmlrpc-c-config
44}
45
46BBCLASSEXTEND = "native"
47
48CLEANBROKEN = "1"