summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/uw-imap/uw-imap_2007f.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2014-12-31 15:15:26 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2015-01-08 12:04:26 +0100
commitad6e0184266241e28216681f6fa0b7dc48f79344 (patch)
tree3e1eed6fd58a6e5a1dc61ba3b28a50f60d6f2a28 /meta-oe/recipes-devtools/uw-imap/uw-imap_2007f.bb
parent2b30fc6fe906d525b703e999138fcb9a0da150db (diff)
downloadmeta-openembedded-ad6e0184266241e28216681f6fa0b7dc48f79344.tar.gz
libc-client: rename to uw-imap, upgrade to 2007f
* Upgrade to 2007f * Rename to uw-imap; this is the name used by Fedora and is much more sensible than libc-client * Fix errors when linking the library against code compiled with -fPIC such as mod-php (patch from Fedora). * Add a security patch from Fedora * Rename files directory to uw-imap Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-oe/recipes-devtools/uw-imap/uw-imap_2007f.bb')
-rw-r--r--meta-oe/recipes-devtools/uw-imap/uw-imap_2007f.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/uw-imap/uw-imap_2007f.bb b/meta-oe/recipes-devtools/uw-imap/uw-imap_2007f.bb
new file mode 100644
index 000000000..e1a987710
--- /dev/null
+++ b/meta-oe/recipes-devtools/uw-imap/uw-imap_2007f.bb
@@ -0,0 +1,41 @@
1SUMMARY = "UW c-client library for mail protocols"
2SECTION = "devel"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a6a4ddbb7cd2999f6827ee143f6fcd97"
6
7DEPENDS = "openssl libpam"
8
9SRC_URI = "ftp://ftp.cac.washington.edu/imap/imap-${PV}.tar.gz \
10 file://quote_cctype.patch \
11 file://imap-2007e-shared.patch \
12 file://imap-2007f-format-security.patch \
13 "
14
15SRC_URI[md5sum] = "2126fd125ea26b73b20f01fcd5940369"
16SRC_URI[sha256sum] = "53e15a2b5c1bc80161d42e9f69792a3fa18332b7b771910131004eb520004a28"
17
18S = "${WORKDIR}/imap-${PV}"
19
20EXTRA_OEMAKE = "CC='${CC}'"
21
22HEADERS = "src/c-client/*.h src/osdep/unix/*.h c-client/auths.c c-client/linkage.c c-client/linkage.h c-client/osdep.h"
23
24do_compile() {
25 echo "SSLINCLUDE=${STAGING_INCDIR} SSLLIB=${STAGING_LIBDIR}" > ${S}/SPECIALS
26 oe_runmake lnp
27}
28
29do_install() {
30 install -d ${D}${includedir}/c-client
31 install ${HEADERS} ${D}${includedir}/c-client
32 install -d ${D}${libdir}
33 install c-client/c-client.a ${D}${libdir}/libc-client.a
34}
35
36RPROVIDES_${PN} = "libc-client"
37RREPLACES_${PN} = "libc-client"
38RCONFLICTS_${PN} = "libc-client"
39
40ALLOW_EMPTY_${PN} = "1"
41