diff options
author | Khem Raj <raj.khem@gmail.com> | 2023-01-21 10:59:14 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-01-21 23:36:00 -0800 |
commit | e95aca9bd00823ee72bab1f7059fab5adc48e46c (patch) | |
tree | 6bb6da81897f67d2d92cf2f96b346fc16535899d /meta-oe/recipes-devtools/uftrace | |
parent | afe5ea5eaf6d25a6b1c0b30fdbe11fdbad824162 (diff) | |
download | meta-openembedded-e95aca9bd00823ee72bab1f7059fab5adc48e46c.tar.gz |
uftreace: Fix a build race
Fixes a build race seen after 0.13 upgrade
| /home/pokybuild/yocto-worker/meta-oe/build/build/tmp/work/core2-64-poky-linux/uftrace/0.13-r0/git/cmds/dump.c: In function 'dump_mermaid_footer':
| /home/pokybuild/yocto-worker/meta-oe/build/build/tmp/work/core2-64-poky-linux/uftrace/0.13-r0/git/cmds/dump.c:1347:10: fatal error: utils/mermaid.html.cstr: No such file or directory
| 1347 | #include "utils/mermaid.html.cstr" /* This file is a converted of mermaid.html to one string literal in build-time */
| | ^~~~~~~~~~~~~~~~~~~~~~~~~
| compilation terminated.
| make[1]: *** [Makefile:310: /home/pokybuild/yocto-worker/meta-oe/build/build/tmp/work/core2-64-poky-linux/uftrace/0.13-r0/build/cmds/dump.o] Error 1
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/uftrace')
-rw-r--r-- | meta-oe/recipes-devtools/uftrace/uftrace/0001-build-Fix-a-build-race-related-to-utils-mermaid.html.patch | 38 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/uftrace/uftrace_0.13.bb | 1 |
2 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/uftrace/uftrace/0001-build-Fix-a-build-race-related-to-utils-mermaid.html.patch b/meta-oe/recipes-devtools/uftrace/uftrace/0001-build-Fix-a-build-race-related-to-utils-mermaid.html.patch new file mode 100644 index 000000000..2cb4f26fb --- /dev/null +++ b/meta-oe/recipes-devtools/uftrace/uftrace/0001-build-Fix-a-build-race-related-to-utils-mermaid.html.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | From 1fa61d77fa7173744dd6dc9d3c4bb0aa783f5222 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 21 Jan 2023 10:35:46 -0800 | ||
4 | Subject: [PATCH] build: Fix a build race related to utils/mermaid.html.cstr | ||
5 | |||
6 | Sometimes build fails like below | ||
7 | |||
8 | | /home/pokybuild/yocto-worker/meta-oe/build/build/tmp/work/core2-64-poky-linux/uftrace/0.13-r0/git/cmds/dump.c: In function 'dump_mermaid_footer': | ||
9 | | /home/pokybuild/yocto-worker/meta-oe/build/build/tmp/work/core2-64-poky-linux/uftrace/0.13-r0/git/cmds/dump.c:1347:10: fatal error: utils/mermaid.html.cstr: No such file or directory | ||
10 | | 1347 | #include "utils/mermaid.html.cstr" /* This file is a converted of mermaid.html to one string literal in build-time */ | ||
11 | | | ^~~~~~~~~~~~~~~~~~~~~~~~~ | ||
12 | | compilation terminated. | ||
13 | | make[1]: *** [Makefile:310: /home/pokybuild/yocto-worker/meta-oe/build/build/tmp/work/core2-64-poky-linux/uftrace/0.13-r0/build/cmds/dump.o] Error 1 | ||
14 | |||
15 | Create a dependency on c-str-conversion for dump.o | ||
16 | |||
17 | Upstream-Status: Submitted [https://github.com/namhyung/uftrace/pull/1622] | ||
18 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
19 | --- | ||
20 | Makefile | 2 ++ | ||
21 | 1 file changed, 2 insertions(+) | ||
22 | |||
23 | diff --git a/Makefile b/Makefile | ||
24 | index 70dc12f0..bb2ac669 100644 | ||
25 | --- a/Makefile | ||
26 | +++ b/Makefile | ||
27 | @@ -304,6 +304,8 @@ $(objdir)/misc/dbginfo.o: $(srcdir)/misc/dbginfo.c $(objdir)/version.h $(COMMON_ | ||
28 | $(objdir)/misc/bench.o: $(srcdir)/misc/bench.c | ||
29 | $(QUIET_CC)$(CC) $(BENCH_CFLAGS) -c -o $@ $< | ||
30 | |||
31 | +$(objdir)/cmds/dump.o: c-str-conversion | ||
32 | + | ||
33 | $(UFTRACE_OBJS_VERSION): $(objdir)/version.h | ||
34 | |||
35 | $(filter-out $(objdir)/uftrace.o, $(UFTRACE_OBJS)): $(objdir)/%.o: $(srcdir)/%.c $(COMMON_DEPS) | ||
36 | -- | ||
37 | 2.39.1 | ||
38 | |||
diff --git a/meta-oe/recipes-devtools/uftrace/uftrace_0.13.bb b/meta-oe/recipes-devtools/uftrace/uftrace_0.13.bb index a429f7948..130242098 100644 --- a/meta-oe/recipes-devtools/uftrace/uftrace_0.13.bb +++ b/meta-oe/recipes-devtools/uftrace/uftrace_0.13.bb | |||
@@ -12,6 +12,7 @@ inherit autotools | |||
12 | 12 | ||
13 | SRCREV = "53ec12d40701cf73ddcf5db8cff63b54736d0eda" | 13 | SRCREV = "53ec12d40701cf73ddcf5db8cff63b54736d0eda" |
14 | SRC_URI = "git://github.com/namhyung/${BPN};branch=master;protocol=https \ | 14 | SRC_URI = "git://github.com/namhyung/${BPN};branch=master;protocol=https \ |
15 | file://0001-build-Fix-a-build-race-related-to-utils-mermaid.html.patch \ | ||
15 | " | 16 | " |
16 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
17 | 18 | ||