diff options
author | Yi-Soo An <yisooan@gmail.com> | 2018-11-01 22:08:38 +0900 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-11-01 10:04:54 -0700 |
commit | 3cb22639385e9a359f1726b46a8467e1ef4c0fe0 (patch) | |
tree | f8d2f483d75915703ab29805cf28b1d5388510c1 /meta-oe/recipes-devtools/uftrace | |
parent | f1511d254632a34c1deb51f4bf8b8c21e7423f51 (diff) | |
download | meta-openembedded-3cb22639385e9a359f1726b46a8467e1ef4c0fe0.tar.gz |
uftrace: Support x86
If TARGET_ARCH is not set to i386 for x86, build will be failed
with logs such as "arch/i586: No such file or directory".
In this case, TARGET_ARCH is set to i586.
To succeed the build, add additional function named set_target_arch.
Signed-off-by: Yi-Soo An <yisooan@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/uftrace')
-rw-r--r-- | meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb | 13 |
1 files changed, 11 insertions, 2 deletions
diff --git a/meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb b/meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb index e377a5c9d..ca38e6aa2 100644 --- a/meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb +++ b/meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb | |||
@@ -18,7 +18,16 @@ SRC_URI = "git://github.com/namhyung/${BPN} \ | |||
18 | S = "${WORKDIR}/git" | 18 | S = "${WORKDIR}/git" |
19 | 19 | ||
20 | LDFLAGS_append_libc-musl = " -largp" | 20 | LDFLAGS_append_libc-musl = " -largp" |
21 | EXTRA_UFTRACE_OECONF = "ARCH=${TARGET_ARCH} \ | 21 | |
22 | def set_target_arch(d): | ||
23 | import re | ||
24 | arch = d.getVar('TARGET_ARCH', True) | ||
25 | if re.match(r'i.86', arch, re.I): | ||
26 | return 'i386' | ||
27 | else: | ||
28 | return arch | ||
29 | |||
30 | EXTRA_UFTRACE_OECONF = "ARCH=${@set_target_arch(d)} \ | ||
22 | with_elfutils=/use/libelf/from/sysroot" | 31 | with_elfutils=/use/libelf/from/sysroot" |
23 | 32 | ||
24 | do_configure() { | 33 | do_configure() { |
@@ -28,7 +37,7 @@ do_configure() { | |||
28 | FILES_SOLIBSDEV = "" | 37 | FILES_SOLIBSDEV = "" |
29 | FILES_${PN} += "${libdir}/*.so" | 38 | FILES_${PN} += "${libdir}/*.so" |
30 | 39 | ||
31 | COMPATIBLE_HOST = "(x86_64|aarch64|arm)" | 40 | COMPATIBLE_HOST = "(i.86|x86_64|aarch64|arm)" |
32 | 41 | ||
33 | # uftrace supports armv6 and above | 42 | # uftrace supports armv6 and above |
34 | COMPATIBLE_HOST_armv4 = 'null' | 43 | COMPATIBLE_HOST_armv4 = 'null' |