summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/tcltk/tk_8.5.8.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-08-17 22:52:35 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-08-17 22:52:35 +0200
commit888e2b64b61a00bc94e0c57f1c08153b6c54753c (patch)
treeba2e96968363ade171aad40429bddea058008064 /meta-oe/recipes-devtools/tcltk/tk_8.5.8.bb
parent924021a825df6412d063e078166bf6bc0ebdb5cf (diff)
downloadmeta-openembedded-888e2b64b61a00bc94e0c57f1c08153b6c54753c.tar.gz
tk 8.5.8: import from OE rev 5350bbef01b8979617e3d0fd38939f94f1fa5315
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-devtools/tcltk/tk_8.5.8.bb')
-rw-r--r--meta-oe/recipes-devtools/tcltk/tk_8.5.8.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/tcltk/tk_8.5.8.bb b/meta-oe/recipes-devtools/tcltk/tk_8.5.8.bb
new file mode 100644
index 000000000..247e55b69
--- /dev/null
+++ b/meta-oe/recipes-devtools/tcltk/tk_8.5.8.bb
@@ -0,0 +1,44 @@
1DESCRIPTION = "Tool Command Language ToolKit Extension"
2HOMEPAGE = "http://tcl.sourceforge.net"
3SECTION = "devel/tcltk"
4LICENSE = "tcl"
5LIC_FILES_CHKSUM = "file://license.terms;md5=24954e7e6b54c1b4e16de861b9d392fc"
6DEPENDS = "tcl virtual/libx11 libxt"
7
8SRC_URI = "\
9 ${SOURCEFORGE_MIRROR}/tcl/tk${PV}-src.tar.gz \
10 file://confsearch.diff;striplevel=2 \
11 file://manpages.diff;striplevel=2 \
12 file://non-linux.diff;striplevel=2 \
13 file://rpath.diff;striplevel=2 \
14 file://tklibrary.diff;striplevel=2 \
15 file://tkprivate.diff;striplevel=2 \
16 file://fix-xft.diff \
17"
18SRC_URI[md5sum] = "13bf90602e16fc530e05196431021dc6"
19SRC_URI[sha256sum] = "9737da5c30e631281062b6acbb4753840f9e95657c78e37657d9c520589ab2d4"
20
21S = "${WORKDIR}/tk${PV}/unix"
22
23inherit autotools
24
25EXTRA_OECONF = "\
26 --enable-threads \
27 --with-tcl=${STAGING_BINDIR_CROSS} \
28 --x-includes=${STAGING_INCDIR} \
29 --x-libraries=${STAGING_LIBDIR} \
30"
31
32do_install_append() {
33 mv libtk8.5.so libtk8.5.so.0
34 oe_libinstall -so libtk8.5 ${D}${libdir}
35 ln -sf wish8.5 ${D}${bindir}/wish
36}
37
38PACKAGES =+ "${PN}-lib"
39
40FILES_${PN}-lib = "${libdir}/libtk8.5.so.*"
41FILES_${PN} += "${libdir}/tk*"
42
43BINCONFIG_GLOB = "*Config.sh"
44BBCLASSEXTEND = "native"