summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/python
diff options
context:
space:
mode:
authorGeorge McCollister <george.mccollister@gmail.com>2016-05-27 15:56:35 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2016-06-08 14:55:24 +0200
commitc2c895ec5496ab5813d20a4d011ecdc73e46b256 (patch)
tree3db434728af18b9ebdb2b718dc05364d235818ae /meta-oe/recipes-devtools/python
parent350bd0bee460633592df3d9211b9cc15b4f9cb11 (diff)
downloadmeta-openembedded-c2c895ec5496ab5813d20a4d011ecdc73e46b256.tar.gz
python-simplejson: change to setuptools
Change from distutils to setuptools. simplejson's setup.py is written to import setup, Extension, Command from setuptools and fallback to distutils if the import fails. Prior to this change files were being installed to a host polluted path /usr/lib/python2.7/site-packages/simplejson-3.8.2-py2.7-linux-x86_64.egg (even on ARM targets). python was unable to import simplejson. Switching to setuptools corrects the problem. Signed-off-by: George McCollister <george.mccollister@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/python')
-rw-r--r--meta-oe/recipes-devtools/python/python-simplejson_3.8.2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/python/python-simplejson_3.8.2.bb b/meta-oe/recipes-devtools/python/python-simplejson_3.8.2.bb
index a2a6c400f..0c9112e44 100644
--- a/meta-oe/recipes-devtools/python/python-simplejson_3.8.2.bb
+++ b/meta-oe/recipes-devtools/python/python-simplejson_3.8.2.bb
@@ -14,7 +14,7 @@ SRC_URI[sha256sum] = "d58439c548433adcda98e695be53e526ba940a4b9c44fb9a05d92cd495
14 14
15S = "${WORKDIR}/${SRCNAME}-${PV}" 15S = "${WORKDIR}/${SRCNAME}-${PV}"
16 16
17inherit distutils 17inherit setuptools
18 18
19RDEPENDS_${PN} = "\ 19RDEPENDS_${PN} = "\
20 python-core \ 20 python-core \