summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/python
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-10-01 11:49:08 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-12 10:24:45 +0200
commit6cba8fe62d10226d2921aeed0a21c7fd18087467 (patch)
tree8c84af40cc2627458e18f19e7c853c3d0a000f2c /meta-oe/recipes-devtools/python
parent1f4e99d526e5cb5b4dc7844780734def5423943d (diff)
downloadmeta-openembedded-6cba8fe62d10226d2921aeed0a21c7fd18087467.tar.gz
python-cython: add patch to fix build error with some distutils packages
* fails with TypeError: unsupported operand type(s) for +: 'NoneType' and 'str' in setup.py when using python-2.6 or python-2.7 (don't know about python-3*) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-devtools/python')
-rw-r--r--meta-oe/recipes-devtools/python/python-cython-0.15.1/0001-Don-t-append-docs-to-_Extension.extension.__doc__.patch27
-rw-r--r--meta-oe/recipes-devtools/python/python-cython_0.15.1.bb5
2 files changed, 31 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/python/python-cython-0.15.1/0001-Don-t-append-docs-to-_Extension.extension.__doc__.patch b/meta-oe/recipes-devtools/python/python-cython-0.15.1/0001-Don-t-append-docs-to-_Extension.extension.__doc__.patch
new file mode 100644
index 000000000..9b9dd460b
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-cython-0.15.1/0001-Don-t-append-docs-to-_Extension.extension.__doc__.patch
@@ -0,0 +1,27 @@
1From bfed128dfe9551a3a40b1ac4269f18ecfeac80a9 Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Sat, 1 Oct 2011 11:46:30 +0200
4Subject: [PATCH] Don't append docs to _Extension.extension.__doc__
5
6* here it fails with TypeError: unsupported operand type(s) for +: 'NoneType' and 'str' in setup.py
7
8Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
9---
10 Cython/Distutils/extension.py | 1 -
11 1 files changed, 0 insertions(+), 1 deletions(-)
12
13diff --git a/Cython/Distutils/extension.py b/Cython/Distutils/extension.py
14index a5a6638..e76c1e7 100644
15--- a/Cython/Distutils/extension.py
16+++ b/Cython/Distutils/extension.py
17@@ -16,7 +16,6 @@ except ImportError:
18 warnings = None
19
20 class Extension(_Extension.Extension):
21- _Extension.Extension.__doc__ + \
22 """pyrex_include_dirs : [string]
23 list of directories to search for Pyrex header files (.pxd) (in
24 Unix form for portability)
25--
261.7.6.1
27
diff --git a/meta-oe/recipes-devtools/python/python-cython_0.15.1.bb b/meta-oe/recipes-devtools/python/python-cython_0.15.1.bb
index f22a47391..3b85601af 100644
--- a/meta-oe/recipes-devtools/python/python-cython_0.15.1.bb
+++ b/meta-oe/recipes-devtools/python/python-cython_0.15.1.bb
@@ -6,8 +6,11 @@ LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e23fadd6ceef8c618fc1c65191d846fa" 6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e23fadd6ceef8c618fc1c65191d846fa"
7SRCNAME = "Cython" 7SRCNAME = "Cython"
8BBCLASSEXTEND = "native" 8BBCLASSEXTEND = "native"
9PR = "r1"
9 10
10SRC_URI = "http://www.cython.org/release/${SRCNAME}-${PV}.tar.gz" 11SRC_URI = "http://www.cython.org/release/${SRCNAME}-${PV}.tar.gz \
12 file://0001-Don-t-append-docs-to-_Extension.extension.__doc__.patch \
13"
11S = "${WORKDIR}/${SRCNAME}-${PV}" 14S = "${WORKDIR}/${SRCNAME}-${PV}"
12 15
13SRC_URI[md5sum] = "171021b3845c9ca8bd6d8185b3cde664" 16SRC_URI[md5sum] = "171021b3845c9ca8bd6d8185b3cde664"