diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2012-02-01 09:20:31 +0100 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-02-01 09:20:31 +0100 |
commit | 954681ee47d741189156ef6fa8ace1f62426f214 (patch) | |
tree | c1706973d0fb76141daf0e342ae699d68a5e7195 /meta-oe/recipes-devtools/python | |
parent | 3fe3f88ef05da7803b9078cb6d77ebc7615c8159 (diff) | |
download | meta-openembedded-954681ee47d741189156ef6fa8ace1f62426f214.tar.gz |
python-twisted: import from OE-classic
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-devtools/python')
-rw-r--r-- | meta-oe/recipes-devtools/python/python-twisted_8.2.0.bb | 223 |
1 files changed, 223 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-twisted_8.2.0.bb b/meta-oe/recipes-devtools/python/python-twisted_8.2.0.bb new file mode 100644 index 000000000..0d703cf01 --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-twisted_8.2.0.bb | |||
@@ -0,0 +1,223 @@ | |||
1 | DESCRIPTION = "Twisted is an event-driven networking framework written in Python and licensed under the LGPL. \ | ||
2 | Twisted supports TCP, UDP, SSL/TLS, multicast, Unix sockets, a large number of protocols \ | ||
3 | (including HTTP, NNTP, IMAP, SSH, IRC, FTP, and others), and much more." | ||
4 | HOMEPAGE = "http://www.twistedmatrix.com" | ||
5 | SECTION = "console/network" | ||
6 | |||
7 | #twisted/topfiles/NEWS:655: - Relicensed: Now under the MIT license, rather than LGPL. | ||
8 | LICENSE = "MIT" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3ea27a26302ba9ad8b80a24781d41767" | ||
10 | |||
11 | SRC_URI = "http://tmrc.mit.edu/mirror/twisted/Twisted/8.2/Twisted-${PV}.tar.bz2 " | ||
12 | SRC_URI[md5sum] = "c85f151999df3ecf04c49a781b4438d2" | ||
13 | SRC_URI[sha256sum] = "e0602bb05e31f6100b6f9ab35cfa93ab9f7a1c50a351a0ddfcd236a923bddfb0" | ||
14 | |||
15 | S = "${WORKDIR}/Twisted-${PV}" | ||
16 | |||
17 | inherit setuptools | ||
18 | |||
19 | do_install_append() { | ||
20 | # remove some useless files before packaging | ||
21 | find ${D} -name "*.bat" -o -name "*.c" -o -name "*.h" -exec rm {} \; | ||
22 | } | ||
23 | |||
24 | PACKAGES += "\ | ||
25 | ${PN}-zsh \ | ||
26 | ${PN}-test \ | ||
27 | ${PN}-protocols \ | ||
28 | ${PN}-bin \ | ||
29 | ${PN}-conch \ | ||
30 | ${PN}-lore \ | ||
31 | ${PN}-mail \ | ||
32 | ${PN}-names \ | ||
33 | ${PN}-news \ | ||
34 | ${PN}-runner \ | ||
35 | ${PN}-web \ | ||
36 | ${PN}-words \ | ||
37 | ${PN}-flow \ | ||
38 | ${PN}-pair \ | ||
39 | ${PN}-core \ | ||
40 | " | ||
41 | |||
42 | RDEPENDS_${PN} = "python-core python-zopeinterface" | ||
43 | RDEPENDS_${PN} += "\ | ||
44 | ${PN}-bin \ | ||
45 | ${PN}-conch \ | ||
46 | ${PN}-lore \ | ||
47 | ${PN}-mail \ | ||
48 | ${PN}-names \ | ||
49 | ${PN}-news \ | ||
50 | ${PN}-runner \ | ||
51 | ${PN}-web \ | ||
52 | ${PN}-words \ | ||
53 | " | ||
54 | |||
55 | ALLOW_EMPTY_${PN} = "1" | ||
56 | FILES_${PN} = "" | ||
57 | |||
58 | FILES_${PN}-test = " \ | ||
59 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/test \ | ||
60 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/test \ | ||
61 | " | ||
62 | |||
63 | FILES_${PN}-protocols = " \ | ||
64 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/ \ | ||
65 | " | ||
66 | |||
67 | FILES_${PN}-zsh = " \ | ||
68 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zsh \ | ||
69 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.* \ | ||
70 | " | ||
71 | |||
72 | FILES_${PN}-bin = " \ | ||
73 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/_c_urlarg.so \ | ||
74 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/spread/cBanana.so \ | ||
75 | " | ||
76 | |||
77 | FILES_${PN}-conch = " \ | ||
78 | ${bindir}/ckeygen \ | ||
79 | ${bindir}/tkconch \ | ||
80 | ${bindir}/conch \ | ||
81 | ${bindir}/conchftp \ | ||
82 | ${bindir}/cftp \ | ||
83 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_conch.py* \ | ||
84 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/conch \ | ||
85 | " | ||
86 | |||
87 | FILES_${PN}-core = " \ | ||
88 | ${bindir}/manhole \ | ||
89 | ${bindir}/mktap \ | ||
90 | ${bindir}/twistd \ | ||
91 | ${bindir}/tap2deb \ | ||
92 | ${bindir}/tap2rpm \ | ||
93 | ${bindir}/tapconvert \ | ||
94 | ${bindir}/tkmktap \ | ||
95 | ${bindir}/trial \ | ||
96 | ${bindir}/easy_install* \ | ||
97 | ${bindir}/pyhtmlizer \ | ||
98 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \ | ||
99 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__init__.py* \ | ||
100 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/notestplugin.py* \ | ||
101 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/testplugin.py* \ | ||
102 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_ftp.py* \ | ||
103 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_inet.py* \ | ||
104 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_manhole.py* \ | ||
105 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_portforward.py* \ | ||
106 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_socks.py* \ | ||
107 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_telnet.py* \ | ||
108 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_trial.py* \ | ||
109 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/dropin.cache \ | ||
110 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/application \ | ||
111 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/cred \ | ||
112 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/enterprise \ | ||
113 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/internet \ | ||
114 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/manhole \ | ||
115 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/manhole \ | ||
116 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/persisted \ | ||
117 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols\ | ||
118 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python\ | ||
119 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/timeoutqueue.py* \ | ||
120 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/filepath.py* \ | ||
121 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dxprofile.py* \ | ||
122 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/plugin.py* \ | ||
123 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/htmlizer.py* \ | ||
124 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/__init__.py* \ | ||
125 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dispatch.py* \ | ||
126 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/hook.py* \ | ||
127 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadpool.py* \ | ||
128 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/otp.py* \ | ||
129 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/usage.py* \ | ||
130 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/roots.py* \ | ||
131 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/versions.py* \ | ||
132 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/urlpath.py* \ | ||
133 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/util.py* \ | ||
134 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/components.py* \ | ||
135 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/logfile.py* \ | ||
136 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/runtime.py* \ | ||
137 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/reflect.py* \ | ||
138 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/context.py* \ | ||
139 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadable.py* \ | ||
140 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/rebuild.py* \ | ||
141 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/failure.py* \ | ||
142 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/lockfile.py* \ | ||
143 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/formmethod.py* \ | ||
144 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/finalize.py* \ | ||
145 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/win32.py* \ | ||
146 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dist.py* \ | ||
147 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/shortcut.py* \ | ||
148 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zipstream.py* \ | ||
149 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/release.py* \ | ||
150 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/syslog.py* \ | ||
151 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/log.py* \ | ||
152 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/compat.py* \ | ||
153 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.py* \ | ||
154 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/procutils.py* \ | ||
155 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/text.py* \ | ||
156 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/_twisted_zsh_stub \ | ||
157 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/scripts/ \ | ||
158 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/spread/ \ | ||
159 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/tap/ \ | ||
160 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/trial/ \ | ||
161 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/__init__.py* \ | ||
162 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/_version.py* \ | ||
163 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/copyright.py* \ | ||
164 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/im.py* \ | ||
165 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \ | ||
166 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/*.py* \ | ||
167 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/*.py* \ | ||
168 | " | ||
169 | |||
170 | FILES_${PN}-lore = " \ | ||
171 | ${bindir}/bookify \ | ||
172 | ${bindir}/lore \ | ||
173 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_lore.py* \ | ||
174 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/lore \ | ||
175 | " | ||
176 | |||
177 | FILES_${PN}-mail = " \ | ||
178 | ${bindir}/mailmail \ | ||
179 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_mail.py* \ | ||
180 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/mail \ | ||
181 | " | ||
182 | |||
183 | FILES_${PN}-names = " \ | ||
184 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_names.py* \ | ||
185 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/names \ | ||
186 | " | ||
187 | |||
188 | FILES_${PN}-news = " \ | ||
189 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_news.py* \ | ||
190 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/news \ | ||
191 | " | ||
192 | |||
193 | FILES_${PN}-runner = " \ | ||
194 | ${libdir}/site-packages/twisted/runner/portmap.so \ | ||
195 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/runner\ | ||
196 | " | ||
197 | |||
198 | FILES_${PN}-web = " \ | ||
199 | ${bindir}/websetroot \ | ||
200 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_web.py* \ | ||
201 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/web\ | ||
202 | " | ||
203 | |||
204 | FILES_${PN}-words = " \ | ||
205 | ${bindir}/im \ | ||
206 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_words.py* \ | ||
207 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/words\ | ||
208 | " | ||
209 | |||
210 | FILES_${PN}-flow = " \ | ||
211 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_flow.py* \ | ||
212 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/flow \" | ||
213 | |||
214 | FILES_${PN}-pair = " \ | ||
215 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_pair.py* \ | ||
216 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/pair \ | ||
217 | " | ||
218 | |||
219 | FILES_${PN}-dbg += " \ | ||
220 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/.debug \ | ||
221 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*/.debug \ | ||
222 | " | ||
223 | |||