diff options
author | Khem Raj <raj.khem@gmail.com> | 2020-01-19 16:33:15 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-01-22 09:56:34 -0800 |
commit | 505774658338002a92c2e32c4c57c55f36c5e36e (patch) | |
tree | c5d1032aac37af7493141cdfa56da5b371ce5a59 /meta-oe/recipes-devtools/python | |
parent | 66454b26ff49c6cca3dd8d32832078cfa05cd5ef (diff) | |
download | meta-openembedded-505774658338002a92c2e32c4c57c55f36c5e36e.tar.gz |
meta-oe: Remove using python2
This change makes the parsing go though, we still might have build
issues, which will be reported in world builds seprately
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/python')
-rw-r--r-- | meta-oe/recipes-devtools/python/python-cpuset_1.6.bb | 18 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/python/python-distutils-extra.bb | 7 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/python/python-futures_3.3.0.bb | 13 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/python/python-jsmin_2.2.2.bb | 11 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/python/python-pytoml.inc | 12 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/python/python-pytoml_0.1.21.bb | 2 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/python/python-six_1.13.0.bb | 2 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/python/python-which_1.1.0.bb | 19 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/python/python3-pygobject/0001-python-pyobject-fix-install-dir.patch (renamed from meta-oe/recipes-devtools/python/python-pygobject/0001-python-pyobject-fix-install-dir.patch) | 0 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/python/python3-pygobject_3.34.0.bb (renamed from meta-oe/recipes-devtools/python/python-pygobject_3.34.0.bb) | 11 |
10 files changed, 5 insertions, 90 deletions
diff --git a/meta-oe/recipes-devtools/python/python-cpuset_1.6.bb b/meta-oe/recipes-devtools/python/python-cpuset_1.6.bb deleted file mode 100644 index 1255a51f7..000000000 --- a/meta-oe/recipes-devtools/python/python-cpuset_1.6.bb +++ /dev/null | |||
@@ -1,18 +0,0 @@ | |||
1 | SUMMARY = "Cpuset is a Python application to make using the cpusets facilities in the Linux kernel easier" | ||
2 | SECTION = "devel/python" | ||
3 | LICENSE = "GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" | ||
5 | |||
6 | S = "${WORKDIR}/git" | ||
7 | SRCREV = "6c46d71a1c6ee711063153b9f7787280128f7252" | ||
8 | SRC_URI = "git://github.com/lpechacek/cpuset.git;protocol=https;" | ||
9 | |||
10 | inherit distutils | ||
11 | |||
12 | RDEPENDS_${PN} = "\ | ||
13 | python-core \ | ||
14 | python-re \ | ||
15 | python-logging \ | ||
16 | python-textutils \ | ||
17 | python-unixadmin \ | ||
18 | " | ||
diff --git a/meta-oe/recipes-devtools/python/python-distutils-extra.bb b/meta-oe/recipes-devtools/python/python-distutils-extra.bb deleted file mode 100644 index eb84f7436..000000000 --- a/meta-oe/recipes-devtools/python/python-distutils-extra.bb +++ /dev/null | |||
@@ -1,7 +0,0 @@ | |||
1 | require python-distutils-extra.inc | ||
2 | |||
3 | inherit setuptools | ||
4 | |||
5 | RDEPENDS_${PN} = "\ | ||
6 | python-distutils \ | ||
7 | " | ||
diff --git a/meta-oe/recipes-devtools/python/python-futures_3.3.0.bb b/meta-oe/recipes-devtools/python/python-futures_3.3.0.bb deleted file mode 100644 index 1636f7371..000000000 --- a/meta-oe/recipes-devtools/python/python-futures_3.3.0.bb +++ /dev/null | |||
@@ -1,13 +0,0 @@ | |||
1 | DESCRIPTION = "The concurrent.futures module provides a high-level interface for asynchronously executing callables." | ||
2 | SECTION = "devel/python" | ||
3 | LICENSE = "PSF" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=834d982f973c48b6d662b5944c5ab567" | ||
5 | HOMEPAGE = "https://github.com/agronholm/pythonfutures" | ||
6 | DEPENDS = "python" | ||
7 | |||
8 | SRC_URI[md5sum] = "b43a39ae1475e3fd6940f2b4f7214675" | ||
9 | SRC_URI[sha256sum] = "7e033af76a5e35f58e56da7a91e687706faf4e7bdfb2cbc3f2cca6b9bcda9794" | ||
10 | |||
11 | inherit pypi setuptools | ||
12 | |||
13 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-oe/recipes-devtools/python/python-jsmin_2.2.2.bb b/meta-oe/recipes-devtools/python/python-jsmin_2.2.2.bb deleted file mode 100644 index d00d1e2a0..000000000 --- a/meta-oe/recipes-devtools/python/python-jsmin_2.2.2.bb +++ /dev/null | |||
@@ -1,11 +0,0 @@ | |||
1 | DESCRIPTION = "JavaScript minifier." | ||
2 | HOMEPAGE = "https://github.com/tikitu/jsmin/" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3a3301ce2ad647e172f4a1016c67324d" | ||
6 | |||
7 | inherit setuptools pypi | ||
8 | SRC_URI[md5sum] = "00e7a3179a4591aab2ee707b3214e2fd" | ||
9 | SRC_URI[sha256sum] = "b6df99b2cd1c75d9d342e4335b535789b8da9107ec748212706ef7bbe5c2553b" | ||
10 | |||
11 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-oe/recipes-devtools/python/python-pytoml.inc b/meta-oe/recipes-devtools/python/python-pytoml.inc deleted file mode 100644 index 180531d75..000000000 --- a/meta-oe/recipes-devtools/python/python-pytoml.inc +++ /dev/null | |||
@@ -1,12 +0,0 @@ | |||
1 | SUMMARY = "A TOML-0.4.0 parser/writer for Python" | ||
2 | HOMEPAGE = "https://pypi.python.org/pypi/pytoml/" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=cfff423699bdaef24331933ac4f56078" | ||
6 | |||
7 | SRC_URI[md5sum] = "e59dd36a559dd2a876e4c149c69e947b" | ||
8 | SRC_URI[sha256sum] = "8eecf7c8d0adcff3b375b09fe403407aa9b645c499e5ab8cac670ac4a35f61e7" | ||
9 | |||
10 | inherit pypi | ||
11 | |||
12 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-oe/recipes-devtools/python/python-pytoml_0.1.21.bb b/meta-oe/recipes-devtools/python/python-pytoml_0.1.21.bb deleted file mode 100644 index 88fa95317..000000000 --- a/meta-oe/recipes-devtools/python/python-pytoml_0.1.21.bb +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | inherit pypi setuptools | ||
2 | require python-pytoml.inc | ||
diff --git a/meta-oe/recipes-devtools/python/python-six_1.13.0.bb b/meta-oe/recipes-devtools/python/python-six_1.13.0.bb deleted file mode 100644 index af26e83d6..000000000 --- a/meta-oe/recipes-devtools/python/python-six_1.13.0.bb +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | inherit pypi setuptools | ||
2 | require recipes-devtools/python/python-six.inc | ||
diff --git a/meta-oe/recipes-devtools/python/python-which_1.1.0.bb b/meta-oe/recipes-devtools/python/python-which_1.1.0.bb deleted file mode 100644 index 901fdc763..000000000 --- a/meta-oe/recipes-devtools/python/python-which_1.1.0.bb +++ /dev/null | |||
@@ -1,19 +0,0 @@ | |||
1 | DESCRIPTION = "which.py -- a portable GNU which replacement" | ||
2 | HOMEPAGE = "http://code.google.com/p/which/" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=030b09798681482b9ad12ac47be496ea" | ||
6 | |||
7 | inherit setuptools pypi python-dir | ||
8 | |||
9 | SRCREV = "425bdeeb2d87c36e2313dc4b8d69ff2bb5a02ee9" | ||
10 | PYPI_SRC_URI = "git://github.com/trentm/which" | ||
11 | |||
12 | S = "${WORKDIR}/git" | ||
13 | |||
14 | do_install_append() { | ||
15 | rmdir -p --ignore-fail-on-non-empty ${D}${STAGING_BINDIR_NATIVE} | ||
16 | rmdir -p --ignore-fail-on-non-empty ${D}${datadir} | ||
17 | } | ||
18 | |||
19 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-oe/recipes-devtools/python/python-pygobject/0001-python-pyobject-fix-install-dir.patch b/meta-oe/recipes-devtools/python/python3-pygobject/0001-python-pyobject-fix-install-dir.patch index 848cda5aa..848cda5aa 100644 --- a/meta-oe/recipes-devtools/python/python-pygobject/0001-python-pyobject-fix-install-dir.patch +++ b/meta-oe/recipes-devtools/python/python3-pygobject/0001-python-pyobject-fix-install-dir.patch | |||
diff --git a/meta-oe/recipes-devtools/python/python-pygobject_3.34.0.bb b/meta-oe/recipes-devtools/python/python3-pygobject_3.34.0.bb index 0cbd07f66..b016df719 100644 --- a/meta-oe/recipes-devtools/python/python-pygobject_3.34.0.bb +++ b/meta-oe/recipes-devtools/python/python3-pygobject_3.34.0.bb | |||
@@ -5,14 +5,13 @@ LICENSE = "LGPLv2.1" | |||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7" | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7" |
6 | 6 | ||
7 | GNOMEBASEBUILDCLASS = "meson" | 7 | GNOMEBASEBUILDCLASS = "meson" |
8 | inherit gnomebase gobject-introspection distutils-base upstream-version-is-even | 8 | inherit gnomebase gobject-introspection distutils3-base upstream-version-is-even |
9 | 9 | ||
10 | DEPENDS += "python glib-2.0" | 10 | DEPENDS += "python3 glib-2.0" |
11 | 11 | ||
12 | SRCNAME = "pygobject" | 12 | SRCNAME = "pygobject" |
13 | SRC_URI = " \ | 13 | SRC_URI = " \ |
14 | http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \ | 14 | http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \ |
15 | file://0001-python-pyobject-fix-install-dir.patch \ | ||
16 | " | 15 | " |
17 | 16 | ||
18 | SRC_URI[md5sum] = "ca1dc4f31c1d6d283758e8f315a88ab6" | 17 | SRC_URI[md5sum] = "ca1dc4f31c1d6d283758e8f315a88ab6" |
@@ -22,12 +21,12 @@ S = "${WORKDIR}/${SRCNAME}-${PV}" | |||
22 | 21 | ||
23 | UNKNOWN_CONFIGURE_WHITELIST = "introspection" | 22 | UNKNOWN_CONFIGURE_WHITELIST = "introspection" |
24 | 23 | ||
25 | PACKAGECONFIG ??= "stagedir" | 24 | PACKAGECONFIG ??= "" |
26 | 25 | ||
27 | PACKAGECONFIG[cairo] = "-Dpycairo=true,-Dpycairo=false, cairo python-pycairo, python-pycairo" | 26 | PACKAGECONFIG[cairo] = "-Dpycairo=true,-Dpycairo=false, cairo python-pycairo, python-pycairo" |
28 | PACKAGECONFIG[tests] = "-Dtests=true, -Dtests=false, , " | 27 | PACKAGECONFIG[tests] = "-Dtests=true, -Dtests=false, , " |
29 | PACKAGECONFIG[python] = "-Dpython=python3, -Dpython=python2, , " | 28 | |
30 | PACKAGECONFIG[stagedir] = "-Dstagedir=${PYTHON_SITEPACKAGES_DIR}, -Dstagedir="", , " | 29 | EXTRA_OEMESON_append = " -Dpython=python3" |
31 | 30 | ||
32 | BBCLASSEXTEND = "native" | 31 | BBCLASSEXTEND = "native" |
33 | RDEPENDS_${PN} = "python-pkgutil" | 32 | RDEPENDS_${PN} = "python-pkgutil" |