diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2016-01-07 15:57:45 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-01-14 11:30:15 +0100 |
commit | 2bd11da4b50f401c9c49975aeedaaafa6a59d08b (patch) | |
tree | db1b531c534d13cd51d0b9fa4c418b89e899879e /meta-oe/recipes-devtools/python | |
parent | 8700ba38804af3c27f3662737f679afa1bdc86da (diff) | |
download | meta-openembedded-2bd11da4b50f401c9c49975aeedaaafa6a59d08b.tar.gz |
recipes: remove recipes using or depending on qt4 bbclasses or recipes
* anki is removed because it runtime depends on python-pyqt, other
recipes are inheriting one of bbclasses removed from oe-core in:
commit cb89d2b25b4edb1241bc5426a69a6bc44df9be2c
Author: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Date: Fri Nov 27 15:48:20 2015 +0200
qt4: remove recipes and classes
* if you're still using one of these recipes add it to meta-qt4 layer
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/python')
-rw-r--r-- | meta-oe/recipes-devtools/python/python-pyqt_4.11.3.bb | 59 |
1 files changed, 0 insertions, 59 deletions
diff --git a/meta-oe/recipes-devtools/python/python-pyqt_4.11.3.bb b/meta-oe/recipes-devtools/python/python-pyqt_4.11.3.bb deleted file mode 100644 index cfddee869..000000000 --- a/meta-oe/recipes-devtools/python/python-pyqt_4.11.3.bb +++ /dev/null | |||
@@ -1,59 +0,0 @@ | |||
1 | SUMMARY = "Python Qt4 Bindings" | ||
2 | AUTHOR = "Phil Thomson @ riverbank.co.uk" | ||
3 | HOMEPAGE = "http://riverbankcomputing.co.uk" | ||
4 | SECTION = "devel/python" | ||
5 | LICENSE = "GPLv2 & GPLv3 & GPL_EXCEPTION" | ||
6 | LIC_FILES_CHKSUM = "\ | ||
7 | file://GPL_EXCEPTION.TXT;md5=b73b0be471db679533dc94781c14af58 \ | ||
8 | file://GPL_EXCEPTION_ADDENDUM.TXT;md5=c1e04ec2aa0911061005a801abf81e40 \ | ||
9 | file://OPENSOURCE-NOTICE.TXT;md5=6ad9123620cc04a22c394753ad4767d7 \ | ||
10 | file://LICENSE.GPL2;md5=577ff65f6653562af318bfc3944b1f20 \ | ||
11 | file://LICENSE.GPL3;md5=feee51612c3c1191a1d5f41156fa2c75 \ | ||
12 | " | ||
13 | DEPENDS = "sip sip-native qt4-x11-free python" | ||
14 | |||
15 | SRC_URI = "\ | ||
16 | ${SOURCEFORGE_MIRROR}/pyqt/PyQt-x11-gpl-${PV}.tar.gz \ | ||
17 | " | ||
18 | SRC_URI[md5sum] = "997c3e443165a89a559e0d96b061bf70" | ||
19 | SRC_URI[sha256sum] = "853780dcdbe2e6ba785d703d059b096e1fc49369d3e8d41a060be874b8745686" | ||
20 | |||
21 | S = "${WORKDIR}/PyQt-x11-gpl-${PV}" | ||
22 | |||
23 | PARALLEL_MAKE = "" | ||
24 | |||
25 | inherit qmake2 pythonnative python-dir distro_features_check | ||
26 | # depends on qt4-x11-free | ||
27 | REQUIRED_DISTRO_FEATURES = "x11" | ||
28 | |||
29 | DISABLED_FEATURES = "PyQt_Desktop_OpenGL PyQt_Accessibility PyQt_SessionManager" | ||
30 | |||
31 | DISABLED_FEATURES_append_arm = " PyQt_qreal_double" | ||
32 | |||
33 | PYQT_MODULES = "QtCore QtGui QtDeclarative QtNetwork QtSvg QtWebKit" | ||
34 | PYQT_MODULES_aarch64 = "QtCore QtGui QtDeclarative QtNetwork QtSvg" | ||
35 | |||
36 | do_configure() { | ||
37 | echo "py_platform = linux" > pyqt.cfg | ||
38 | echo "py_inc_dir = %(sysroot)/$includedir/python%(py_major).%(py_minor)" >> pyqt.cfg | ||
39 | echo "py_pylib_dir = %(sysroot)/${libdir}/python%(py_major).%(py_minor)" >> pyqt.cfg | ||
40 | echo "py_pylib_lib = python%(py_major).%(py_minor)mu" >> pyqt.cfg | ||
41 | echo "pyqt_module_dir = ${D}/${libdir}/python%(py_major).%(py_minor)/site-packages" >> pyqt.cfg | ||
42 | echo "pyqt_bin_dir = ${D}/${bindir}" >> pyqt.cfg | ||
43 | echo "pyqt_sip_dir = ${D}/${datadir}/sip/PyQt4" >> pyqt.cfg | ||
44 | echo "pyuic_interpreter = ${D}/${bindir}/python%(py_major).%(py_minor)" >> pyqt.cfg | ||
45 | echo "pyqt_disabled_features = ${DISABLED_FEATURES}" >> pyqt.cfg | ||
46 | echo "qt_shared = True" >> pyqt.cfg | ||
47 | echo "[Qt 4.8]" >> pyqt.cfg | ||
48 | echo "pyqt_modules = ${PYQT_MODULES}" >> pyqt.cfg | ||
49 | echo yes | python configure-ng.py --verbose --qmake ${STAGING_BINDIR_NATIVE}/qmake2 --configuration pyqt.cfg --sysroot ${STAGING_DIR_HOST} | ||
50 | } | ||
51 | do_install() { | ||
52 | oe_runmake install | ||
53 | } | ||
54 | |||
55 | RDEPENDS_${PN} = "python-core python-sip" | ||
56 | |||
57 | FILES_${PN} += "${libdir}/${PYTHON_DIR}/site-packages ${datadir}/sip/PyQt4/" | ||
58 | FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/*/.debug/" | ||
59 | |||