diff options
author | Andreas Müller <schnitzeltony@googlemail.com> | 2016-10-31 23:10:37 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-11-23 15:23:59 +0100 |
commit | b24dd42d480c8f4deb1828d4ca55f18acd28148c (patch) | |
tree | c728c99afd3467f5e622509c23ac1fef7dc38fc1 /meta-oe/recipes-devtools/python | |
parent | 471cd564fd72a34ac62f702fad8983f44e4b411a (diff) | |
download | meta-openembedded-b24dd42d480c8f4deb1828d4ca55f18acd28148c.tar.gz |
python-distutils-extra: initial add 2.39
add version for python2 and python3
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/python')
3 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-distutils-extra.bb b/meta-oe/recipes-devtools/python/python-distutils-extra.bb new file mode 100644 index 000000000..56dd33d7f --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-distutils-extra.bb | |||
@@ -0,0 +1,9 @@ | |||
1 | require python-distutils-extra.inc | ||
2 | |||
3 | inherit setuptools | ||
4 | |||
5 | DISTUTILS_INSTALL_ARGS += "--install-lib=${libdir}/${PYTHON_DIR}/site-packages" | ||
6 | |||
7 | RDEPENDS_${PN} = "\ | ||
8 | python-distutils \ | ||
9 | " | ||
diff --git a/meta-oe/recipes-devtools/python/python-distutils-extra.inc b/meta-oe/recipes-devtools/python/python-distutils-extra.inc new file mode 100644 index 000000000..4d87d77cd --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-distutils-extra.inc | |||
@@ -0,0 +1,13 @@ | |||
1 | SUMMARY = "python-distutils extension" | ||
2 | DESCRITION = "python-distutils extension integrating gettext support, themed icons and scrollkeeper based documentation" | ||
3 | HOMEPAGE = "https://launchpad.net/python-distutils-extra" | ||
4 | SECTION = "devel/python" | ||
5 | LICENSE = "GPLv2" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4325afd396febcb659c36b49533135d4" | ||
7 | |||
8 | PV = "2.39" | ||
9 | SRC_URI = "https://launchpad.net/python-distutils-extra/trunk/${PV}/+download/python-distutils-extra-${PV}.tar.gz" | ||
10 | SRC_URI[md5sum] = "16e06db0ef73a35b4bff4b9eed5699b5" | ||
11 | SRC_URI[sha256sum] = "723f24f4d65fc8d99b33a002fbbb3771d4cc9d664c97085bf37f3997ae8063af" | ||
12 | |||
13 | BBCLASSEXTEND = "native" | ||
diff --git a/meta-oe/recipes-devtools/python/python3-distutils-extra.bb b/meta-oe/recipes-devtools/python/python3-distutils-extra.bb new file mode 100644 index 000000000..af242b850 --- /dev/null +++ b/meta-oe/recipes-devtools/python/python3-distutils-extra.bb | |||
@@ -0,0 +1,11 @@ | |||
1 | require python-distutils-extra.inc | ||
2 | |||
3 | inherit setuptools3 | ||
4 | |||
5 | S = "${WORKDIR}/python-distutils-extra-${PV}" | ||
6 | |||
7 | DISTUTILS_INSTALL_ARGS += "--install-lib=${libdir}/${PYTHON_DIR}/site-packages" | ||
8 | |||
9 | RDEPENDS_${PN} = "\ | ||
10 | python3-setuptools \ | ||
11 | " | ||