diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2011-04-10 13:24:47 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2011-04-10 14:43:41 +0200 |
commit | 89500c583e0f1dc1b4ffdf72914e08e505e427e0 (patch) | |
tree | b073036cc61aa34ca5ac9eec4d617366e0dcb3d5 /meta-oe/recipes-devtools/python | |
parent | e66079da37992abd54486488aa06a99bf7a4198c (diff) | |
download | meta-openembedded-89500c583e0f1dc1b4ffdf72914e08e505e427e0.tar.gz |
recipes,classes: import a lot of recipes from meta-shr
* tested on shr-lite-image for om-gta02 and nokia900 (with meta-shr layer)
Diffstat (limited to 'meta-oe/recipes-devtools/python')
10 files changed, 253 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-dateutil_1.4.1.bb b/meta-oe/recipes-devtools/python/python-dateutil_1.4.1.bb new file mode 100644 index 000000000..8cde2886e --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-dateutil_1.4.1.bb | |||
@@ -0,0 +1,24 @@ | |||
1 | DESCRIPTION = "Extensions to the standard Python date/time support" | ||
2 | HOMEPAGE = "http://labix.org/python-dateutil" | ||
3 | SECTION = "devel/python" | ||
4 | PRIORITY = "optional" | ||
5 | LICENSE = "PSF" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d82268718c68bda0b091006ec6e583c6" | ||
7 | SRCNAME = "${PN}" | ||
8 | PR = "r1" | ||
9 | |||
10 | SRC_URI = "http://labix.org/download/python-dateutil/${SRCNAME}-${PV}.tar.gz" | ||
11 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
12 | |||
13 | inherit setuptools | ||
14 | |||
15 | PACKAGES =+ "${PN}-zoneinfo" | ||
16 | FILES_${PN}-zoneinfo = "${libdir}/${PYTHON_DIR}/site-packages/dateutil/zoneinfo" | ||
17 | |||
18 | RDEPENDS_${PN} = "\ | ||
19 | python-core \ | ||
20 | python-datetime \ | ||
21 | " | ||
22 | |||
23 | SRC_URI[md5sum] = "2a5f25ab12fcefcf0b21348f2d47595a" | ||
24 | SRC_URI[sha256sum] = "74b615c6a55b4421187feba1633fc233e7c5ebdd7abe9b092447a32946823357" | ||
diff --git a/meta-oe/recipes-devtools/python/python-numeric/no-lapack.patch b/meta-oe/recipes-devtools/python/python-numeric/no-lapack.patch new file mode 100644 index 000000000..c1916b8b9 --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-numeric/no-lapack.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | |||
2 | # | ||
3 | # Patch managed by http://www.holgerschurig.de/patcher.html | ||
4 | # | ||
5 | |||
6 | --- Numeric-23.7/setup.py~nolapack | ||
7 | +++ Numeric-23.7/setup.py | ||
8 | @@ -32,7 +32,7 @@ | ||
9 | mathlibs = [] | ||
10 | |||
11 | # delete all but the first one in this list if using your own LAPACK/BLAS | ||
12 | -sourcelist = [os.path.join('Src', 'lapack_litemodule.c'), | ||
13 | +sourcelist = [ | ||
14 | #os.path.join('Src', 'blas_lite.c'), | ||
15 | #os.path.join('Src', 'f2c_lite.c'), | ||
16 | #os.path.join('Src', 'zlapack_lite.c'), | ||
17 | @@ -40,12 +40,12 @@ | ||
18 | ] | ||
19 | # set these to use your own BLAS; | ||
20 | |||
21 | -library_dirs_list = ['/usr/lib/atlas'] | ||
22 | -libraries_list = ['lapack', 'cblas', 'f77blas', 'atlas', 'g2c'] | ||
23 | +library_dirs_list = [] | ||
24 | +libraries_list = [] | ||
25 | |||
26 | # set to true (1), if you also want BLAS optimized matrixmultiply/dot/innerproduct | ||
27 | -use_dotblas = 1 | ||
28 | -include_dirs = ['/usr/include/atlas'] | ||
29 | +use_dotblas = 0 | ||
30 | +include_dirs = [] | ||
31 | # You may need to set this to find cblas.h | ||
32 | # e.g. on UNIX using ATLAS this should be ['/usr/include/atlas'] | ||
33 | extra_link_args = [] | ||
diff --git a/meta-oe/recipes-devtools/python/python-numeric_24.2.bb b/meta-oe/recipes-devtools/python/python-numeric_24.2.bb new file mode 100644 index 000000000..436718f46 --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-numeric_24.2.bb | |||
@@ -0,0 +1,15 @@ | |||
1 | DESCRIPTION = "A sophisticated Numeric Processing Package for Python" | ||
2 | SECTION = "devel/python" | ||
3 | PRIORITY = "optional" | ||
4 | LICENSE = "PSF & LLNL" | ||
5 | LIC_FILES_CHKSUM = "file://Legal.htm;md5=e3ce75dedd4043918d15979ae43e312e" | ||
6 | |||
7 | PR = "ml1" | ||
8 | |||
9 | SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/Numeric-${PV}.tar.gz" | ||
10 | S = "${WORKDIR}/Numeric-${PV}" | ||
11 | |||
12 | inherit distutils | ||
13 | |||
14 | SRC_URI[md5sum] = "2ae672656e06716a149acb048cca3093" | ||
15 | SRC_URI[sha256sum] = "5f72e729eb6ff57442f2a38bfc9931738b59e5077928e2e70d22b4610ff15258" | ||
diff --git a/meta-oe/recipes-devtools/python/python-pexpect_2.3.bb b/meta-oe/recipes-devtools/python/python-pexpect_2.3.bb new file mode 100644 index 000000000..8111ba3f0 --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-pexpect_2.3.bb | |||
@@ -0,0 +1,24 @@ | |||
1 | DESCRIPTION = "A Pure Python Expect like Module for Python" | ||
2 | SECTION = "devel/python" | ||
3 | PRIORITY = "optional" | ||
4 | LICENSE = "PSF" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=04a2bf11b85ce49d4a8c0c413fd34404" | ||
6 | SRCNAME = "pexpect" | ||
7 | PR = "ml1" | ||
8 | |||
9 | SRC_URI = "${SOURCEFORGE_MIRROR}/${SRCNAME}/${SRCNAME}-${PV}.tar.gz" | ||
10 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
11 | |||
12 | inherit distutils | ||
13 | |||
14 | RDEPENDS_${PN} = "\ | ||
15 | python-core \ | ||
16 | python-io \ | ||
17 | python-terminal \ | ||
18 | python-resource \ | ||
19 | python-fcntl \ | ||
20 | " | ||
21 | |||
22 | |||
23 | SRC_URI[md5sum] = "bf107cf54e67bc6dec5bea1f3e6a65c3" | ||
24 | SRC_URI[sha256sum] = "d315e7f3a8544fd85034d7e17fd7c5854e8f0828f5791f83cf313f8fa5740b75" | ||
diff --git a/meta-oe/recipes-devtools/python/python-phoneutils_git.bb b/meta-oe/recipes-devtools/python/python-phoneutils_git.bb new file mode 100644 index 000000000..b46a772a6 --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-phoneutils_git.bb | |||
@@ -0,0 +1,15 @@ | |||
1 | DESCRIPTION = "Python Bindings for libphone-utils" | ||
2 | SECTION = "devel/python" | ||
3 | DEPENDS = "libphone-utils python-cython-native python-pyrex-native" | ||
4 | RDEPENDS_${PN} = "libphone-utils" | ||
5 | LICENSE = "LGPLv2.1+" | ||
6 | LIC_FILES_CHKSUM = "file://phoneutils/c_phoneutils.pyx;endline=18;md5=ca321e4ec3a30a44469b23ebca782665" | ||
7 | |||
8 | SRCREV = "8a7c719e0c3f1f8c10f77f17422da02d7177f0dd" | ||
9 | PV = "0.0.2+gitr${SRCPV}" | ||
10 | PR = "r3" | ||
11 | |||
12 | SRC_URI = "git://git.shr-project.org/repo/libphone-utils.git;protocol=http;branch=master" | ||
13 | S = "${WORKDIR}/git/src/python" | ||
14 | |||
15 | inherit setuptools | ||
diff --git a/meta-oe/recipes-devtools/python/python-pyalsaaudio_0.4.bb b/meta-oe/recipes-devtools/python/python-pyalsaaudio_0.4.bb new file mode 100644 index 000000000..5a6dd5496 --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-pyalsaaudio_0.4.bb | |||
@@ -0,0 +1,16 @@ | |||
1 | DESCRIPTION = "Support for the Linux 2.6.x ALSA Sound System" | ||
2 | SECTION = "devel/python" | ||
3 | DEPENDS = "alsa-lib" | ||
4 | PRIORITY = "optional" | ||
5 | LICENSE = "PSF" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1a3b161aa0fcec32a0c8907a2219ad9d" | ||
7 | SRCNAME = "pyalsaaudio" | ||
8 | PR = "ml0" | ||
9 | |||
10 | SRC_URI = "${SOURCEFORGE_MIRROR}/pyalsaaudio/${SRCNAME}-${PV}.tar.gz" | ||
11 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
12 | |||
13 | inherit distutils | ||
14 | |||
15 | SRC_URI[md5sum] = "b312c28efba7db0494836a79f0a49898" | ||
16 | SRC_URI[sha256sum] = "07148ce16024724b17cc24c51d0f4fb78af214b09b7dc8dcb7b06e5647f4c582" | ||
diff --git a/meta-oe/recipes-devtools/python/python-pyserial_2.4.bb b/meta-oe/recipes-devtools/python/python-pyserial_2.4.bb new file mode 100644 index 000000000..cc138d196 --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-pyserial_2.4.bb | |||
@@ -0,0 +1,23 @@ | |||
1 | DESCRIPTION = "Serial Port Support for Python" | ||
2 | SECTION = "devel/python" | ||
3 | PRIORITY = "optional" | ||
4 | LICENSE = "PSF" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=7424386ffe323e815ee62ee9ad591dd8" | ||
6 | SRCNAME = "pyserial" | ||
7 | PR = "ml2" | ||
8 | |||
9 | SRC_URI = "${SOURCEFORGE_MIRROR}/${SRCNAME}/${SRCNAME}-${PV}.tar.gz" | ||
10 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
11 | |||
12 | inherit setuptools | ||
13 | |||
14 | # FIXME might stop packaging serialwin32 and serialjava files | ||
15 | |||
16 | RDEPENDS_${PN} = "\ | ||
17 | python-fcntl \ | ||
18 | python-io \ | ||
19 | python-stringold \ | ||
20 | " | ||
21 | |||
22 | SRC_URI[md5sum] = "eec19df59fd75ba5a136992897f8e468" | ||
23 | SRC_URI[sha256sum] = "6b6a9e3d2fd5978c92c843e0109918a4bcac481eecae316254481c0e0f7e73c8" | ||
diff --git a/meta-oe/recipes-devtools/python/python-pyyaml/setup.py b/meta-oe/recipes-devtools/python/python-pyyaml/setup.py new file mode 100644 index 000000000..fb6498341 --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-pyyaml/setup.py | |||
@@ -0,0 +1,64 @@ | |||
1 | NAME = 'PyYAML' | ||
2 | VERSION = '3.06' | ||
3 | DESCRIPTION = "YAML parser and emitter for Python" | ||
4 | LONG_DESCRIPTION = """\ | ||
5 | YAML is a data serialization format designed for human readability and | ||
6 | interaction with scripting languages. PyYAML is a YAML parser and | ||
7 | emitter for Python. | ||
8 | |||
9 | PyYAML features a complete YAML 1.1 parser, Unicode support, pickle | ||
10 | support, capable extension API, and sensible error messages. PyYAML | ||
11 | supports standard YAML tags and provides Python-specific tags that allow | ||
12 | to represent an arbitrary Python object. | ||
13 | |||
14 | PyYAML is applicable for a broad range of tasks from complex | ||
15 | configuration files to object serialization and persistance.""" | ||
16 | AUTHOR = "Kirill Simonov" | ||
17 | AUTHOR_EMAIL = 'xi@resolvent.net' | ||
18 | LICENSE = "MIT" | ||
19 | PLATFORMS = "Any" | ||
20 | URL = "http://pyyaml.org/wiki/PyYAML" | ||
21 | DOWNLOAD_URL = "http://pyyaml.org/download/pyyaml/%s-%s.tar.gz" % (NAME, VERSION) | ||
22 | CLASSIFIERS = [ | ||
23 | "Development Status :: 5 - Production/Stable", | ||
24 | "Intended Audience :: Developers", | ||
25 | "License :: OSI Approved :: MIT License", | ||
26 | "Operating System :: OS Independent", | ||
27 | "Programming Language :: Python", | ||
28 | "Topic :: Software Development :: Libraries :: Python Modules", | ||
29 | "Topic :: Text Processing :: Markup", | ||
30 | ] | ||
31 | |||
32 | from distutils.core import setup | ||
33 | from distutils.extension import Extension | ||
34 | from Cython.Distutils import build_ext | ||
35 | |||
36 | import sys, os.path | ||
37 | |||
38 | |||
39 | if __name__ == '__main__': | ||
40 | |||
41 | setup( | ||
42 | name=NAME, | ||
43 | version=VERSION, | ||
44 | description=DESCRIPTION, | ||
45 | long_description=LONG_DESCRIPTION, | ||
46 | author=AUTHOR, | ||
47 | author_email=AUTHOR_EMAIL, | ||
48 | license=LICENSE, | ||
49 | platforms=PLATFORMS, | ||
50 | url=URL, | ||
51 | download_url=DOWNLOAD_URL, | ||
52 | classifiers=CLASSIFIERS, | ||
53 | |||
54 | package_dir={'': 'lib'}, | ||
55 | packages=['yaml'], | ||
56 | |||
57 | ext_modules = [ | ||
58 | Extension( "_yaml", ["ext/_yaml.pyx"], libraries = ["yaml"] ) | ||
59 | ], | ||
60 | |||
61 | cmdclass={ | ||
62 | 'build_ext': build_ext, | ||
63 | }, | ||
64 | ) | ||
diff --git a/meta-oe/recipes-devtools/python/python-pyyaml_svn.bb b/meta-oe/recipes-devtools/python/python-pyyaml_svn.bb new file mode 100644 index 000000000..965b1cc11 --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-pyyaml_svn.bb | |||
@@ -0,0 +1,22 @@ | |||
1 | DESCRIPTION = "Python support for YAML" | ||
2 | HOMEPAGE = "http://www.pyyaml.org" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=6015f088759b10e0bc2bf64898d4ae17" | ||
6 | DEPENDS = "libyaml python-cython-native" | ||
7 | SRCREV = "344" | ||
8 | PV = "3.08+svnr${SRCPV}" | ||
9 | PR = "ml0" | ||
10 | |||
11 | SRC_URI = "\ | ||
12 | svn://svn.pyyaml.org/pyyaml;module=trunk;proto=http \ | ||
13 | file://setup.py \ | ||
14 | " | ||
15 | S = "${WORKDIR}/trunk" | ||
16 | |||
17 | inherit distutils | ||
18 | |||
19 | do_configure_prepend() { | ||
20 | # upstream setup.py overcomplicated, use ours | ||
21 | install -m 0644 ${WORKDIR}/setup.py ${S} | ||
22 | } | ||
diff --git a/meta-oe/recipes-devtools/python/python-vobject_0.8.1c.bb b/meta-oe/recipes-devtools/python/python-vobject_0.8.1c.bb new file mode 100644 index 000000000..6b7e7a481 --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-vobject_0.8.1c.bb | |||
@@ -0,0 +1,17 @@ | |||
1 | DESCRIPTION = "Python package for parsing and generating vCard and vCalendar files" | ||
2 | SECTION = "devel/python" | ||
3 | PRIORITY = "optional" | ||
4 | LICENSE = "Apache License V2.0" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57" | ||
6 | HOMEPAGE = "http://vobject.skyhouseconsulting.com/" | ||
7 | SRCNAME = "vobject" | ||
8 | RDEPENDS_${PN} = "python python-dateutil" | ||
9 | PR = "r2" | ||
10 | |||
11 | SRC_URI = "http://vobject.skyhouseconsulting.com/${SRCNAME}-${PV}.tar.gz" | ||
12 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
13 | |||
14 | inherit setuptools | ||
15 | |||
16 | SRC_URI[md5sum] = "c9686dd74d39fdae140890d9c694c076" | ||
17 | SRC_URI[sha256sum] = "594113117f2017ed837c8f3ce727616f9053baa5a5463a7420c8249b8fc556f5" | ||