diff options
author | Philip Balister <philip@balister.org> | 2014-12-18 13:40:44 -0500 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-12-19 20:13:11 +0100 |
commit | afc100a940b96628d9b99cefda65463a65b84f28 (patch) | |
tree | 47a0a8578361501b60837c41ba60abc07399cf1f /meta-oe/recipes-devtools/python | |
parent | 67c5f319b18a3728776dc1b8bb580d79164bdbd3 (diff) | |
download | meta-openembedded-afc100a940b96628d9b99cefda65463a65b84f28.tar.gz |
sip: Update to 4.14.2.
The sip configure.py script now has some support for cross compiling. This
allowed simplication of the existing OpenEmbedded sip support. The sip
recipe now produces support for builds via sip-native and target runtime
via sip.
This has been build and runtime tested on the zedboard and ettus-e300.
Signed-off-by: Philip Balister <philip@balister.org>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/python')
-rw-r--r-- | meta-oe/recipes-devtools/python/python-sip_4.14.2.bb | 46 |
1 files changed, 0 insertions, 46 deletions
diff --git a/meta-oe/recipes-devtools/python/python-sip_4.14.2.bb b/meta-oe/recipes-devtools/python/python-sip_4.14.2.bb deleted file mode 100644 index acabc97210..0000000000 --- a/meta-oe/recipes-devtools/python/python-sip_4.14.2.bb +++ /dev/null | |||
@@ -1,46 +0,0 @@ | |||
1 | SUMMARY = "Runtime helper for sip-generated python wrapper libraries" | ||
2 | SECTION = "devel/python" | ||
3 | HOMEPAGE = "http://www.riverbankcomputing.co.uk/sip" | ||
4 | AUTHOR = "Phil Thompson" | ||
5 | LICENSE = "GPLv2+" | ||
6 | LIC_FILES_CHKSUM = "file://siplib.sbf.in;endline=15;md5=3d462bd8cb43db3e4be998fe155ae9cf" | ||
7 | DEPENDS = "python" | ||
8 | RDEPENDS_${PN} = "python-core" | ||
9 | |||
10 | # riverbankcomputing is upstream, but keeps only latest version, sf usually have few older | ||
11 | #SRC_URI = "http://www.riverbankcomputing.com/static/Downloads/sip4/sip-${PV}.tar.gz" | ||
12 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/pyqt/sip/sip-${PV}/sip-${PV}.tar.gz" | ||
13 | SRC_URI[md5sum] = "b93442e745b3be2fad89de0686a76ce9" | ||
14 | SRC_URI[sha256sum] = "1a9d3bf26c821f369c175f8e68946b79bc994da4f96e8f5ecff06e6ee7ac0528" | ||
15 | |||
16 | S = "${WORKDIR}/sip-${PV}/siplib" | ||
17 | |||
18 | inherit qt4x11 distutils-base | ||
19 | |||
20 | EXTRA_QMAKEVARS_POST += " TEMPLATE=lib \ | ||
21 | CONFIG=console \ | ||
22 | DESTDIR= \ | ||
23 | VERSION=1.0.0 \ | ||
24 | TARGET=sip \ | ||
25 | DEFINES=SIP_QT_SUPPORT \ | ||
26 | INCLUDEPATH+=. \ | ||
27 | INCLUDEPATH+=${STAGING_INCDIR}/${PYTHON_DIR} \ | ||
28 | INCLUDEPATH+=${STAGING_INCDIR}" | ||
29 | |||
30 | |||
31 | do_configure_prepend() { | ||
32 | cat siplib.sbf.in | sed s,target,TARGET, | sed s,sources,SOURCES, | sed s,headers,HEADERS, | sed s,@CFG_MODULE_BASENAME@,sip, > siplib.pro | ||
33 | cat siplib.c.in | sed s,@CFG_MODULE_BASENAME@,sip, > siplib.c | ||
34 | cat sip.h.in | sed -e s,@CFG_MODULE_NAME@,sip,g > sip.h | ||
35 | } | ||
36 | |||
37 | do_install() { | ||
38 | install -d ${D}${libdir}/${PYTHON_DIR}/site-packages/ | ||
39 | install -m 0755 libsip.so.1.0.0 ${D}${libdir}/${PYTHON_DIR}/site-packages/sip.so | ||
40 | # sipconfig.py sipdistutils.py | ||
41 | install -d ${D}${includedir} | ||
42 | install -m 0644 ../siplib/sip.h ${D}${includedir}/sip.h | ||
43 | } | ||
44 | |||
45 | FILES_${PN} = "${libdir}/${PYTHON_DIR}/site-packages/sip.so" | ||
46 | |||