summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/python
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-08-01 14:19:43 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2012-10-02 19:29:38 +0200
commitab6cd2bb734ba738bdbacfbeb8558e89abf29748 (patch)
tree2e7bc1395ad306bbd31d61b00bdf63becc37a4e9 /meta-oe/recipes-devtools/python
parenta76f29b40651c9c87b5d7d1a2f450a5b013c1bcf (diff)
downloadmeta-openembedded-ab6cd2bb734ba738bdbacfbeb8558e89abf29748.tar.gz
python-pyqt: upgrade to 4.9.5
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/python')
-rw-r--r--meta-oe/recipes-devtools/python/python-pyqt-4.8.4/assistantclient-fix.patch13
-rw-r--r--meta-oe/recipes-devtools/python/python-pyqt-4.8.4/fix_qthelp_ftbfs.diff15
-rw-r--r--meta-oe/recipes-devtools/python/python-pyqt-4.8.4/fix_the_QAssitant_ftbfs.diff29
-rw-r--r--meta-oe/recipes-devtools/python/python-pyqt-4.8.4/pyqt-generated.patch24
-rw-r--r--meta-oe/recipes-devtools/python/python-pyqt-4.9.5/pyqt-generated.patch12
-rw-r--r--meta-oe/recipes-devtools/python/python-pyqt-4.9.5/qreal_float_support.diff (renamed from meta-oe/recipes-devtools/python/python-pyqt-4.8.4/qreal_float_support.diff)0
-rw-r--r--meta-oe/recipes-devtools/python/python-pyqt_4.9.5.bb (renamed from meta-oe/recipes-devtools/python/python-pyqt_4.8.4.bb)18
7 files changed, 18 insertions, 93 deletions
diff --git a/meta-oe/recipes-devtools/python/python-pyqt-4.8.4/assistantclient-fix.patch b/meta-oe/recipes-devtools/python/python-pyqt-4.8.4/assistantclient-fix.patch
deleted file mode 100644
index 15f83d23b..000000000
--- a/meta-oe/recipes-devtools/python/python-pyqt-4.8.4/assistantclient-fix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
1Index: PyQt-x11-gpl-4.8.3/sip/QtAssistant/qassistantclient.sip
2===================================================================
3--- PyQt-x11-gpl-4.8.3.orig/sip/QtAssistant/qassistantclient.sip
4+++ PyQt-x11-gpl-4.8.3/sip/QtAssistant/qassistantclient.sip
5@@ -33,7 +33,7 @@
6 class QAssistantClient : QObject
7 {
8 %TypeHeaderCode
9-#include <qassistantclient.h>
10+#include <QtAssistant/qassistantclient.h>
11 %End
12
13 %ConvertToSubClassCode
diff --git a/meta-oe/recipes-devtools/python/python-pyqt-4.8.4/fix_qthelp_ftbfs.diff b/meta-oe/recipes-devtools/python/python-pyqt-4.8.4/fix_qthelp_ftbfs.diff
deleted file mode 100644
index e7a68829a..000000000
--- a/meta-oe/recipes-devtools/python/python-pyqt-4.8.4/fix_qthelp_ftbfs.diff
+++ /dev/null
@@ -1,15 +0,0 @@
1Description: Fix QtHelp FTBFS with ld --no-add-needed.
2Author: Felix Geyer <debfx-pkg@fobos.de>
3
4--- python-qt4-4.8.1.orig/configure.py
5+++ python-qt4-4.8.1/configure.py
6@@ -364,7 +364,8 @@ class ConfigurePyQt4:
7 pyqt_modules.append("QtCore")
8
9 check_module("QtGui", "qwidget.h", "new QWidget()")
10- check_module("QtHelp", "qhelpengine.h", "new QHelpEngine(\"foo\")")
11+ check_module("QtHelp", "qhelpengine.h", "new QHelpEngine(\"foo\")",
12+ extra_libs=["QtCore"])
13 check_module("QtMultimedia", "QAudioDeviceInfo",
14 "new QAudioDeviceInfo()")
15 check_module("QtNetwork", "qhostaddress.h", "new QHostAddress()")
diff --git a/meta-oe/recipes-devtools/python/python-pyqt-4.8.4/fix_the_QAssitant_ftbfs.diff b/meta-oe/recipes-devtools/python/python-pyqt-4.8.4/fix_the_QAssitant_ftbfs.diff
deleted file mode 100644
index 96e306247..000000000
--- a/meta-oe/recipes-devtools/python/python-pyqt-4.8.4/fix_the_QAssitant_ftbfs.diff
+++ /dev/null
@@ -1,29 +0,0 @@
1From aa85ab2be6be7cb3c4df68139a8271fc4c8c11c8 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Picca=20Fr=C3=A9d=C3=A9ric-Emmanuel?= <picca@synchrotron-soleil.fr>
3Date: Tue, 1 Mar 2011 21:49:23 +0100
4Subject: [PATCH] * fix the QAssitant ftbfs
5
6---
7 configure.py | 4 ++--
8 1 files changed, 2 insertions(+), 2 deletions(-)
9
10diff --git a/configure.py b/configure.py
11index 7ed9582..185ec9f 100644
12--- a/configure.py
13+++ b/configure.py
14@@ -354,10 +354,10 @@ class ConfigurePyQt4:
15
16 if opts.mwg_ssl_dir:
17 ass_lib_dirs = [os.path.join(opts.mwg_ssl_dir, "lib")]
18- ass_libs = ["ssleay32", "libeay32"]
19+ ass_libs = ["ssleay32", "libeay32", "QtCore"]
20 else:
21 ass_lib_dirs = None
22- ass_libs = None
23+ ass_libs = ["QtCore"]
24
25 # Note that the order in which we check is important for the
26 # consolidated module - a module's dependencies must be checked first.
27--
281.7.4.1
29
diff --git a/meta-oe/recipes-devtools/python/python-pyqt-4.8.4/pyqt-generated.patch b/meta-oe/recipes-devtools/python/python-pyqt-4.8.4/pyqt-generated.patch
deleted file mode 100644
index 0af554953..000000000
--- a/meta-oe/recipes-devtools/python/python-pyqt-4.8.4/pyqt-generated.patch
+++ /dev/null
@@ -1,24 +0,0 @@
1diff -uNr PyQt-x11-gpl-4.8.4.orig/QtGui/sipQtGuiQSystemTrayIcon.cpp PyQt-x11-gpl-4.8.4/QtGui/sipQtGuiQSystemTrayIcon.cpp
2--- PyQt-x11-gpl-4.8.4.orig/QtGui/sipQtGuiQSystemTrayIcon.cpp 2012-08-01 16:37:34.000000000 +0200
3+++ PyQt-x11-gpl-4.8.4/QtGui/sipQtGuiQSystemTrayIcon.cpp 2012-08-01 17:05:45.000000000 +0200
4@@ -957,8 +957,6 @@
5 qtgui_untrack(sipCpp);
6 #line 959 "QtGui/sipQtGuiQSystemTrayIcon.cpp"
7
8- QSystemTrayIcon *sipCpp = reinterpret_cast<QSystemTrayIcon *>(sipCppV);
9-
10 if (QThread::currentThread() == sipCpp->thread())
11 delete sipCpp;
12 else
13diff -uNr PyQt-x11-gpl-4.8.4.orig/QtGui/sipQtGuiQGraphicsScene.cpp PyQt-x11-gpl-4.8.4/QtGui/sipQtGuiQGraphicsScene.cpp
14--- PyQt-x11-gpl-4.8.4.orig/QtGui/sipQtGuiQGraphicsScene.cpp 2012-08-01 16:37:35.000000000 +0200
15+++ PyQt-x11-gpl-4.8.4/QtGui/sipQtGuiQGraphicsScene.cpp 2012-08-01 17:26:58.000000000 +0200
16@@ -4016,8 +4016,6 @@
17 qtgui_untrack(sipCpp);
18 #line 4018 "QtGui/sipQtGuiQGraphicsScene.cpp"
19
20- QGraphicsScene *sipCpp = reinterpret_cast<QGraphicsScene *>(sipCppV);
21-
22 if (QThread::currentThread() == sipCpp->thread())
23 delete sipCpp;
24 else
diff --git a/meta-oe/recipes-devtools/python/python-pyqt-4.9.5/pyqt-generated.patch b/meta-oe/recipes-devtools/python/python-pyqt-4.9.5/pyqt-generated.patch
new file mode 100644
index 000000000..6579aa400
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-pyqt-4.9.5/pyqt-generated.patch
@@ -0,0 +1,12 @@
1diff -uNr PyQt-x11-gpl-4.9.5.orig/QtGui/sipQtGuiQSystemTrayIcon.cpp PyQt-x11-gpl-4.9.5/QtGui/sipQtGuiQSystemTrayIcon.cpp
2--- PyQt-x11-gpl-4.9.5.orig/QtGui/sipQtGuiQSystemTrayIcon.cpp 2012-10-01 16:48:16.496700577 +0200
3+++ PyQt-x11-gpl-4.9.5/QtGui/sipQtGuiQSystemTrayIcon.cpp 2012-10-01 21:40:43.063130099 +0200
4@@ -993,8 +993,6 @@
5 qtgui_untrack(sipCpp);
6 #line 995 "QtGui/sipQtGuiQSystemTrayIcon.cpp"
7
8- QSystemTrayIcon *sipCpp = reinterpret_cast<QSystemTrayIcon *>(sipCppV);
9-
10 if (QThread::currentThread() == sipCpp->thread())
11 delete sipCpp;
12 else
diff --git a/meta-oe/recipes-devtools/python/python-pyqt-4.8.4/qreal_float_support.diff b/meta-oe/recipes-devtools/python/python-pyqt-4.9.5/qreal_float_support.diff
index abdf70fab..abdf70fab 100644
--- a/meta-oe/recipes-devtools/python/python-pyqt-4.8.4/qreal_float_support.diff
+++ b/meta-oe/recipes-devtools/python/python-pyqt-4.9.5/qreal_float_support.diff
diff --git a/meta-oe/recipes-devtools/python/python-pyqt_4.8.4.bb b/meta-oe/recipes-devtools/python/python-pyqt_4.9.5.bb
index 8bae09eef..9feab4df8 100644
--- a/meta-oe/recipes-devtools/python/python-pyqt_4.8.4.bb
+++ b/meta-oe/recipes-devtools/python/python-pyqt_4.9.5.bb
@@ -7,27 +7,21 @@ LIC_FILES_CHKSUM = "\
7 file://GPL_EXCEPTION.TXT;md5=b73b0be471db679533dc94781c14af58 \ 7 file://GPL_EXCEPTION.TXT;md5=b73b0be471db679533dc94781c14af58 \
8 file://GPL_EXCEPTION_ADDENDUM.TXT;md5=c1e04ec2aa0911061005a801abf81e40 \ 8 file://GPL_EXCEPTION_ADDENDUM.TXT;md5=c1e04ec2aa0911061005a801abf81e40 \
9 file://OPENSOURCE-NOTICE.TXT;md5=6ad9123620cc04a22c394753ad4767d7 \ 9 file://OPENSOURCE-NOTICE.TXT;md5=6ad9123620cc04a22c394753ad4767d7 \
10 file://LICENSE-MERGED-GPL2-GPL3;md5=53ced8933428255115039368cdca0aef \ 10 file://LICENSE.GPL2;md5=276c6b9cad5f85a3af3534299825feff \
11 file://LICENSE.GPL2;md5=59bccd9d4dcaae9e668798337b91a022 \ 11 file://LICENSE.GPL3;md5=eda942b9c6ba7eb0f40fee79e94950d5 \
12 file://LICENSE.GPL3;md5=da83bb3624af9ff4808aa9ffc49fc582 \
13" 12"
14 13
15DEPENDS = "sip-native python-sip" 14DEPENDS = "sip-native python-sip"
16RDEPENDS_${PN} = "python-core" 15RDEPENDS_${PN} = "python-core"
17SRCNAME = "pyqt"
18 16
19PYQT_OE_VERSION = "Qt_4_7_1" 17PYQT_OE_VERSION = "Qt_4_8_3"
20 18
21SRC_URI = "\ 19SRC_URI = "\
22 http://www.riverbankcomputing.co.uk/static/Downloads/PyQt4/PyQt-x11-gpl-${PV}.tar.gz \ 20 ${SOURCEFORGE_MIRROR}/pyqt/PyQt-x11-gpl-${PV}.tar.gz \
23 \
24 file://fix_qthelp_ftbfs.diff \
25 file://fix_the_QAssitant_ftbfs.diff \
26 file://assistantclient-fix.patch \
27 file://pyqt-generated.patch;apply=no \ 21 file://pyqt-generated.patch;apply=no \
28" 22"
29SRC_URI[md5sum] = "97c5dc1042feb5b3fe20baabad055af1" 23SRC_URI[md5sum] = "e4cdd6619c63655f7510efb4df8462fb"
30SRC_URI[sha256sum] = "fcfa3ecc0b4fad6d93227751b36a6f81ea104ee19dd26905f52de59f060b3e98" 24SRC_URI[sha256sum] = "75ff0a3a088ae22c4d6e8adb242f7e593104af93933cbdd9900bc7b06f46191e"
31S = "${WORKDIR}/PyQt-x11-gpl-${PV}" 25S = "${WORKDIR}/PyQt-x11-gpl-${PV}"
32 26
33# arm and mips machines need some extra patches 27# arm and mips machines need some extra patches