summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/python
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-01-09 15:30:18 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-01-13 11:39:40 +0100
commit9ec0d24a5f1b6d769f706f1b7a585eee9c119041 (patch)
treebf210703cbc5a34e9ef89e7ac4b92219a9a85356 /meta-oe/recipes-devtools/python
parent73457a7f36c1edcbb97d58e835f36bd33d74fd9a (diff)
downloadmeta-openembedded-9ec0d24a5f1b6d769f706f1b7a585eee9c119041.tar.gz
python-mako: use setuptools.bbclass, fixing install paths
An argument was missed in the manual setuptools configuration which meant that the tool was installed into /data/poky-master/tmp/sysroots/x86_64-linux/usr/bin/mako-render. Using the setuptools class reduces duplication and puts the tool into /usr/bin where it belongs. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/python')
-rw-r--r--meta-oe/recipes-devtools/python/python-mako_0.7.2.bb8
1 files changed, 2 insertions, 6 deletions
diff --git a/meta-oe/recipes-devtools/python/python-mako_0.7.2.bb b/meta-oe/recipes-devtools/python/python-mako_0.7.2.bb
index d2222d61d..6f71561bd 100644
--- a/meta-oe/recipes-devtools/python/python-mako_0.7.2.bb
+++ b/meta-oe/recipes-devtools/python/python-mako_0.7.2.bb
@@ -3,7 +3,7 @@ SECTION = "devel/python"
3LICENSE = "MIT" 3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=da8dd26ed9751ee0cfdf9df1a16bbb54" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=da8dd26ed9751ee0cfdf9df1a16bbb54"
5 5
6PR = "r1" 6PR = "r2"
7 7
8SRC_URI = "http://www.makotemplates.org/downloads/Mako-${PV}.tar.gz" 8SRC_URI = "http://www.makotemplates.org/downloads/Mako-${PV}.tar.gz"
9SRC_URI[md5sum] = "e3c0a677aa4216da9e89ef8fa76cbafb" 9SRC_URI[md5sum] = "e3c0a677aa4216da9e89ef8fa76cbafb"
@@ -11,11 +11,7 @@ SRC_URI[sha256sum] = "fe8698e845035586bd711a6748e4e40a208a58de276b91380261647004
11 11
12S = "${WORKDIR}/Mako-${PV}" 12S = "${WORKDIR}/Mako-${PV}"
13 13
14inherit distutils 14inherit setuptools
15
16DISTUTILS_INSTALL_ARGS = "--single-version-externally-managed \
17 --root=${D} \
18 --install-lib=${PYTHON_SITEPACKAGES_DIR}"
19 15
20RDEPENDS_${PN} = "python-threading \ 16RDEPENDS_${PN} = "python-threading \
21 python-netclient \ 17 python-netclient \