diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2011-03-17 21:41:22 +0100 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-03-17 21:41:22 +0100 |
commit | c58cc7d3796dcee6e93885c835ed04cb566abeb2 (patch) | |
tree | 3eea4d4ef6a4ef79e0f4e025d7012c1a5cc38835 /meta-oe/recipes-devtools/python/python-numpy/trycompile.diff | |
parent | eec6ab97f712e06eb52c9f7c99e19ffab3ce9d74 (diff) | |
download | meta-openembedded-c58cc7d3796dcee6e93885c835ed04cb566abeb2.tar.gz |
move layer into meta-oe in preparation for future splits
As per TSC decision
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-devtools/python/python-numpy/trycompile.diff')
-rw-r--r-- | meta-oe/recipes-devtools/python/python-numpy/trycompile.diff | 33 |
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-numpy/trycompile.diff b/meta-oe/recipes-devtools/python/python-numpy/trycompile.diff new file mode 100644 index 000000000..3ab3d72f2 --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-numpy/trycompile.diff | |||
@@ -0,0 +1,33 @@ | |||
1 | --- /tmp/setup.py 2008-09-01 10:37:44.000000000 +0200 | ||
2 | +++ numpy-1.1.1/numpy/core/setup.py 2008-09-01 10:38:20.373198000 +0200 | ||
3 | @@ -80,8 +80,7 @@ | ||
4 | raise SystemError,\ | ||
5 | "Non-existing %s. Perhaps you need to install"\ | ||
6 | " python-dev|python-devel." % (python_h) | ||
7 | - result = config_cmd.try_run(tc,include_dirs=[python_include], | ||
8 | - library_dirs = default_lib_dirs) | ||
9 | + result = config_cmd.try_compile(tc) | ||
10 | if not result: | ||
11 | raise SystemError,"Failed to test configuration. "\ | ||
12 | "See previous error messages for more information." | ||
13 | @@ -95,7 +94,7 @@ | ||
14 | if mathlib: | ||
15 | mathlibs_choices.insert(0,mathlib.split(',')) | ||
16 | for libs in mathlibs_choices: | ||
17 | - if config_cmd.try_run(tc,libraries=libs): | ||
18 | + if config_cmd.try_compile(tc): | ||
19 | mathlibs = libs | ||
20 | break | ||
21 | else: | ||
22 | @@ -180,10 +179,7 @@ | ||
23 | " python-dev|python-devel." % (python_h) | ||
24 | |||
25 | config.numpy_include_dirs | ||
26 | - result = config_cmd.try_run(testcode, | ||
27 | - include_dirs = [python_include] + \ | ||
28 | - config.numpy_include_dirs, | ||
29 | - library_dirs = default_lib_dirs) | ||
30 | + result = config_cmd.try_compile(testcode) | ||
31 | |||
32 | if not result: | ||
33 | raise SystemError,"Failed to generate numpy configuration. "\ | ||