summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/python/python-imaging_1.1.7.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-03-20 09:59:04 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-03-21 13:50:41 +0100
commitbea124794b17bd87d4b1a3a0df30a1f02869c7f0 (patch)
tree1d7fb700e6a123dcddea012cdb684a7a58c0ef63 /meta-oe/recipes-devtools/python/python-imaging_1.1.7.bb
parent0148de029c33ca496b51700ddf1fcd035a38fc77 (diff)
downloadmeta-openembedded-bea124794b17bd87d4b1a3a0df30a1f02869c7f0.tar.gz
python-imaging: remove
Fixes from this version have now been merged into OE-Core, so remove it here. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-devtools/python/python-imaging_1.1.7.bb')
-rw-r--r--meta-oe/recipes-devtools/python/python-imaging_1.1.7.bb41
1 files changed, 0 insertions, 41 deletions
diff --git a/meta-oe/recipes-devtools/python/python-imaging_1.1.7.bb b/meta-oe/recipes-devtools/python/python-imaging_1.1.7.bb
deleted file mode 100644
index c8dd8147c..000000000
--- a/meta-oe/recipes-devtools/python/python-imaging_1.1.7.bb
+++ /dev/null
@@ -1,41 +0,0 @@
1DESCRIPTION = "Python Imaging Library"
2SECTION = "devel/python"
3
4PR = "r1"
5
6LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://README;beginline=92;endline=117;md5=003338c482e1d2eb2e4d862897f3abbf"
8
9DEPENDS = "freetype jpeg tiff"
10SRCNAME = "Imaging"
11
12SRC_URI = "http://effbot.org/downloads/Imaging-${PV}.tar.gz \
13 file://0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch \
14"
15SRC_URI[md5sum] = "fc14a54e1ce02a0225be8854bfba478e"
16SRC_URI[sha256sum] = "895bc7c2498c8e1f9b99938f1a40dc86b3f149741f105cf7c7bd2e0725405211"
17
18S = "${WORKDIR}/${SRCNAME}-${PV}"
19
20inherit distutils
21
22do_compile() {
23 export STAGING_LIBDIR=${STAGING_LIBDIR}
24 export STAGING_INCDIR=${STAGING_INCDIR}
25 distutils_do_compile
26}
27
28do_install() {
29 export STAGING_LIBDIR=${STAGING_LIBDIR}
30 export STAGING_INCDIR=${STAGING_INCDIR}
31 distutils_do_install
32 install -d ${D}${datadir}/doc/${PN}/html/
33 install -m 0644 ${S}/README ${D}${datadir}/doc/${PN}/
34 install -m 0644 ${S}/Docs/* ${D}${datadir}/doc/${PN}/html/
35
36 # get rid of #!/usr/local/bin/python
37 sed -i -e 's:/usr/local/bin/:${bindir}/env :g' ${D}${bindir}/*
38
39}
40RDEPENDS_${PN} = "python-lang python-stringold"
41