summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/protobuf
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2018-07-19 14:13:00 +0800
committerKhem Raj <raj.khem@gmail.com>2018-07-26 20:10:07 -0700
commit2f5819d9c37387764a600d9dc8d22bee8a71f710 (patch)
tree55cb9f395fc659630885d305ffa1105095424f41 /meta-oe/recipes-devtools/protobuf
parentc031adb61d36ada4ac9afeadeaa64d43ffb76323 (diff)
downloadmeta-openembedded-2f5819d9c37387764a600d9dc8d22bee8a71f710.tar.gz
protobuf: upgrade 3.5.1 -> 3.6.0.1
License-Update: copyright year updated and clean some useless content Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/protobuf')
-rw-r--r--meta-oe/recipes-devtools/protobuf/protobuf/0001-protobuf-fix-configure-error.patch33
-rw-r--r--meta-oe/recipes-devtools/protobuf/protobuf_3.6.0.1.bb (renamed from meta-oe/recipes-devtools/protobuf/protobuf_3.5.1.bb)14
2 files changed, 43 insertions, 4 deletions
diff --git a/meta-oe/recipes-devtools/protobuf/protobuf/0001-protobuf-fix-configure-error.patch b/meta-oe/recipes-devtools/protobuf/protobuf/0001-protobuf-fix-configure-error.patch
new file mode 100644
index 000000000..a2f7a4b77
--- /dev/null
+++ b/meta-oe/recipes-devtools/protobuf/protobuf/0001-protobuf-fix-configure-error.patch
@@ -0,0 +1,33 @@
1From 52959e8e01e39139d18f752e97283e45b4b7a426 Mon Sep 17 00:00:00 2001
2From: Changqing Li <changqing.li@windriver.com>
3Date: Wed, 18 Jul 2018 17:52:34 +0800
4Subject: [PATCH] protobuf: fix configure error
5
6fix below error:
7gnu-configize: 'configure.ac' or 'configure.in' is required
8
9third_party/googletest is git submodule of protobuf. Above error
10caused by missing submodule googletest.
11
12Upstream-Status: Inappropriate [oe-specific]
13
14Signed-off-by: Changqing Li <changqing.li@windriver.com>
15---
16 configure.ac | 1 -
17 1 file changed, 1 deletion(-)
18
19diff --git a/configure.ac b/configure.ac
20index aec10cf..7fbe57d 100644
21--- a/configure.ac
22+++ b/configure.ac
23@@ -214,7 +214,6 @@ AX_CXX_COMPILE_STDCXX([11], [noext], [mandatory])
24 # too.
25 export CFLAGS
26 export CXXFLAGS
27-AC_CONFIG_SUBDIRS([third_party/googletest])
28
29 AC_CONFIG_FILES([Makefile src/Makefile benchmarks/Makefile conformance/Makefile protobuf.pc protobuf-lite.pc])
30 AC_OUTPUT
31--
322.7.4
33
diff --git a/meta-oe/recipes-devtools/protobuf/protobuf_3.5.1.bb b/meta-oe/recipes-devtools/protobuf/protobuf_3.6.0.1.bb
index 8cef391bd..58507442a 100644
--- a/meta-oe/recipes-devtools/protobuf/protobuf_3.5.1.bb
+++ b/meta-oe/recipes-devtools/protobuf/protobuf_3.6.0.1.bb
@@ -5,18 +5,19 @@ all of its internal RPC protocols and file formats."
5HOMEPAGE = "https://github.com/google/protobuf" 5HOMEPAGE = "https://github.com/google/protobuf"
6SECTION = "console/tools" 6SECTION = "console/tools"
7LICENSE = "BSD-3-Clause" 7LICENSE = "BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=35953c752efc9299b184f91bef540095" 8LIC_FILES_CHKSUM = "file://LICENSE;md5=37b5762e07f0af8c74ce80a8bda4266b"
9 9
10DEPENDS = "zlib" 10DEPENDS = "zlib"
11DEPENDS_append_class-target = " protobuf-native" 11DEPENDS_append_class-target = " protobuf-native"
12 12
13PV .= "+git${SRCPV}" 13PV .= "+git${SRCPV}"
14SRCREV = "106ffc04be1abf3ff3399f54ccf149815b287dd9"
15 14
16SRC_URI = "git://github.com/google/protobuf.git;branch=3.5.x \ 15SRCREV = "ce044817c7ba0aea27c3fd8e496635d94d20a755"
16
17SRC_URI = "git://github.com/google/protobuf.git;branch=3.6.x \
17 file://run-ptest \ 18 file://run-ptest \
19 file://0001-protobuf-fix-configure-error.patch \
18" 20"
19
20S = "${WORKDIR}/git" 21S = "${WORKDIR}/git"
21 22
22inherit autotools-brokensep pkgconfig ptest 23inherit autotools-brokensep pkgconfig ptest
@@ -82,3 +83,8 @@ RDEPENDS_${PN}-ptest = "bash python-protobuf"
82MIPS_INSTRUCTION_SET = "mips" 83MIPS_INSTRUCTION_SET = "mips"
83 84
84BBCLASSEXTEND = "native nativesdk" 85BBCLASSEXTEND = "native nativesdk"
86
87LDFLAGS_append_arm = " -latomic"
88LDFLAGS_append_mips = " -latomic"
89LDFLAGS_append_powerpc = " -latomic"
90LDFLAGS_append_mipsel = " -latomic"