diff options
author | Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org> | 2013-04-16 12:42:49 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-22 09:51:47 +0200 |
commit | f91950e3ad2e95bae2c859b7430ef38bfeef1e3c (patch) | |
tree | 586a9792986062054d13b0b0dfae7457d60ba3b4 /meta-oe/recipes-devtools/php | |
parent | 7c292ce28756824b1fa377d516aedd979fa41f19 (diff) | |
download | meta-openembedded-f91950e3ad2e95bae2c859b7430ef38bfeef1e3c.tar.gz |
php: update to 5.4.14
Build tested for AArch64 and x86.
Runtime tested on x86.
Signed-off-by: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/php')
-rw-r--r-- | meta-oe/recipes-devtools/php/php.inc | 4 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/php/php/phar-makefile.patch | 8 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/php/php/php-m4-divert.patch | 83 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/php/php/php_exec_native.patch | 26 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/php/php_5.4.14.bb (renamed from meta-oe/recipes-devtools/php/php_5.3.19.bb) | 5 |
5 files changed, 26 insertions, 100 deletions
diff --git a/meta-oe/recipes-devtools/php/php.inc b/meta-oe/recipes-devtools/php/php.inc index 176d4a1c5..225c3d72a 100644 --- a/meta-oe/recipes-devtools/php/php.inc +++ b/meta-oe/recipes-devtools/php/php.inc | |||
@@ -64,7 +64,9 @@ do_install_append_pn-php-native() { | |||
64 | # fixme | 64 | # fixme |
65 | do_install_append_pn-php() { | 65 | do_install_append_pn-php() { |
66 | install -d ${D}/${sysconfdir}/ | 66 | install -d ${D}/${sysconfdir}/ |
67 | mv ${D}/${STAGING_DIR_NATIVE}/${sysconfdir}/* ${D}/${sysconfdir}/ | 67 | if [ -d ${D}/${STAGING_DIR_NATIVE}/${sysconfdir} ];then |
68 | mv ${D}/${STAGING_DIR_NATIVE}/${sysconfdir}/* ${D}/${sysconfdir}/ | ||
69 | fi | ||
68 | rm -rf ${D}/${TMPDIR} | 70 | rm -rf ${D}/${TMPDIR} |
69 | rm -rf ${D}/.registry | 71 | rm -rf ${D}/.registry |
70 | rm -rf ${D}/.channels | 72 | rm -rf ${D}/.channels |
diff --git a/meta-oe/recipes-devtools/php/php/phar-makefile.patch b/meta-oe/recipes-devtools/php/php/phar-makefile.patch index 9d1dc7b9a..6fde25127 100644 --- a/meta-oe/recipes-devtools/php/php/phar-makefile.patch +++ b/meta-oe/recipes-devtools/php/php/phar-makefile.patch | |||
@@ -4,8 +4,8 @@ index fc93d1d..9a8cd65 100755 | |||
4 | +++ b/ext/phar/Makefile.frag | 4 | +++ b/ext/phar/Makefile.frag |
5 | @@ -6,19 +6,8 @@ pharcmd: $(builddir)/phar.php $(builddir)/phar.phar | 5 | @@ -6,19 +6,8 @@ pharcmd: $(builddir)/phar.php $(builddir)/phar.phar |
6 | 6 | ||
7 | PHP_PHARCMD_SETTINGS = -d 'open_basedir=' -d 'output_buffering=0' -d 'memory_limit=-1' -d phar.readonly=0 -d 'safe_mode=0' | 7 | PHP_PHARCMD_SETTINGS = -d 'open_basedir=' -d 'output_buffering=0' -d 'memory_limit=-1' -d phar.readonly=0 -d 'safe_mode=0' |
8 | PHP_PHARCMD_EXECUTABLE = ` \ | 8 | PHP_PHARCMD_EXECUTABLE = ` \ |
9 | - if test -x "$(top_builddir)/$(SAPI_CLI_PATH)"; then \ | 9 | - if test -x "$(top_builddir)/$(SAPI_CLI_PATH)"; then \ |
10 | - $(top_srcdir)/build/shtool echo -n -- "$(top_builddir)/$(SAPI_CLI_PATH) -n"; \ | 10 | - $(top_srcdir)/build/shtool echo -n -- "$(top_builddir)/$(SAPI_CLI_PATH) -n"; \ |
11 | - if test "x$(PHP_MODULES)" != "x"; then \ | 11 | - if test "x$(PHP_MODULES)" != "x"; then \ |
@@ -21,6 +21,6 @@ index fc93d1d..9a8cd65 100755 | |||
21 | - fi;` | 21 | - fi;` |
22 | + $(top_srcdir)/build/shtool echo -n -- "$(PHP_EXECUTABLE)"; ` | 22 | + $(top_srcdir)/build/shtool echo -n -- "$(PHP_EXECUTABLE)"; ` |
23 | + | 23 | + |
24 | PHP_PHARCMD_BANG = `$(top_srcdir)/build/shtool echo -n -- "$(INSTALL_ROOT)$(bindir)/$(program_prefix)php$(program_suffix)$(EXEEXT)";` | 24 | PHP_PHARCMD_BANG = `$(top_srcdir)/build/shtool echo -n -- "$(INSTALL_ROOT)$(bindir)/$(program_prefix)php$(program_suffix)$(EXEEXT)";` |
25 | 25 | ||
26 | $(builddir)/phar/phar.inc: $(srcdir)/phar/phar.inc | 26 | $(builddir)/phar/phar.inc: $(srcdir)/phar/phar.inc |
diff --git a/meta-oe/recipes-devtools/php/php/php-m4-divert.patch b/meta-oe/recipes-devtools/php/php/php-m4-divert.patch deleted file mode 100644 index dfc7b643e..000000000 --- a/meta-oe/recipes-devtools/php/php/php-m4-divert.patch +++ /dev/null | |||
@@ -1,83 +0,0 @@ | |||
1 | Patch taken from | ||
2 | |||
3 | http://cvs.pld-linux.org/cgi-bin/cvsweb/packages/php/php-m4-divert.patch?rev=1.1 | ||
4 | |||
5 | diff -ur php-5.2.10.org/configure.in php-5.2.10/configure.in | ||
6 | --- php-5.2.10.org/configure.in 2009-06-17 14:22:41.000000000 +0200 | ||
7 | +++ php-5.2.10/configure.in 2009-08-18 12:16:25.317640253 +0200 | ||
8 | @@ -1,7 +1,7 @@ | ||
9 | ## $Id: configure.in,v 1.579.2.52.2.139 2009/06/17 12:22:41 iliaa Exp $ -*- autoconf -*- | ||
10 | dnl ## Process this file with autoconf to produce a configure script. | ||
11 | |||
12 | -divert(1) | ||
13 | +divert(1001) | ||
14 | |||
15 | dnl ## Diversion 1 is the autoconf + automake setup phase. We also | ||
16 | dnl ## set the PHP version, deal with platform-specific compile | ||
17 | @@ -263,7 +263,7 @@ | ||
18 | sinclude(TSRM/tsrm.m4) | ||
19 | |||
20 | |||
21 | -divert(2) | ||
22 | +divert(1002) | ||
23 | |||
24 | dnl ## Diversion 2 is where we set PHP-specific options and come up | ||
25 | dnl ## with reasonable default values for them. We check for pthreads here | ||
26 | @@ -302,7 +302,7 @@ | ||
27 | PTHREADS_FLAGS | ||
28 | fi | ||
29 | |||
30 | -divert(3) | ||
31 | +divert(1003) | ||
32 | |||
33 | dnl ## In diversion 3 we check for compile-time options to the PHP | ||
34 | dnl ## core and how to deal with different system dependencies. | ||
35 | @@ -661,7 +661,7 @@ | ||
36 | PHP_CRYPT_R_STYLE | ||
37 | fi | ||
38 | |||
39 | -divert(4) | ||
40 | +divert(1004) | ||
41 | |||
42 | dnl ## In diversion 4 we check user-configurable general settings. | ||
43 | |||
44 | @@ -902,7 +902,7 @@ | ||
45 | AC_MSG_RESULT([using system default]) | ||
46 | fi | ||
47 | |||
48 | -divert(5) | ||
49 | +divert(1005) | ||
50 | |||
51 | dnl ## In diversion 5 we check which extensions should be compiled. | ||
52 | dnl ## All of these are normally in the extension directories. | ||
53 | diff -ur php-5.2.10.org/ext/standard/config.m4 php-5.2.10/ext/standard/config.m4 | ||
54 | --- php-5.2.10.org/ext/standard/config.m4 2007-07-11 13:56:03.000000000 +0200 | ||
55 | +++ php-5.2.10/ext/standard/config.m4 2009-08-18 12:16:25.317640253 +0200 | ||
56 | @@ -1,6 +1,6 @@ | ||
57 | dnl $Id: config.m4,v 1.80.2.3.2.3 2007/07/11 11:56:03 jani Exp $ -*- autoconf -*- | ||
58 | |||
59 | -divert(3)dnl | ||
60 | +divert(1003)dnl | ||
61 | |||
62 | dnl | ||
63 | dnl Check if flush should be called explicitly after buffered io | ||
64 | @@ -205,7 +205,7 @@ | ||
65 | AC_CHECK_FUNCS(getcwd getwd asinh acosh atanh log1p hypot glob strfmon nice fpclass isinf isnan) | ||
66 | AC_FUNC_FNMATCH | ||
67 | |||
68 | -divert(5)dnl | ||
69 | +divert(1005)dnl | ||
70 | |||
71 | dnl | ||
72 | dnl Check for regex library type | ||
73 | diff -ur php-5.2.10.org/scripts/phpize.m4 php-5.2.10/scripts/phpize.m4 | ||
74 | --- php-5.2.10.org/scripts/phpize.m4 2009-06-02 21:54:22.000000000 +0200 | ||
75 | +++ php-5.2.10/scripts/phpize.m4 2009-08-18 12:16:25.317640253 +0200 | ||
76 | @@ -1,6 +1,6 @@ | ||
77 | dnl This file becomes configure.in for self-contained extensions. | ||
78 | |||
79 | -divert(1) | ||
80 | +divert(1001) | ||
81 | |||
82 | AC_PREREQ(2.13) | ||
83 | AC_INIT(config.m4) | ||
diff --git a/meta-oe/recipes-devtools/php/php/php_exec_native.patch b/meta-oe/recipes-devtools/php/php/php_exec_native.patch index a563c9a5e..31be1b70b 100644 --- a/meta-oe/recipes-devtools/php/php/php_exec_native.patch +++ b/meta-oe/recipes-devtools/php/php/php_exec_native.patch | |||
@@ -1,11 +1,19 @@ | |||
1 | --- php/configure.in.orig 2011-03-12 02:13:19.000000000 +0100 | 1 | --- |
2 | +++ php/configure.in 2011-03-12 02:14:05.000000000 +0100 | 2 | sapi/cli/config.m4 | 2 +- |
3 | @@ -1216,7 +1216,7 @@ | 3 | 1 file changed, 1 insertion(+), 1 deletion(-) |
4 | PHP_INSTALL_CLI_TARGET="install-cli" | 4 | |
5 | PHP_ADD_SOURCES(sapi/cli, php_cli.c php_cli_readline.c,, cli) | 5 | --- php-5.4.14.orig/sapi/cli/config.m4 |
6 | PHP_INSTALLED_SAPIS="cli $PHP_SAPI" | 6 | +++ php-5.4.14/sapi/cli/config.m4 |
7 | @@ -34,11 +34,11 @@ if test "$PHP_CLI" != "no"; then | ||
8 | BUILD_CLI="\$(LIBTOOL) --mode=link \$(CC) -export-dynamic \$(CFLAGS_CLEAN) \$(EXTRA_CFLAGS) \$(EXTRA_LDFLAGS_PROGRAM) \$(LDFLAGS) \$(PHP_RPATHS) \$(PHP_GLOBAL_OBJS) \$(PHP_BINARY_OBJS) \$(PHP_CLI_OBJS) \$(EXTRA_LIBS) \$(ZEND_EXTRA_LIBS) -o \$(SAPI_CLI_PATH)" | ||
9 | ;; | ||
10 | esac | ||
11 | |||
12 | dnl Set executable for tests | ||
7 | - PHP_EXECUTABLE="\$(top_builddir)/\$(SAPI_CLI_PATH)" | 13 | - PHP_EXECUTABLE="\$(top_builddir)/\$(SAPI_CLI_PATH)" |
8 | + PHP_EXECUTABLE="${PHP_NATIVE_DIR}/php" | 14 | + PHP_EXECUTABLE="${PHP_NATIVE_DIR}/php" |
9 | else | 15 | PHP_SUBST(PHP_EXECUTABLE) |
10 | PHP_INSTALLED_SAPIS="$PHP_SAPI" | 16 | |
11 | fi | 17 | dnl Expose to Makefile |
18 | PHP_SUBST(SAPI_CLI_PATH) | ||
19 | PHP_SUBST(BUILD_CLI) | ||
diff --git a/meta-oe/recipes-devtools/php/php_5.3.19.bb b/meta-oe/recipes-devtools/php/php_5.4.14.bb index 0ce811300..4e0efb1ed 100644 --- a/meta-oe/recipes-devtools/php/php_5.3.19.bb +++ b/meta-oe/recipes-devtools/php/php_5.4.14.bb | |||
@@ -5,7 +5,6 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=cb564efdf78cce8ea6e4b5a4f7c05d97" | |||
5 | PR = "${INC_PR}.0" | 5 | PR = "${INC_PR}.0" |
6 | 6 | ||
7 | SRC_URI += "file://acinclude-xml2-config.patch \ | 7 | SRC_URI += "file://acinclude-xml2-config.patch \ |
8 | file://php-m4-divert.patch \ | ||
9 | file://0001-php-don-t-use-broken-wrapper-for-mkdir.patch" | 8 | file://0001-php-don-t-use-broken-wrapper-for-mkdir.patch" |
10 | 9 | ||
11 | SRC_URI_append_pn-php += "file://iconv.patch \ | 10 | SRC_URI_append_pn-php += "file://iconv.patch \ |
@@ -18,5 +17,5 @@ SRC_URI_append_pn-php += "file://iconv.patch \ | |||
18 | file://php-fpm-apache.conf \ | 17 | file://php-fpm-apache.conf \ |
19 | " | 18 | " |
20 | 19 | ||
21 | SRC_URI[md5sum] = "e1d2a3ec7849d4b3032bd1abf1916aa4" | 20 | SRC_URI[md5sum] = "cfdc044be2c582991a1fe0967898fa38" |
22 | SRC_URI[sha256sum] = "814ce55b950158c4ddadbcd0b2d7d8cb4b570de4a29b9db021020594e2469fd6" | 21 | SRC_URI[sha256sum] = "5450f3843bc651eb3fb00601f0cce1930aaaf65c7c966c02fe4a46f9c81be20a" |