diff options
author | Huang Qiyu <huangqy.fnst@cn.fujitsu.com> | 2016-12-26 22:39:08 +0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-01-10 13:12:54 +0100 |
commit | c1ad61096eb2fc997061aa6b6cb2882837bd1d4e (patch) | |
tree | df89b107c1fefc8bf21b1f34e7e4a05cc5c8a1a9 /meta-oe/recipes-devtools/php | |
parent | cae9cafb9c536fd5ea40d1457c0ee1fcd6a6aa43 (diff) | |
download | meta-openembedded-c1ad61096eb2fc997061aa6b6cb2882837bd1d4e.tar.gz |
php: Add 7.1.0
1)Add php_7.1.0.bb
2)Delete php_5.5.38.bb,since it is replaced by php_5.6.26.bb.
3)Move pthread-check-threads-m4.patch out of 7.1.0, since it is integrated upstream.
Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/php')
-rw-r--r-- | meta-oe/recipes-devtools/php/php-7.1.0/change-AC_TRY_RUN-to-AC_TRY_LINK.patch | 56 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/php/php.inc | 1 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/php/php_5.5.38.bb | 6 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/php/php_5.6.26.bb | 4 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/php/php_7.1.0.bb | 14 |
5 files changed, 73 insertions, 8 deletions
diff --git a/meta-oe/recipes-devtools/php/php-7.1.0/change-AC_TRY_RUN-to-AC_TRY_LINK.patch b/meta-oe/recipes-devtools/php/php-7.1.0/change-AC_TRY_RUN-to-AC_TRY_LINK.patch new file mode 100644 index 000000000..39c334f39 --- /dev/null +++ b/meta-oe/recipes-devtools/php/php-7.1.0/change-AC_TRY_RUN-to-AC_TRY_LINK.patch | |||
@@ -0,0 +1,56 @@ | |||
1 | [PATCH] config.m4: change AC_TRY_RUN to AC_TRY_LINK | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | |||
5 | AC_TRY_RUN is not suitable for cross-compile | ||
6 | |||
7 | Signed-off-by: Roy Li <rongqing.li@windriver.com> | ||
8 | --- | ||
9 | ext/fileinfo/config.m4 | 31 ++++++------------------------- | ||
10 | 1 file changed, 6 insertions(+), 25 deletions(-) | ||
11 | |||
12 | diff --git a/ext/fileinfo/config.m4 b/ext/fileinfo/config.m4 | ||
13 | index 7e98d62..8a8ea0e 100644 | ||
14 | --- a/ext/fileinfo/config.m4 | ||
15 | +++ b/ext/fileinfo/config.m4 | ||
16 | @@ -14,31 +14,12 @@ if test "$PHP_FILEINFO" != "no"; then | ||
17 | libmagic/readcdf.c libmagic/softmagic.c" | ||
18 | |||
19 | AC_MSG_CHECKING([for strcasestr]) | ||
20 | - AC_TRY_RUN([ | ||
21 | -#include <string.h> | ||
22 | -#include <strings.h> | ||
23 | -#include <stdlib.h> | ||
24 | - | ||
25 | -int main(void) | ||
26 | -{ | ||
27 | - char *s0, *s1, *ret; | ||
28 | - | ||
29 | - s0 = (char *) malloc(42); | ||
30 | - s1 = (char *) malloc(8); | ||
31 | - | ||
32 | - memset(s0, 'X', 42); | ||
33 | - s0[24] = 'Y'; | ||
34 | - s0[26] = 'Z'; | ||
35 | - s0[41] = '\0'; | ||
36 | - memset(s1, 'x', 8); | ||
37 | - s1[0] = 'y'; | ||
38 | - s1[2] = 'Z'; | ||
39 | - s1[7] = '\0'; | ||
40 | - | ||
41 | - ret = strcasestr(s0, s1); | ||
42 | - | ||
43 | - return !(NULL != ret); | ||
44 | -} | ||
45 | + AC_TRY_COMPILE([ | ||
46 | + #include <string.h> | ||
47 | + #include <strings.h> | ||
48 | + #include <stdlib.h> | ||
49 | + ],[ | ||
50 | + strcasestr(NULL, NULL); | ||
51 | ],[ | ||
52 | dnl using the platform implementation | ||
53 | AC_MSG_RESULT(yes) | ||
54 | -- | ||
55 | 1.9.1 | ||
56 | |||
diff --git a/meta-oe/recipes-devtools/php/php.inc b/meta-oe/recipes-devtools/php/php.inc index cd919403e..c4fb1d90b 100644 --- a/meta-oe/recipes-devtools/php/php.inc +++ b/meta-oe/recipes-devtools/php/php.inc | |||
@@ -24,7 +24,6 @@ SRC_URI_append_class-target = " \ | |||
24 | file://php-fpm.conf \ | 24 | file://php-fpm.conf \ |
25 | file://php-fpm-apache.conf \ | 25 | file://php-fpm-apache.conf \ |
26 | file://configure.patch \ | 26 | file://configure.patch \ |
27 | file://pthread-check-threads-m4.patch \ | ||
28 | file://70_mod_php5.conf \ | 27 | file://70_mod_php5.conf \ |
29 | file://php-fpm.service \ | 28 | file://php-fpm.service \ |
30 | " | 29 | " |
diff --git a/meta-oe/recipes-devtools/php/php_5.5.38.bb b/meta-oe/recipes-devtools/php/php_5.5.38.bb deleted file mode 100644 index 26f35b1c1..000000000 --- a/meta-oe/recipes-devtools/php/php_5.5.38.bb +++ /dev/null | |||
@@ -1,6 +0,0 @@ | |||
1 | require php.inc | ||
2 | |||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=464ca70af214d2407f6b7d4458158afd" | ||
4 | |||
5 | SRC_URI[md5sum] = "312244a0eecad602a1555ed2434e223f" | ||
6 | SRC_URI[sha256sum] = "473c81ebb2e48ca468caee031762266651843d7227c18a824add9b07b9393e38" | ||
diff --git a/meta-oe/recipes-devtools/php/php_5.6.26.bb b/meta-oe/recipes-devtools/php/php_5.6.26.bb index cbd0615d6..ddc7ce3c3 100644 --- a/meta-oe/recipes-devtools/php/php_5.6.26.bb +++ b/meta-oe/recipes-devtools/php/php_5.6.26.bb | |||
@@ -2,6 +2,8 @@ require php.inc | |||
2 | 2 | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b602636d46a61c0ac0432bbf5c078fe4" | 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b602636d46a61c0ac0432bbf5c078fe4" |
4 | 4 | ||
5 | SRC_URI += "file://change-AC_TRY_RUN-to-AC_TRY_LINK.patch" | 5 | SRC_URI += "file://change-AC_TRY_RUN-to-AC_TRY_LINK.patch \ |
6 | file://pthread-check-threads-m4.patch \ | ||
7 | " | ||
6 | SRC_URI[md5sum] = "cb424b705cfb715fc04f499f8a8cf52e" | 8 | SRC_URI[md5sum] = "cb424b705cfb715fc04f499f8a8cf52e" |
7 | SRC_URI[sha256sum] = "d47aab8083a4284b905777e1b45dd7735adc53be827b29f896684750ac8b6236" | 9 | SRC_URI[sha256sum] = "d47aab8083a4284b905777e1b45dd7735adc53be827b29f896684750ac8b6236" |
diff --git a/meta-oe/recipes-devtools/php/php_7.1.0.bb b/meta-oe/recipes-devtools/php/php_7.1.0.bb new file mode 100644 index 000000000..210d91fd7 --- /dev/null +++ b/meta-oe/recipes-devtools/php/php_7.1.0.bb | |||
@@ -0,0 +1,14 @@ | |||
1 | require php.inc | ||
2 | |||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b602636d46a61c0ac0432bbf5c078fe4" | ||
4 | |||
5 | SRC_URI += "file://change-AC_TRY_RUN-to-AC_TRY_LINK.patch" | ||
6 | SRC_URI[md5sum] = "54e364b60a88db77adb96aacb10f10a4" | ||
7 | SRC_URI[sha256sum] = "68bcfd7deed5b3474d81dec9f74d122058327e2bed0ac25bbc9ec70995228e61" | ||
8 | |||
9 | PACKAGECONFIG[mysql] = "--with-mysqli=${STAGING_BINDIR_CROSS}/mysql_config \ | ||
10 | --with-pdo-mysql=${STAGING_BINDIR_CROSS}/mysql_config \ | ||
11 | ,--without-mysqli --without-pdo-mysql \ | ||
12 | ,mysql5" | ||
13 | |||
14 | FILES_${PN}-fpm += "${sysconfdir}/php-fpm.d/www.conf.default" | ||