diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-11-11 08:32:58 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-11-13 01:17:18 -0800 |
commit | ce3a46e874bebbe3b67d9d1fa1246622c7508c46 (patch) | |
tree | eef6daa9f06a04267830990edb9ab2915f95ff4b /meta-oe/recipes-devtools/php | |
parent | 7175f8b66980cad3299a2ff9001691af0015e5c0 (diff) | |
download | meta-openembedded-ce3a46e874bebbe3b67d9d1fa1246622c7508c46.tar.gz |
php: Build minilua for build host
see https://bugs.php.net/bug.php?id=80717&edit=1
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/php')
3 files changed, 22 insertions, 35 deletions
diff --git a/meta-oe/recipes-devtools/php/php/0011-opcache-jit-use-minilua-in-sysroot.patch b/meta-oe/recipes-devtools/php/php/0011-opcache-jit-use-minilua-in-sysroot.patch deleted file mode 100644 index 2ba0f2b77..000000000 --- a/meta-oe/recipes-devtools/php/php/0011-opcache-jit-use-minilua-in-sysroot.patch +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | From aaa6a81cfb20f9b3c25aa22e5a472c0f2867f72c Mon Sep 17 00:00:00 2001 | ||
2 | From: Claude Bing <cbing@cybernetics.com> | ||
3 | Date: Tue, 9 Nov 2021 13:11:42 -0500 | ||
4 | Subject: [PATCH 11/11] opcache/jit: use minilua in sysroot | ||
5 | |||
6 | Signed-off-by: Claude Bing <cbing@cybernetics.com> | ||
7 | --- | ||
8 | ext/opcache/jit/Makefile.frag | 7 ++----- | ||
9 | 1 file changed, 2 insertions(+), 5 deletions(-) | ||
10 | |||
11 | diff --git a/ext/opcache/jit/Makefile.frag b/ext/opcache/jit/Makefile.frag | ||
12 | index b3af5b290a..f2e737e463 100644 | ||
13 | --- a/ext/opcache/jit/Makefile.frag | ||
14 | +++ b/ext/opcache/jit/Makefile.frag | ||
15 | @@ -1,9 +1,6 @@ | ||
16 | |||
17 | -$(builddir)/minilua: $(srcdir)/jit/dynasm/minilua.c | ||
18 | - $(CC) $(srcdir)/jit/dynasm/minilua.c -lm -o $@ | ||
19 | - | ||
20 | -$(builddir)/jit/zend_jit_x86.c: $(srcdir)/jit/zend_jit_x86.dasc $(srcdir)/jit/dynasm/*.lua $(builddir)/minilua | ||
21 | - $(builddir)/minilua $(srcdir)/jit/dynasm/dynasm.lua $(DASM_FLAGS) -o $@ $(srcdir)/jit/zend_jit_x86.dasc | ||
22 | +$(builddir)/jit/zend_jit_x86.c: $(srcdir)/jit/zend_jit_x86.dasc $(srcdir)/jit/dynasm/*.lua | ||
23 | + @minilua $(srcdir)/jit/dynasm/dynasm.lua $(DASM_FLAGS) -o $@ $(srcdir)/jit/zend_jit_x86.dasc | ||
24 | |||
25 | $(builddir)/jit/zend_jit.lo: \ | ||
26 | $(builddir)/jit/zend_jit_x86.c \ | ||
27 | -- | ||
28 | 2.25.1 | ||
29 | |||
diff --git a/meta-oe/recipes-devtools/php/php/1010-Fix-opcache-jit-minilua-compiling.patch b/meta-oe/recipes-devtools/php/php/1010-Fix-opcache-jit-minilua-compiling.patch new file mode 100644 index 000000000..6f134fabb --- /dev/null +++ b/meta-oe/recipes-devtools/php/php/1010-Fix-opcache-jit-minilua-compiling.patch | |||
@@ -0,0 +1,20 @@ | |||
1 | From 73ea1d44c1e6b063bfa02e12919ec8a9de3709d8 Mon Sep 17 00:00:00 2001 | ||
2 | From: Michael Heimpold <mhei@heimpold.de> | ||
3 | Date: Wed, 3 Feb 2021 22:51:34 +0100 | ||
4 | Subject: [PATCH] Fix opcache jit minilua compiling | ||
5 | |||
6 | Signed-off-by: Michael Heimpold <mhei@heimpold.de> | ||
7 | --- | ||
8 | ext/opcache/jit/Makefile.frag | 2 +- | ||
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
10 | |||
11 | --- a/ext/opcache/jit/Makefile.frag | ||
12 | +++ b/ext/opcache/jit/Makefile.frag | ||
13 | @@ -1,6 +1,6 @@ | ||
14 | |||
15 | $(builddir)/minilua: $(srcdir)/jit/dynasm/minilua.c | ||
16 | - $(CC) $(srcdir)/jit/dynasm/minilua.c -lm -o $@ | ||
17 | + $(HOSTCC) $(srcdir)/jit/dynasm/minilua.c -lm -o $@ | ||
18 | |||
19 | $(builddir)/jit/zend_jit_x86.c: $(srcdir)/jit/zend_jit_x86.dasc $(srcdir)/jit/dynasm/*.lua $(builddir)/minilua | ||
20 | $(builddir)/minilua $(srcdir)/jit/dynasm/dynasm.lua $(DASM_FLAGS) -o $@ $(srcdir)/jit/zend_jit_x86.dasc | ||
diff --git a/meta-oe/recipes-devtools/php/php_8.0.12.bb b/meta-oe/recipes-devtools/php/php_8.0.12.bb index 300499de5..8d24c187e 100644 --- a/meta-oe/recipes-devtools/php/php_8.0.12.bb +++ b/meta-oe/recipes-devtools/php/php_8.0.12.bb | |||
@@ -25,7 +25,7 @@ SRC_URI:append:class-target = " \ | |||
25 | file://0006-ext-phar-Makefile.frag-Fix-phar-packaging.patch \ | 25 | file://0006-ext-phar-Makefile.frag-Fix-phar-packaging.patch \ |
26 | file://0007-sapi-cli-config.m4-fix-build-directory.patch \ | 26 | file://0007-sapi-cli-config.m4-fix-build-directory.patch \ |
27 | file://0008-ext-imap-config.m4-fix-include-paths.patch \ | 27 | file://0008-ext-imap-config.m4-fix-include-paths.patch \ |
28 | file://0011-opcache-jit-use-minilua-in-sysroot.patch \ | 28 | file://1010-Fix-opcache-jit-minilua-compiling.patch \ |
29 | file://php-fpm.conf \ | 29 | file://php-fpm.conf \ |
30 | file://php-fpm-apache.conf \ | 30 | file://php-fpm-apache.conf \ |
31 | file://70_mod_php${PHP_MAJOR_VERSION}.conf \ | 31 | file://70_mod_php${PHP_MAJOR_VERSION}.conf \ |
@@ -108,6 +108,7 @@ PACKAGECONFIG[valgrind] = "--with-valgrind=${STAGING_DIR_TARGET}/usr,--with-valg | |||
108 | PACKAGECONFIG[mbregex] = "--enable-mbregex, --disable-mbregex, oniguruma" | 108 | PACKAGECONFIG[mbregex] = "--enable-mbregex, --disable-mbregex, oniguruma" |
109 | PACKAGECONFIG[mbstring] = "--enable-mbstring,," | 109 | PACKAGECONFIG[mbstring] = "--enable-mbstring,," |
110 | 110 | ||
111 | export HOSTCC = "${BUILD_CC}" | ||
111 | export PHP_NATIVE_DIR = "${STAGING_BINDIR_NATIVE}" | 112 | export PHP_NATIVE_DIR = "${STAGING_BINDIR_NATIVE}" |
112 | export PHP_PEAR_PHP_BIN = "${STAGING_BINDIR_NATIVE}/php" | 113 | export PHP_PEAR_PHP_BIN = "${STAGING_BINDIR_NATIVE}/php" |
113 | CFLAGS += " -D_GNU_SOURCE -g -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED -I${STAGING_INCDIR}/apache2" | 114 | CFLAGS += " -D_GNU_SOURCE -g -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED -I${STAGING_INCDIR}/apache2" |
@@ -258,13 +259,8 @@ RCONFLICTS:${PN}-modphp = "${MODPHP_OLDPACKAGE}" | |||
258 | do_install:append:class-native() { | 259 | do_install:append:class-native() { |
259 | create_wrapper ${D}${bindir}/php \ | 260 | create_wrapper ${D}${bindir}/php \ |
260 | PHP_PEAR_SYSCONF_DIR=${sysconfdir}/ | 261 | PHP_PEAR_SYSCONF_DIR=${sysconfdir}/ |
261 | |||
262 | if [ "$MACHINE_ARCH" == "x86" || "$MACHINE_ARCH" == "x86-64" ]; then | ||
263 | install -m 0755 ${WORKDIR}/build/ext/opcache/minilua ${D}${bindir}/ | ||
264 | fi | ||
265 | } | 262 | } |
266 | 263 | ||
267 | |||
268 | # Fails to build with thumb-1 (qemuarm) | 264 | # Fails to build with thumb-1 (qemuarm) |
269 | # | {standard input}: Assembler messages: | 265 | # | {standard input}: Assembler messages: |
270 | # | {standard input}:3719: Error: selected processor does not support Thumb mode `smull r0,r2,r9,r3' | 266 | # | {standard input}:3719: Error: selected processor does not support Thumb mode `smull r0,r2,r9,r3' |