diff options
author | Wang Mingyu <wangmy@fujitsu.com> | 2023-07-18 12:25:22 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-07-20 19:08:57 -0700 |
commit | 98f9c81f1e7f9e37125c790baedd2f68af7bb95a (patch) | |
tree | acfdfefba3bd03f6d00a21488c274da636023c58 /meta-oe/recipes-devtools/php | |
parent | 99d6fd5c0f5bd7313592d1781d7762f0796f433b (diff) | |
download | meta-openembedded-98f9c81f1e7f9e37125c790baedd2f68af7bb95a.tar.gz |
php: upgrade 8.2.7 -> 8.2.8
Changelog:
==========
- CLI:
. Fixed bug GH-11246 (cli/get_set_process_title fails on MacOS).
- Core:
. Fixed build for the riscv64 architecture/GCC 12.
- Curl:
. Fixed bug GH-11433 (Unable to set CURLOPT_ACCEPT_ENCODING to NULL).
- Date:
. Fixed bug GH-11455 (Segmentation fault with custom object date properties).
- DOM:
. Fixed bugs GH-11288 and GH-11289 and GH-11290 and GH-9142 (DOMExceptions
and segfaults with replaceWith).
. Fixed bug GH-10234 (Setting DOMAttr::textContent results in an empty
attribute value).
. Fix return value in stub file for DOMNodeList::item.
. Fix spec compliance error with '*' namespace for
DOMDocument::getElementsByTagNameNS.
. Fix DOMElement::append() and DOMElement::prepend() hierarchy checks.
. Fixed bug GH-11347 (Memory leak when calling a static method inside an
xpath query).
. Fixed bug #67440 (append_node of a DOMDocumentFragment does not reconcile
namespaces).
. Fixed bug #81642 (DOMChildNode::replaceWith() bug when replacing a node
with itself).
. Fixed bug #77686 (Removed elements are still returned by getElementById).
. Fixed bug #70359 (print_r() on DOMAttr causes Segfault in
php_libxml_node_free_list()).
. Fixed bug #78577 (Crash in DOMNameSpace debug info handlers).
. Fix lifetime issue with getAttributeNodeNS().
. Fix "invalid state error" with cloned namespace declarations.
. Fixed bug #55294 and #47530 and #47847 (various namespace reconciliation
issues).
. Fixed bug #80332 (Completely broken array access functionality with
DOMNamedNodeMap).
- Opcache:
. Fix allocation loop in zend_shared_alloc_startup().
. Access violation on smm_shared_globals with ALLOC_FALLBACK.
. Fixed bug GH-11336 (php still tries to unlock the shared memory ZendSem
with opcache.file_cache_only=1 but it was never locked).
- OpenSSL:
. Fixed bug GH-9356 Incomplete validation of IPv6 Address fields in
subjectAltNames
- PCRE:
. Fix preg_replace_callback_array() pattern validation.
- PGSQL:
. Fixed intermittent segfault with pg_trace.
- Phar:
. Fix cross-compilation check in phar generation for FreeBSD.
- SPL:
. Fixed bug GH-11338 (SplFileInfo empty getBasename with more than one
slash).
- Standard:
. Fix access on NULL pointer in array_merge_recursive().
. Fix exception handling in array_multisort().
- SQLite3:
. Fixed bug GH-11451 (Invalid associative array containing duplicate
keys).
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/php')
-rw-r--r-- | meta-oe/recipes-devtools/php/php_8.2.8.bb (renamed from meta-oe/recipes-devtools/php/php_8.2.7.bb) | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/php/php_8.2.7.bb b/meta-oe/recipes-devtools/php/php_8.2.8.bb index 4dc0399b5..08d041d77 100644 --- a/meta-oe/recipes-devtools/php/php_8.2.7.bb +++ b/meta-oe/recipes-devtools/php/php_8.2.8.bb | |||
@@ -34,7 +34,7 @@ SRC_URI:append:class-target = " \ | |||
34 | " | 34 | " |
35 | 35 | ||
36 | S = "${WORKDIR}/php-${PV}" | 36 | S = "${WORKDIR}/php-${PV}" |
37 | SRC_URI[sha256sum] = "5bfb2a35c67921bdcadd5c90cb290ad7537d24da113a5e8bc2d646b02de7488f" | 37 | SRC_URI[sha256sum] = "995ed4009c7917c962d31837a1a3658f36d4af4f357b673c97ffdbe6403f8517" |
38 | 38 | ||
39 | CVE_CHECK_IGNORE += "\ | 39 | CVE_CHECK_IGNORE += "\ |
40 | CVE-2007-2728 \ | 40 | CVE-2007-2728 \ |