diff options
author | Wang Mingyu <wangmy@fujitsu.com> | 2023-08-24 16:09:45 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-08-26 17:32:44 -0700 |
commit | 739e880b21eb5c558e098eb9fe02e3dbaef37d65 (patch) | |
tree | b4f563901938622e8d54775e0ff382371a86c974 /meta-oe/recipes-devtools/php | |
parent | cfa06f76818ed2a6d1b6db30b3224075269ea739 (diff) | |
download | meta-openembedded-739e880b21eb5c558e098eb9fe02e3dbaef37d65.tar.gz |
php: upgrade 8.2.8 -> 8.2.9
Changelog:
===========
- Build:
. Fixed bug GH-11522 (PHP version check fails with '-' separator).
- CLI:
. Fix interrupted CLI output causing the process to exit.
- Core:
. Fixed oss-fuzz #60011 (Mis-compilation of by-reference nullsafe operator).
. Fixed line number of JMP instruction over else block.
. Fixed use-of-uninitialized-value with ??= on assert.
. Fixed oss-fuzz #60411 (Fix double-compilation of arrow-functions).
. Fixed build for FreeBSD before the 11.0 releases.
- Curl:
. Fix crash when an invalid callback function is passed to
CURLMOPT_PUSHFUNCTION.
- Date:
. Fixed bug GH-11368 (Date modify returns invalid datetime).
. Fixed bug GH-11600 (Can't parse time strings which include
non-breaking space characters).
. Fixed bug GH-11854 (DateTime:createFromFormat stopped parsing datetime with
extra space).
- DOM:
. Fixed bug GH-11625 (DOMElement::replaceWith() doesn't replace node with
DOMDocumentFragment but just deletes node or causes wrapping <></>
depending on libxml2 version).
- Fileinfo:
. Fixed bug GH-11298 (finfo returns wrong mime type for xz files).
- FTP:
. Fix context option check for "overwrite".
. Fixed bug GH-10562 (Memory leak and invalid state with consecutive
ftp_nb_fget).
- GD:
. Fix most of the external libgd test failures.
- Intl:
. Fix memory leak in MessageFormatter::format() on failure.
- Libxml:
. Fixed bug GHSA-3qrf-m4j2-pcrr (Security issue with external entity loading
in XML without enabling it). (CVE-2023-3823)
- MBString:
. Fix GH-11300 (license issue: restricted unicode license headers).
- Opcache:
. Fixed bug GH-10914 (OPCache with Enum and Callback functions results in
segmentation fault).
. Prevent potential deadlock if accelerated globals cannot be allocated.
- PCNTL:
. Fixed bug GH-11498 (SIGCHLD is not always returned from proc_open).
- PDO:
. Fix GH-11587 (After php8.1, when PDO::ATTR_EMULATE_PREPARES is true
and PDO::ATTR_STRINGIFY_FETCHES is true, decimal zeros are no longer
filled).
- PDO SQLite:
. Fix GH-11492 (Make test failure: ext/pdo_sqlite/tests/bug_42589.phpt).
- Phar:
. Add missing check on EVP_VerifyUpdate() in phar util.
. Fixed bug GHSA-jqcx-ccgc-xwhv (Buffer mismanagement in phar_dir_read()).
- PHPDBG:
. Fixed bug GH-9669 (phpdbg -h options doesn't list the -z option).
- Session:
. Removed broken url support for transferring session ID.
- Standard:
. Fix serialization of RC1 objects appearing in object graph twice.
- Streams:
. Fixed bug GH-11735 (Use-after-free when unregistering user stream wrapper
from itself).
- SQLite3:
. Fix replaced error handling in SQLite3Stmt::__construct.
- XMLReader:
. Fix GH-11548 (Argument corruption when calling XMLReader::open or
XMLReader::XML non-statically with observer active).
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/php')
-rw-r--r-- | meta-oe/recipes-devtools/php/php_8.2.9.bb (renamed from meta-oe/recipes-devtools/php/php_8.2.8.bb) | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/php/php_8.2.8.bb b/meta-oe/recipes-devtools/php/php_8.2.9.bb index 407b1a7bc..27d3be1b0 100644 --- a/meta-oe/recipes-devtools/php/php_8.2.8.bb +++ b/meta-oe/recipes-devtools/php/php_8.2.9.bb | |||
@@ -34,7 +34,7 @@ SRC_URI:append:class-target = " \ | |||
34 | " | 34 | " |
35 | 35 | ||
36 | S = "${WORKDIR}/php-${PV}" | 36 | S = "${WORKDIR}/php-${PV}" |
37 | SRC_URI[sha256sum] = "995ed4009c7917c962d31837a1a3658f36d4af4f357b673c97ffdbe6403f8517" | 37 | SRC_URI[sha256sum] = "48460b994ae7eb5096a310f44d13e865de1771104d4a550d53072be58a6f176c" |
38 | 38 | ||
39 | CVE_STATUS_GROUPS += "CVE_STATUS_PHP" | 39 | CVE_STATUS_GROUPS += "CVE_STATUS_PHP" |
40 | CVE_STATUS_PHP[status] = "fixed-version: The name of this product is exactly the same as github.com/emlog/emlog. CVE can be safely ignored." | 40 | CVE_STATUS_PHP[status] = "fixed-version: The name of this product is exactly the same as github.com/emlog/emlog. CVE can be safely ignored." |