summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/perl
diff options
context:
space:
mode:
authorQian Lei <qianl.fnst@cn.fujitsu.com>2014-12-16 11:00:04 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-12-19 20:10:57 +0100
commit71e0dbf975c546b9e3dfcc72ab0ef91f9a956e53 (patch)
treee4fb99781ce614e84dbcde06578c3923edbcfc73 /meta-oe/recipes-devtools/perl
parent4a8fc6c6e179aa6abd9839e31945a8cbb1a441c2 (diff)
downloadmeta-openembedded-71e0dbf975c546b9e3dfcc72ab0ef91f9a956e53.tar.gz
ipc-run: Add new recipe
IPC::Run allows you run and interact with child processes using files, pipes, and pseudo-ttys. Both system()-style and scripted usages are supported and may be mixed. Likewise, functional and OO API styles are both supported and may be mixed. Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/perl')
-rw-r--r--meta-oe/recipes-devtools/perl/ipc-run_0.94.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/perl/ipc-run_0.94.bb b/meta-oe/recipes-devtools/perl/ipc-run_0.94.bb
new file mode 100644
index 000000000..66054a257
--- /dev/null
+++ b/meta-oe/recipes-devtools/perl/ipc-run_0.94.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "\
2IPC::Run allows you run and interact with child processes \
3using files, pipes, and pseudo-ttys. Both system()-style and scripted \
4usages are supported and may be mixed. Likewise, functional and OO API \
5styles are both supported and may be mixed."
6SECTION = "libs"
7LICENSE = "Artistic-1.0 | GPL-1.0+"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=0ebd37caf53781e8b7223e6b99b63f4e"
9DEPENDS = "perl"
10
11SRC_URI = "git://github.com/toddr/IPC-Run.git"
12SRCREV = "6bdf41e276e06d23e140783b13a6eaef4745c216"
13
14S = "${WORKDIR}/git"
15
16inherit cpan
17
18EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
19
20do_compile() {
21 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
22 cpan_do_compile
23}