summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/packagegroups/packagegroup-sdk-target.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-09-04 14:11:58 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2012-09-05 10:05:06 +0200
commit21a4be0e36bb1ee6c3c469c83a623c5d9a45257a (patch)
treebe14375786b4756c8c9d62020cc99a8b2da808fa /meta-oe/recipes-devtools/packagegroups/packagegroup-sdk-target.bb
parentf3dbc97b44a5dd2588eb0c6ed7e3ce1b1e997847 (diff)
downloadmeta-openembedded-21a4be0e36bb1ee6c3c469c83a623c5d9a45257a.tar.gz
task*: rename to packagegroup to match oe-core
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/packagegroups/packagegroup-sdk-target.bb')
-rw-r--r--meta-oe/recipes-devtools/packagegroups/packagegroup-sdk-target.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/packagegroups/packagegroup-sdk-target.bb b/meta-oe/recipes-devtools/packagegroups/packagegroup-sdk-target.bb
new file mode 100644
index 000000000..3ad9b5557
--- /dev/null
+++ b/meta-oe/recipes-devtools/packagegroups/packagegroup-sdk-target.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "Packages required for a target (on-device) SDK"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
4
5inherit packagegroup allarch
6
7RPROVIDES_${PN} = "packagegroup-native-sdk"
8RDEPENDS_${PN} = "gcc-symlinks g++-symlinks cpp cpp-symlinks \
9 binutils-symlinks \
10 perl-modules \
11 flex flex-dev \
12 bison \
13 gawk \
14 sed \
15 grep \
16 autoconf automake \
17 make \
18 patch diffstat diffutils \
19 libstdc++-dev \
20 libtool libtool-dev libltdl-dev \
21 pkgconfig"
22
23# usefull, but not in oe-core/meta-oe yet: patchutils
24RRECOMMENDS_${PN} = " g77-symlinks gfortran-symlinks"