summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/openocd
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-05-31 21:50:52 -0700
committerKhem Raj <raj.khem@gmail.com>2018-05-31 21:53:52 -0700
commit5500ca6a45f10deb2f5d736ba7c0ae9ed6ed08a5 (patch)
tree9cad33260bf090d99b1b4a1a56aa8edd687271c6 /meta-oe/recipes-devtools/openocd
parent24c24fba961e4d231bd5d7a233e11a06c41a8053 (diff)
downloadmeta-openembedded-5500ca6a45f10deb2f5d736ba7c0ae9ed6ed08a5.tar.gz
openocd: Upgrade to latest tip of master
Fix build with new libusb and gcc8 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/openocd')
-rw-r--r--meta-oe/recipes-devtools/openocd/openocd/0001-Fix-libusb-1.0.22-deprecated-libusb_set_debug-with-l.patch39
-rw-r--r--meta-oe/recipes-devtools/openocd/openocd_git.bb5
2 files changed, 42 insertions, 2 deletions
diff --git a/meta-oe/recipes-devtools/openocd/openocd/0001-Fix-libusb-1.0.22-deprecated-libusb_set_debug-with-l.patch b/meta-oe/recipes-devtools/openocd/openocd/0001-Fix-libusb-1.0.22-deprecated-libusb_set_debug-with-l.patch
new file mode 100644
index 000000000..c5b9083dc
--- /dev/null
+++ b/meta-oe/recipes-devtools/openocd/openocd/0001-Fix-libusb-1.0.22-deprecated-libusb_set_debug-with-l.patch
@@ -0,0 +1,39 @@
1From b95a996bfb281104b68ec66f32ebb79db519a4a8 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 31 May 2018 21:06:46 -0700
4Subject: [PATCH] Fix libusb-1.0.22 deprecated libusb_set_debug with
5 libusb_set_option
6
7libusb_set_debug is deprecated in libusb >= 1.0.22 therefore replace
8with equivalent libusb_set_option() API
9
10see libusb commit for more details
11
12https://github.com/libusb/libusb/commit/539f22e2fd916558d11ab9a66f10f461c5593168
13
14Signed-off-by: Khem Raj <raj.khem@gmail.com>
15---
16Upstream-Status: Submitted [http://openocd.zylin.com/#/c/4540/]
17 src/jtag/drivers/xds110.c | 5 ++++-
18 1 file changed, 4 insertions(+), 1 deletion(-)
19
20diff --git a/src/jtag/drivers/xds110.c b/src/jtag/drivers/xds110.c
21index 90b699027..9bfe02ea8 100644
22--- a/src/jtag/drivers/xds110.c
23+++ b/src/jtag/drivers/xds110.c
24@@ -367,8 +367,11 @@ static bool usb_connect(void)
25
26 /* Set libusb to auto detach kernel and disable debug messages */
27 (void)libusb_set_auto_detach_kernel_driver(dev, 1);
28+#if LIBUSB_API_VERSION >= 0x01000106
29+ libusb_set_option(ctx, LIBUSB_OPTION_LOG_LEVEL, LIBUSB_LOG_LEVEL_NONE);
30+#else
31 libusb_set_debug(ctx, LIBUSB_LOG_LEVEL_NONE);
32-
33+#endif
34 /* Claim the debug interface on the XDS110 */
35 result = libusb_claim_interface(dev, INTERFACE_DEBUG);
36 } else {
37--
382.17.1
39
diff --git a/meta-oe/recipes-devtools/openocd/openocd_git.bb b/meta-oe/recipes-devtools/openocd/openocd_git.bb
index 67abeede9..84727bf97 100644
--- a/meta-oe/recipes-devtools/openocd/openocd_git.bb
+++ b/meta-oe/recipes-devtools/openocd/openocd_git.bb
@@ -5,8 +5,9 @@ DEPENDS = "libusb-compat libftdi"
5RDEPENDS_${PN} = "libusb1" 5RDEPENDS_${PN} = "libusb1"
6 6
7SRC_URI = "git://repo.or.cz/openocd.git \ 7SRC_URI = "git://repo.or.cz/openocd.git \
8" 8 file://0001-Fix-libusb-1.0.22-deprecated-libusb_set_debug-with-l.patch \
9SRCREV = "3737dd69e73816d186ba418d7b833462a8041079" 9 "
10SRCREV = "cdf1e826eb23c29de1019ce64125f644f01b0afe"
10 11
11PV = "0.10+gitr${SRCPV}" 12PV = "0.10+gitr${SRCPV}"
12S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"